aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ixp4xx
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-30 03:05:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-30 03:05:50 +0000
commit9f00cacbccf02db56cb4e134a8dcecb6d13205d9 (patch)
tree1a7ea5199565885e67fbd4a5cbc211847bdcd0f8 /packages/ixp4xx
parentf0c27346be9b14f69a4fd1424db329d58a505ce7 (diff)
downloadopenembedded-9f00cacbccf02db56cb4e134a8dcecb6d13205d9.tar.gz
linux: fix missing HOST_CC_ARCH in module compilation in kernel/module all
- define TARGET_KERNEL_CC_ARCH to define arch specific compiler options in machine.conf. The default for the kernel is "" (empty), although it should probably be TARGET_CC_ARCH in the future. The default for modules is TARGET_CC_ARCH
Diffstat (limited to 'packages/ixp4xx')
-rw-r--r--packages/ixp4xx/ixp-osal_1.5.bb6
-rw-r--r--packages/ixp4xx/ixp-osal_2.0.bb6
-rw-r--r--packages/ixp4xx/ixp-osal_2.1.bb6
-rw-r--r--packages/ixp4xx/ixp4xx-csr_1.4.bb6
-rw-r--r--packages/ixp4xx/ixp4xx-csr_1.5.bb6
-rw-r--r--packages/ixp4xx/ixp4xx-csr_2.0.bb6
-rw-r--r--packages/ixp4xx/ixp4xx-csr_2.1.bb6
7 files changed, 0 insertions, 42 deletions
diff --git a/packages/ixp4xx/ixp-osal_1.5.bb b/packages/ixp4xx/ixp-osal_1.5.bb
index c0e0cb930c..66cf9e6b06 100644
--- a/packages/ixp4xx/ixp-osal_1.5.bb
+++ b/packages/ixp4xx/ixp-osal_1.5.bb
@@ -27,12 +27,6 @@ COMPATIBLE_HOST = "^armeb-linux.*"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
EXTRA_OEMAKE = "'CC=${KERNEL_CC}' \
'LD=${KERNEL_LD}' \
'AR=${AR}' \
diff --git a/packages/ixp4xx/ixp-osal_2.0.bb b/packages/ixp4xx/ixp-osal_2.0.bb
index c5ddf66bef..84929d5cb5 100644
--- a/packages/ixp4xx/ixp-osal_2.0.bb
+++ b/packages/ixp4xx/ixp-osal_2.0.bb
@@ -33,12 +33,6 @@ COMPATIBLE_HOST = "^arm.*-linux.*"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
IX_TARGET = "linux${ARCH_BYTE_SEX}"
EXTRA_OEMAKE = "'CC=${KERNEL_CC}' \
diff --git a/packages/ixp4xx/ixp-osal_2.1.bb b/packages/ixp4xx/ixp-osal_2.1.bb
index 4fca2c3a1e..48d4355648 100644
--- a/packages/ixp4xx/ixp-osal_2.1.bb
+++ b/packages/ixp4xx/ixp-osal_2.1.bb
@@ -37,12 +37,6 @@ COMPATIBLE_HOST = "^arm.*-linux.*"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
IX_TARGET = "linux${ARCH_BYTE_SEX}"
IX_ENSURE = ""
#IX_ENSURE = "IX_OSAL_ENSURE_ON=1"
diff --git a/packages/ixp4xx/ixp4xx-csr_1.4.bb b/packages/ixp4xx/ixp4xx-csr_1.4.bb
index 788d303c67..7146d9e402 100644
--- a/packages/ixp4xx/ixp4xx-csr_1.4.bb
+++ b/packages/ixp4xx/ixp4xx-csr_1.4.bb
@@ -31,12 +31,6 @@ COMPATIBLE_HOST = "^armeb-linux.*"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
#LINUX_MACH_CFLAGS := -D__LINUX_ARM_ARCH__=5 -mcpu=xscale -mtune=xscale
CFLAGS = "-fno-common -D__KERNEL__ -DMODULE -D__linux -DCPU=33 -DXSCALE=33 \
-D__LINUX_ARM_ARCH__=5 \
diff --git a/packages/ixp4xx/ixp4xx-csr_1.5.bb b/packages/ixp4xx/ixp4xx-csr_1.5.bb
index 2feef7ea4a..debdeb404f 100644
--- a/packages/ixp4xx/ixp4xx-csr_1.5.bb
+++ b/packages/ixp4xx/ixp4xx-csr_1.5.bb
@@ -30,12 +30,6 @@ COMPATIBLE_HOST = "^armeb-linux.*"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
OSAL_PATH = "lib/linux/linuxbe/ixp400"
# This is a somewhat arbitrary choice:
OSAL_DIR = "${STAGING_KERNEL_DIR}/ixp_osal"
diff --git a/packages/ixp4xx/ixp4xx-csr_2.0.bb b/packages/ixp4xx/ixp4xx-csr_2.0.bb
index 963ecc2f64..3fc86c272d 100644
--- a/packages/ixp4xx/ixp4xx-csr_2.0.bb
+++ b/packages/ixp4xx/ixp4xx-csr_2.0.bb
@@ -38,12 +38,6 @@ COMPATIBLE_HOST = "^arm.*-linux.*"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
IX_TARGET = "linux${ARCH_BYTE_SEX}"
OSAL_PATH = "lib/ixp425/linux/${IX_TARGET}"
diff --git a/packages/ixp4xx/ixp4xx-csr_2.1.bb b/packages/ixp4xx/ixp4xx-csr_2.1.bb
index 93ac8aab6f..a91cc25cc1 100644
--- a/packages/ixp4xx/ixp4xx-csr_2.1.bb
+++ b/packages/ixp4xx/ixp4xx-csr_2.1.bb
@@ -44,12 +44,6 @@ COMPATIBLE_HOST = "^arm.*-linux.*"
inherit module
-# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
-# required. Notice that this has to be done for each separately built
-# module as well!
-KERNEL_CC += "${TARGET_CC_KERNEL_ARCH}"
-KERNEL_LD += "${TARGET_LD_KERNEL_ARCH}"
-
IX_TARGET = "linux${ARCH_BYTE_SEX}"
IX_ENSURE = ""
#IX_ENSURE = "IX_OSAL_ENSURE_ON=1"