aboutsummaryrefslogtreecommitdiffstats
path: root/packages/jamvm
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-07-13 13:35:46 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-07-13 13:35:46 +0000
commit85d37bf5630eec2a5198d2049432271052ceaf4a (patch)
treef4a11114f2fb38f85420533fa288c6020c6f3b41 /packages/jamvm
parenta6993535d09d741c5758cbbdc7dee66a0cc90b3b (diff)
downloadopenembedded-85d37bf5630eec2a5198d2049432271052ceaf4a.tar.gz
Added jamvm-native as a provider for virtual/java-native. Use this if
you have trouble with cacao-native (which is somehow miscompiled with Debian's GCC 4.3.1). jamvm-native 1.5.1: New recipe.
Diffstat (limited to 'packages/jamvm')
-rw-r--r--packages/jamvm/jamvm-native.inc18
-rw-r--r--packages/jamvm/jamvm-native_1.5.1.bb4
2 files changed, 22 insertions, 0 deletions
diff --git a/packages/jamvm/jamvm-native.inc b/packages/jamvm/jamvm-native.inc
new file mode 100644
index 0000000000..07eecb52b3
--- /dev/null
+++ b/packages/jamvm/jamvm-native.inc
@@ -0,0 +1,18 @@
+require jamvm.inc
+
+DEPENDS = "zlib-native classpath-native virtual/javac-native"
+
+PROVIDES_jamvm = "virtual/java-native"
+
+RPROVIDES_jamvm = ""
+
+# This uses 32 bit arm, so force the instruction set to arm, not thumb
+ARM_INSTRUCTION_SET = "arm"
+
+inherit native
+
+S = "${WORKDIR}/jamvm-${PV}"
+
+do_install_append() {
+ ln -sf jamvm ${STAGING_BINDIR}/java
+}
diff --git a/packages/jamvm/jamvm-native_1.5.1.bb b/packages/jamvm/jamvm-native_1.5.1.bb
new file mode 100644
index 0000000000..e174e2a312
--- /dev/null
+++ b/packages/jamvm/jamvm-native_1.5.1.bb
@@ -0,0 +1,4 @@
+require jamvm-native.inc
+
+PR = "r0"
+