aboutsummaryrefslogtreecommitdiffstats
path: root/packages/jpeg
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:40:07 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:40:07 +0000
commit00590e39668c11f13f315683c6a3435d768b1322 (patch)
treee09adcd896949a645ef97df84eb0071af24538c1 /packages/jpeg
parent9c9c7139952b06112d99b5b11bfa3d36435a6459 (diff)
downloadopenembedded-00590e39668c11f13f315683c6a3435d768b1322.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/31 14:38:06-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 14:37:57-08:00 (none)!ggilbert Many files: More licenses 2004/12/31 21:40:58+00:00 nexus.co.uk!pb banish audiofile-config and other stuff from /usr/bin to separate packages 2004/12/31 21:38:39+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2004/12/31 21:38:10+00:00 nexus.co.uk!pb update glib-2.0 (and -native) to 2.6.0 BKrev: 41d5d547IMV0BSOCNaouK2zsnwHytg
Diffstat (limited to 'packages/jpeg')
-rw-r--r--packages/jpeg/jpeg_6b.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/jpeg/jpeg_6b.bb b/packages/jpeg/jpeg_6b.bb
index e69de29bb2..30429b6031 100644
--- a/packages/jpeg/jpeg_6b.bb
+++ b/packages/jpeg/jpeg_6b.bb
@@ -0,0 +1,35 @@
+SECTION = "libs"
+PRIORITY = "required"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "libtool-cross"
+DESCRIPTION = "libjpeg is a library for handling the JPEG (JFIF) image format."
+PACKAGES =+ "jpeg-tools "
+FILES_jpeg-tools = "${bindir}"
+LICENSE ="jpeg"
+SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
+ file://debian.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://paths.patch;patch=1"
+S = "${WORKDIR}/jpeg-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF="--enable-static --enable-shared"
+EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR}/${HOST_SYS}-libtool"'
+
+CFLAGS_append = " -D_REENTRANT"
+
+do_stage() {
+ install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
+ install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
+ install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
+ install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
+ install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
+ oe_libinstall -so libjpeg ${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}/${bindir} ${D}/${includedir} \
+ ${D}/${mandir}/man1 ${D}/${libdir}
+ oe_runmake 'DESTDIR=${D}' install
+}