aboutsummaryrefslogtreecommitdiffstats
path: root/packages/kbdd
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-04 05:40:13 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-04 05:40:13 +0000
commit14f13f31d3307aa6e70f14a045af7c3828b7dc51 (patch)
tree04cc605e8c5f1d111712bf9e6ac5c9877c553990 /packages/kbdd
parentecb1a9ebc036bfb90e50b1e156d830c75dfe2436 (diff)
downloadopenembedded-14f13f31d3307aa6e70f14a045af7c3828b7dc51.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/03 21:18:56-08:00 (none)!emte Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into t.(none):/home/OE/speedracer/packages 2005/01/03 21:18:13-08:00 (none)!emte Added initscripts and a new patch to kbdd-patched BKrev: 41da2c3d3_Isov1D4izGqw8uxglvWg
Diffstat (limited to 'packages/kbdd')
-rw-r--r--packages/kbdd/kbdd-patched-20040904/fellowes.init0
-rw-r--r--packages/kbdd/kbdd-patched-20040904/kbdd.default0
-rw-r--r--packages/kbdd/kbdd-patched-20040904/snapntype.init0
-rw-r--r--packages/kbdd/kbdd-patched-20040904/stowaway-fellowes-apm.patch0
-rw-r--r--packages/kbdd/kbdd-patched-20040904/stowaway.init0
-rw-r--r--packages/kbdd/kbdd-patched_20040904.bb72
6 files changed, 72 insertions, 0 deletions
diff --git a/packages/kbdd/kbdd-patched-20040904/fellowes.init b/packages/kbdd/kbdd-patched-20040904/fellowes.init
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kbdd/kbdd-patched-20040904/fellowes.init
diff --git a/packages/kbdd/kbdd-patched-20040904/kbdd.default b/packages/kbdd/kbdd-patched-20040904/kbdd.default
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kbdd/kbdd-patched-20040904/kbdd.default
diff --git a/packages/kbdd/kbdd-patched-20040904/snapntype.init b/packages/kbdd/kbdd-patched-20040904/snapntype.init
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kbdd/kbdd-patched-20040904/snapntype.init
diff --git a/packages/kbdd/kbdd-patched-20040904/stowaway-fellowes-apm.patch b/packages/kbdd/kbdd-patched-20040904/stowaway-fellowes-apm.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kbdd/kbdd-patched-20040904/stowaway-fellowes-apm.patch
diff --git a/packages/kbdd/kbdd-patched-20040904/stowaway.init b/packages/kbdd/kbdd-patched-20040904/stowaway.init
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kbdd/kbdd-patched-20040904/stowaway.init
diff --git a/packages/kbdd/kbdd-patched_20040904.bb b/packages/kbdd/kbdd-patched_20040904.bb
index e69de29bb2..cfcd6a4106 100644
--- a/packages/kbdd/kbdd-patched_20040904.bb
+++ b/packages/kbdd/kbdd-patched_20040904.bb
@@ -0,0 +1,72 @@
+DESCRIPTION = "Keyboard Device Daemon which provides support for snapntype and stowaway keyboards"
+MAINTAINER = "Paul Eggleton <http://handhelds.org/moin/moin.cgi/PaulEggleton>"
+SECTION = "utils"
+LICENSE = "GPL"
+PR = "r1"
+DEPENDS = "virtual/kernel"
+RDEPENDS = "kernel-module-keybdev kernel-module-uinput"
+SRC_URI = "${HANDHELDS_CVS};module=apps/kbdd;date=${PV} \
+ file://snapntype.patch;patch=1;pnum=0 \
+ file://stowaway-fellowes-apm.patch;patch=1;pnum=0 \
+ file://fellowes.init \
+ file://stowaway.init \
+ file://snapntype.init \
+ file://kbdd.default"
+
+inherit autotools
+
+S = "${WORKDIR}/kbdd"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${docdir}/kbdd/
+ install -m 0755 kbdd ${D}/${sbindir}/
+ install -m 0644 README ${D}/${docdir}/kbdd/
+}
+
+do_install_append () {
+ set -x
+ install -d ${D}/${sysconfdir}/init.d
+ cat ${WORKDIR}/fellowes.init | \
+ sed -e 's,/usr/sbin/,${sbindir}/,g; s,/usr/bin/,${bindir}/,g; s,/usr/lib/,${libdir}/,g; s,/etc/,${sysconfdir}/,g; s,/usr/,${prefix}/,g;' > ${D}/${sysconfdir}/init.d/kbdd-fellowes
+ cat ${WORKDIR}/stowaway.init | \
+ sed -e 's,/usr/sbin/,${sbindir}/,g; s,/usr/bin/,${bindir}/,g; s,/usr/lib/,${libdir}/,g; s,/etc/,${sysconfdir}/,g; s,/usr/,${prefix}/,g;' > ${D}/${sysconfdir}/init.d/kbdd-stowaway
+ cat ${WORKDIR}/snapntype.init | \
+ sed -e 's,/usr/sbin/,${sbindir}/,g; s,/usr/bin/,${bindir}/,g; s,/usr/lib/,${libdir}/,g; s,/etc/,${sysconfdir}/,g; s,/usr/,${prefix}/,g;' > ${D}/${sysconfdir}/init.d/kbdd-snapntype
+ chmod 755 ${D}/${sysconfdir}/init.d/kbdd-fellowes
+ chmod 755 ${D}/${sysconfdir}/init.d/kbdd-stowaway
+ chmod 755 ${D}/${sysconfdir}/init.d/kbdd-snapntype
+ mkdir -p ${D}/${sysconfdir}/defaults
+ cat ${WORKDIR}/kbdd.default > ${D}/${sysconfdir}/defaults/kbdd
+ chmod 755 ${D}/${sysconfdir}/defaults/kbdd
+ mkdir -p ${D}/${sysconfdir}/modutils
+ touch ${D}/${sysconfdir}/modutils/kbdd-modules
+ echo "keybdev" > ${D}/${sysconfdir}/modutils/kbdd-modules
+ echo "uinput" >> ${D}/${sysconfdir}/modutils/kbdd-modules
+ chmod 755 ${D}/${sysconfdir}/modutils/kbdd-modules
+}
+
+pkg_postinst () {
+ if test -n "${D}"; then
+ D="-r"
+ fi
+# update-rc.d $D kbdd-fellowes defaults
+# update-rc.d $D kbdd-stowaway defaults
+ update-rc.d $D kbdd-snapntype defaults
+ update-modules
+}
+
+pkg_prerm () {
+ if test -n "${D}"; then
+ D="-r"
+ fi
+ update-rc.d $D kbdd-fellowes remove
+ update-rc.d $D kbdd-stowaway remove
+ update-rc.d $D kbdd-snapntype remove
+ rm ${D}/${sysconfdir}/modutils/kbdd-modules
+ update-modules
+}