aboutsummaryrefslogtreecommitdiffstats
path: root/packages/keylaunch
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-07-05 07:27:31 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-05 07:27:31 +0000
commit22e54f274d63175ecf42217b9601f20e6d2292a1 (patch)
tree4ac733efb949ca20f275f118ddb731ed5c15246e /packages/keylaunch
parentd7b97b907c77740d6a338516d9f14d92728e5fe7 (diff)
downloadopenembedded-22e54f274d63175ecf42217b9601f20e6d2292a1.tar.gz
keylaunch: Install configuration using update-alternatives, enables different key-bindings for different window managers
Diffstat (limited to 'packages/keylaunch')
-rw-r--r--packages/keylaunch/keylaunch_2.0.10.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/packages/keylaunch/keylaunch_2.0.10.bb b/packages/keylaunch/keylaunch_2.0.10.bb
index 67ed0923f2..990de0cba7 100644
--- a/packages/keylaunch/keylaunch_2.0.10.bb
+++ b/packages/keylaunch/keylaunch_2.0.10.bb
@@ -13,7 +13,7 @@ DESCRIPTION = "A small utility for binding commands to a hot key.\
program is already running, keylaunch can bring its window to the front\
rather than just running another copy."
PACKAGE_ARCH = "${MACHINE_ARCH}"
-PR = "r5"
+PR = "r6"
SRC_URI += " file://keylaunchrc"
@@ -21,4 +21,17 @@ do_install_prepend () {
install ${WORKDIR}/keylaunchrc ${S}/keylaunchrc
}
+do_install_append() {
+ # yeah I know...this is less than ideal
+ mv ${D}/etc/keylaunchrc ${D}/etc/keylaunchrc.matchbox
+}
+
export CVSBUILD="no"
+
+pkg_postinst_${PN}() {
+ update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.matchbox 10
+}
+
+pkg_postrm_${PN}() {
+ update-alternatives --remove keylaunchrc /etc/keylaunchrc.matchbox
+}