aboutsummaryrefslogtreecommitdiffstats
path: root/packages/kismet
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/kismet
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/kismet')
-rw-r--r--packages/kismet/.mtn2git_empty0
-rw-r--r--packages/kismet/files/.mtn2git_empty0
-rw-r--r--packages/kismet/files/glibc3.3.2-getopt-throw.diff36
-rw-r--r--packages/kismet/files/no-chmod.diff173
-rw-r--r--packages/kismet/files/no-strip.diff45
-rw-r--r--packages/kismet/kismet-2004-04-R1/.mtn2git_empty0
-rw-r--r--packages/kismet/kismet-2004-04-R1/mtx-1/.mtn2git_empty0
-rw-r--r--packages/kismet/kismet-2004-04-R1/mtx-1/kismet.conf328
-rw-r--r--packages/kismet/kismet-2004-04-R1/no-lib-modules-uname-include.diff15
-rw-r--r--packages/kismet/kismet-2004-04-R1/packet_friend_fix.patch19
-rw-r--r--packages/kismet/kismet-2005-01-R1/.mtn2git_empty0
-rw-r--r--packages/kismet/kismet-2005-01-R1/no-lib-modules-uname-include.diff15
-rw-r--r--packages/kismet/kismet_2005-01-R1.bb33
-rw-r--r--packages/kismet/kismet_2005-04-R1.bb31
14 files changed, 695 insertions, 0 deletions
diff --git a/packages/kismet/.mtn2git_empty b/packages/kismet/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kismet/.mtn2git_empty
diff --git a/packages/kismet/files/.mtn2git_empty b/packages/kismet/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kismet/files/.mtn2git_empty
diff --git a/packages/kismet/files/glibc3.3.2-getopt-throw.diff b/packages/kismet/files/glibc3.3.2-getopt-throw.diff
index e69de29bb2..7032e3d736 100644
--- a/packages/kismet/files/glibc3.3.2-getopt-throw.diff
+++ b/packages/kismet/files/glibc3.3.2-getopt-throw.diff
@@ -0,0 +1,36 @@
+--- getopt.h.o 2004-10-10 19:48:48.409249432 +0200
++++ getopt.h 2004-10-10 19:51:42.610766776 +0200
+@@ -20,6 +20,14 @@
+
+ #include "config.h"
+
++#ifndef __THROW
++# if defined __cplusplus && __GNUC_PREREQ (2,8)
++# define __THROW throw ()
++# else
++# define __THROW
++# endif
++#endif
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+@@ -103,15 +111,15 @@
+ /* Many other libraries have conflicting prototypes for getopt, with
+ differences in the consts, in stdlib.h. To avoid compilation
+ errors, only prototype getopt for the GNU C library. */
+-extern int getopt (int argc, char *const *argv, const char *shortopts);
++extern int getopt (int argc, char *const *argv, const char *shortopts) __THROW;
+ #else /* not __GNU_LIBRARY__ */
+ /* extern int getopt (); */
+ #endif /* not __GNU_LIBRARY__ */
+ extern int getopt_long (int argc, char *const *argv, const char *shortopts,
+- const struct option *longopts, int *longind);
++ const struct option *longopts, int *longind) __THROW;
+ extern int getopt_long_only (int argc, char *const *argv,
+ const char *shortopts,
+- const struct option *longopts, int *longind);
++ const struct option *longopts, int *longind) __THROW;
+
+ /* Internal only. Users should not call this directly. */
+ extern int _getopt_internal (int argc, char *const *argv,
diff --git a/packages/kismet/files/no-chmod.diff b/packages/kismet/files/no-chmod.diff
index e69de29bb2..9520d1df5b 100644
--- a/packages/kismet/files/no-chmod.diff
+++ b/packages/kismet/files/no-chmod.diff
@@ -0,0 +1,173 @@
+--- Makefile.in.o 2004-10-16 15:55:52.836093688 +0200
++++ Makefile.in 2004-10-16 16:06:38.966866880 +0200
+@@ -130,52 +130,52 @@
+ fi
+
+ binuserinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(DRONE) $(BIN)/$(DRONE);
++ install -m 755 $(PS) $(BIN)/$(PS);
++ install -m 755 $(DRONE) $(BIN)/$(DRONE);
+
+ binsuidinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(DRONE) $(BIN)/$(DRONE);
++ install -m 4755 $(PS) $(BIN)/$(PS);
++ install -m 4755 $(DRONE) $(BIN)/$(DRONE);
+
+ commoninstall:
+ mkdir -p $(ETC)
+ mkdir -p $(BIN)
+
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet $(BIN)/kismet
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(NC) $(BIN)/$(NC)
+- # install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(HOPPER) $(BIN)/$(HOPPER)
++ install -m 755 scripts/kismet $(BIN)/kismet
++ install -m 755 $(NC) $(BIN)/$(NC)
++ # install -m 755 $(HOPPER) $(BIN)/$(HOPPER)
+ @if test "$(ZAURUS)" = "yes"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
++ install -m 755 $(BUZZER) $(BIN)/buzzme; \
++ echo install -m 755 $(BUZZER) $(BIN)/buzzme; \
+ fi
+-#install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
+-#install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
++#install -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
++#install -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
+ mkdir -p $(MAN)/man1
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet.1 $(MAN)/man1/kismet.1
+- # install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_monitor.1 $(MAN)/man1/kismet_monitor.1
+- # install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_hopper.1 $(MAN)/man1/kismet_hopper.1
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.1 $(MAN)/man1/kismet_drone.1
++ install -m 644 man/kismet.1 $(MAN)/man1/kismet.1
++ # install -m 644 man/kismet_monitor.1 $(MAN)/man1/kismet_monitor.1
++ # install -m 644 man/kismet_hopper.1 $(MAN)/man1/kismet_hopper.1
++ install -m 644 man/kismet_drone.1 $(MAN)/man1/kismet_drone.1
+ mkdir -p $(MAN)/man5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet.conf.5 $(MAN)/man5/kismet.conf.5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_ui.conf.5 $(MAN)/man5/kismet_ui.conf.5
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
++ install -m 644 man/kismet.conf.5 $(MAN)/man5/kismet.conf.5
++ install -m 644 man/kismet_ui.conf.5 $(MAN)/man5/kismet_ui.conf.5
++ install -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
+
+ @if test "$(GPSLBUILD)" = "$(GPSL)"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+- install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
+- echo install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
++ install -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ echo install -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ install -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
++ echo install -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
++ install -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
++ echo install -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
+ fi
+
+ mkdir -p $(WAV)
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/new_network.wav $(WAV)/new_network.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/traffic.wav $(WAV)/traffic.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/junk_traffic.wav $(WAV)/junk_traffic.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 wav/alert.wav $(WAV)/alert.wav
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/ap_manuf $(ETC)/ap_manuf;
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/client_manuf $(ETC)/client_manuf;
++ install -m 644 wav/new_network.wav $(WAV)/new_network.wav
++ install -m 644 wav/traffic.wav $(WAV)/traffic.wav
++ install -m 644 wav/junk_traffic.wav $(WAV)/junk_traffic.wav
++ install -m 644 wav/alert.wav $(WAV)/alert.wav
++ install -m 644 conf/ap_manuf $(ETC)/ap_manuf;
++ install -m 644 conf/client_manuf $(ETC)/client_manuf;
+
+ @if test -f $(BIN)/kismet_curses; then \
+ echo "Removing old kismet_curses binary. The panels frontend is now kismet_client."; \
+@@ -188,22 +188,22 @@
+ @if test -f $(ETC)/kismet.conf; then \
+ $(MAKE) -e checkconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ echo install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_drone.conf; then \
+ $(MAKE) -e checkdroneconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ echo install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_ui.conf; then \
+ $(MAKE) -e checkuiconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ echo install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf."; \
+ fi
+ @echo "Installed kismet into $(BIN)/."
+@@ -221,22 +221,22 @@
+ @if test -f $(ETC)/kismet.conf; then \
+ $(MAKE) -e checkconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ echo install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_drone.conf; then \
+ $(MAKE) -e checkdroneconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ echo install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf."; \
+ fi
+ @if test -f $(ETC)/kismet_ui.conf; then \
+ $(MAKE) -e checkuiconfig; \
+ else \
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ echo install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf."; \
+ fi
+ @echo "Installed kismet into $(BIN)/."
+@@ -252,11 +252,11 @@
+ forceinstall: $(PS)
+ $(MAKE) -e commoninstall
+ $(MAKE) -e binuserinstall
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf.";
+ @echo "Installed kismet into $(BIN)/."
+ @echo "If you have not done so already, read the README file and the FAQ file. Additional"
+@@ -271,11 +271,11 @@
+ suidforceinstall: $(PS)
+ $(MAKE) -e commoninstall
+ $(MAKE) -e binsuidinstall
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
++ install -m 644 conf/kismet.conf $(ETC)/kismet.conf; \
+ echo "Installed config into $(ETC)/kismet.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
++ install -m 644 conf/kismet_drone.conf $(ETC)/kismet_drone.conf; \
+ echo "Installed drone config into $(ETC)/kismet_drone.conf.";
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
++ install -m 644 conf/kismet_ui.conf $(ETC)/kismet_ui.conf; \
+ echo "Installed UI config into $(ETC)/kismet_ui.conf.";
+ @echo "Installed kismet into $(BIN)/."
+ @echo "If you have not done so already, read the README file and the FAQ file. Additional"
diff --git a/packages/kismet/files/no-strip.diff b/packages/kismet/files/no-strip.diff
index e69de29bb2..a4a8f85344 100644
--- a/packages/kismet/files/no-strip.diff
+++ b/packages/kismet/files/no-strip.diff
@@ -0,0 +1,45 @@
+--- Makefile.in.o 2004-10-08 18:59:21.294566720 +0200
++++ Makefile.in 2004-10-08 18:59:40.034717784 +0200
+@@ -130,23 +130,23 @@
+ fi
+
+ binuserinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(DRONE) $(BIN)/$(DRONE);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(PS) $(BIN)/$(PS);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(DRONE) $(BIN)/$(DRONE);
+
+ binsuidinstall:
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 4755 $(PS) $(BIN)/$(PS);
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 4755 $(DRONE) $(BIN)/$(DRONE);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(PS) $(BIN)/$(PS);
++ install -o $(INSTUSR) -g $(INSTGRP) -m 4755 $(DRONE) $(BIN)/$(DRONE);
+
+ commoninstall:
+ mkdir -p $(ETC)
+ mkdir -p $(BIN)
+
+ install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet $(BIN)/kismet
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(NC) $(BIN)/$(NC)
+- # install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(HOPPER) $(BIN)/$(HOPPER)
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(NC) $(BIN)/$(NC)
++ # install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(HOPPER) $(BIN)/$(HOPPER)
+ @if test "$(ZAURUS)" = "yes"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(BUZZER) $(BIN)/buzzme; \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(BUZZER) $(BIN)/buzzme; \
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
++ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(BUZZER) $(BIN)/buzzme; \
+ fi
+ #install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_monitor $(BIN)/kismet_monitor
+ #install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/kismet_unmonitor $(BIN)/kismet_unmonitor
+@@ -161,8 +161,8 @@
+ install -o $(INSTUSR) -g $(MANGRP) -m 644 man/kismet_drone.conf.5 $(MAN)/man5/kismet_drone.conf.5
+
+ @if test "$(GPSLBUILD)" = "$(GPSL)"; then \
+- install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(GPSL) $(BIN)/$(GPSL); \
+- echo install -o $(INSTUSR) -g $(INSTGRP) -s -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
++ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 $(GPSL) $(BIN)/$(GPSL); \
+ install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+ echo install -o $(INSTUSR) -g $(INSTGRP) -m 755 scripts/gpsmap-helper-earthamaps $(BIN)/gpsmap-helper-earthamaps; \
+ install -o $(INSTUSR) -g $(MANGRP) -m 644 man/gpsmap.1 $(MAN)/man1/gpsmap.1; \
diff --git a/packages/kismet/kismet-2004-04-R1/.mtn2git_empty b/packages/kismet/kismet-2004-04-R1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kismet/kismet-2004-04-R1/.mtn2git_empty
diff --git a/packages/kismet/kismet-2004-04-R1/mtx-1/.mtn2git_empty b/packages/kismet/kismet-2004-04-R1/mtx-1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kismet/kismet-2004-04-R1/mtx-1/.mtn2git_empty
diff --git a/packages/kismet/kismet-2004-04-R1/mtx-1/kismet.conf b/packages/kismet/kismet-2004-04-R1/mtx-1/kismet.conf
index e69de29bb2..233aec378a 100644
--- a/packages/kismet/kismet-2004-04-R1/mtx-1/kismet.conf
+++ b/packages/kismet/kismet-2004-04-R1/mtx-1/kismet.conf
@@ -0,0 +1,328 @@
+# Kismet config file
+# Most of the "static" configs have been moved to here -- the command line
+# config was getting way too crowded and cryptic. We want functionality,
+# not continually reading --help!
+
+# Version of Kismet config
+version=2004.03.devel.a
+
+# Name of server (Purely for organiational purposes)
+servername=Kismet
+
+# User to setid to (should be your normal user)
+suiduser=your_user_here
+
+# Sources are defined as:
+# source=cardtype,interface,name[,initialchannel]
+# Card types and required drivers are listed in the README.
+# The initial channel is optional, if hopping is not enabled it can be used
+# to set the channel the interface listens on.
+source=hostap,wlan0,wlan0
+source=hostap,wlan1,wlan1
+# Other common source configs:
+# source=prism2,wlan0,prism2source
+# source=prism2_avs,wlan0,newprism2source
+# source=orinoco,eth0,orinocosource
+# An example source line with an initial channel:
+# source=orinoco,eth0,silver,11
+
+# Comma-separated list of sources to enable. This is only needed if you defined
+# multiple sources and only want to enable some of them. By default, all defined
+# sources are enabled.
+# For example:
+# enablesources=prismsource,ciscosource
+
+# Do we channelhop?
+channelhop=true
+
+# How many channels per second do we hop? (1-10)
+channelvelocity=5
+
+# By setting the dwell time for channel hopping we override the channelvelocity
+# setting above and dwell on each channel for the given number of seconds.
+#channeldwell=10
+
+# Do we split channels between cards on the same spectrum? This means if
+# multiple 802.11b capture sources are defined, they will be offset to cover
+# the most possible spectrum at a given time. This also controls splitting
+# fine-tuned sourcechannels lines which cover multiple interfaces (see below)
+channelsplit=true
+
+# Basic channel hopping control:
+# These define the channels the cards hop through for various frequency ranges
+# supported by Kismet. More finegrain control is available via the
+# "sourcechannels" configuration option.
+#
+# Don't change the IEEE80211<x> identifiers or channel hopping won't work.
+
+# Users outside the US might want to use this list:
+# defaultchannels=IEEE80211b:1,7,13,2,8,3,14,9,4,10,5,11,6,12
+defaultchannels=IEEE80211b:1,6,11,2,7,3,8,4,9,5,10
+
+# 802.11g uses the same channels as 802.11b...
+defaultchannels=IEEE80211g:1,6,11,2,7,3,8,4,9,5,10
+
+# 802.11a channels are non-overlapping so sequential is fine. You may want to
+# adjust the list depending on the channels your card actually supports.
+# defaultchannels=IEEE80211a:36,40,44,48,52,56,60,64,100,104,108,112,116,120,124,128,132,136,140,149,153,157,161,184,188,192,196,200,204,208,212,216
+defaultchannels=IEEE80211a:36,40,44,48,52,56,60,64
+
+# Combo cards like Atheros use both 'a' and 'b/g' channels. Of course, you
+# can also explicitly override a given source. You can use the script
+# extras/listchan.pl to extract all the channels your card supports.
+defaultchannels=IEEE80211ab:1,6,11,2,7,3,8,4,9,5,10,36,40,44,48,52,56,60,64
+
+# Fine-tuning channel hopping control:
+# The sourcechannels option can be used to set the channel hopping for
+# specific interfaces, and to control what interfaces share a list of
+# channels for split hopping. This can also be used to easily lock
+# one card on a single channel while hopping with other cards.
+# Any card without a sourcechannel definition will use the standard hopping
+# list.
+# sourcechannels=sourcename[,sourcename]:ch1,ch2,ch3,...chN
+
+# ie, for us channels on the source 'prism2source' (same as normal channel
+# hopping behavior):
+# sourcechannels=prism2source:1,6,11,2,7,3,8,4,9,5,10
+
+# Given two capture sources, "prism2a" and "prism2b", we want prism2a to stay
+# on channel 6 and prism2b to hop normally. By not setting a sourcechannels
+# line for prism2b, it will use the standard hopping.
+# sourcechannels=prism2a:6
+
+# To assign the same custom hop channel to multiple sources, or to split the
+# same custom hop channel over two sources (if splitchannels is true), list
+# them all on the same sourcechannels line:
+# sourcechannels=prism2a,prism2b,prism2c:1,6,11
+
+# Port to serve GUI data
+tcpport=2501
+# People allowed to connect, comma seperated IP addresses or network/mask
+# blocks. Netmasks can be expressed as dotted quad (/255.255.255.0) or as
+# numbers (/24)
+allowedhosts=127.0.0.1
+# Maximum number of concurrent GUI's
+maxclients=5
+
+# Do we have a GPS?
+gps=true
+# Host:port that GPSD is running on. This can be localhost OR remote!
+gpshost=localhost:2947
+# Do we lock the mode? This overrides coordinates of lock "0", which will
+# generate some bad information until you get a GPS lock, but it will
+# fix problems with GPS units with broken NMEA that report lock 0
+gpsmodelock=false
+
+# Packet filtering options:
+# filter_tracker - Packets filtered from the tracker are not processed or
+# recorded in any way.
+# filter_dump - Packets filtered at the dump level are tracked, displayed,
+# and written to the csv/xml/network/etc files, but not
+# recorded in the packet dump
+# filter_export - Controls what packets influence the exported CSV, network,
+# xml, gps, etc files.
+# All filtering options take arguments containing the type of address and
+# addresses to be filtered. Valid address types are 'ANY', 'BSSID',
+# 'SOURCE', and 'DEST'. Filtering can be inverted by the use of '!' before
+# the address. For example,
+# filter_tracker=ANY(!00:00:DE:AD:BE:EF)
+# has the same effect as the previous mac_filter config file option.
+# filter_tracker=...
+# filter_dump=...
+# filter_export=...
+
+# Alerts to be reported and the throttling rates.
+# alert=name,throttle/unit,burst
+# The throttle/unit describes the number of alerts of this type that are
+# sent per time unit. Valid time units are second, minute, hour, and day.
+# Burst describes the number of alerts sent before throttling takes place.
+# For example:
+# alert=FOO,10/min,5
+# Would allow 5 alerts through before throttling is enabled, and will then
+# limit the number of alerts to 10 per minute.
+# A throttle rate of 0 disables throttling of the alert.
+# See the README for a list of alert types.
+alert=NETSTUMBLER,5/min,2
+alert=WELLENREITER,5/min,2
+alert=LUCENTTEST,5/min,2
+alert=DEAUTHFLOOD,5/min,4
+alert=BCASTDISCON,5/min,4
+alert=CHANCHANGE,5/min,4
+alert=AIRJACKSSID,5/min,2
+alert=PROBENOJOIN,5/min,2
+alert=DISASSOCTRAFFIC,5/min,2
+alert=NULLPROBERESP,5/min,5
+
+# Known WEP keys to decrypt, bssid,hexkey. This is only for networks where
+# the keys are already known, and it may impact throughput on slower hardware.
+# Multiple wepkey lines may be used for multiple BSSIDs.
+# wepkey=00:DE:AD:C0:DE:00,FEEDFACEDEADBEEF01020304050607080900
+
+# Is transmission of the keys to the client allowed? This may be a security
+# risk for some. If you disable this, you will not be able to query keys from
+# a client.
+allowkeytransmit=true
+
+# How often (in seconds) do we write all our data files (0 to disable)
+writeinterval=300
+
+# Do we use sound?
+# Not to be confused with GUI sound parameter, this controls wether or not the
+# server itself will play sound. Primarily for headless or automated systems.
+sound=false
+# Path to sound player
+soundplay=/usr/bin/play
+# Optional parameters to pass to the player
+# soundopts=--volume=.3
+# New network found
+sound_new=/usr/share/kismet/wav/new_network.wav
+# Wepped new network
+# sound_new_wep=/usr/com/kismet/wav/new_wep_network.wav
+# Network traffic sound
+sound_traffic=/usr/share/kismet/wav/traffic.wav
+# Network junk traffic found
+sound_junktraffic=/usr/share/kismet/wav/junk_traffic.wav
+# GPS lock aquired sound
+# sound_gpslock=/usr/share/kismet/wav/foo.wav
+# GPS lock lost sound
+# sound_gpslost=/usr/share/kismet/wav/bar.wav
+# Alert sound
+sound_alert=/usr/share/kismet/wav/alert.wav
+
+# Does the server have speech? (Again, not to be confused with the GUI's speech)
+speech=false
+# Server's path to Festival
+festival=/usr/bin/festival
+# How do we speak? Valid options:
+# speech Normal speech
+# nato NATO spellings (alpha, bravo, charlie)
+# spell Spell the letters out (aye, bee, sea)
+speech_type=nato
+# speech_encrypted and speech_unencrypted - Speech templates
+# Similar to the logtemplate option, this lets you customize the speech output.
+# speech_encrypted is used for an encrypted network spoken string
+# speech_unencrypted is used for an unencrypted network spoken string
+#
+# %b is replaced by the BSSID (MAC) of the network
+# %s is replaced by the SSID (name) of the network
+# %c is replaced by the CHANNEL of the network
+# %r is replaced by the MAX RATE of the network
+speech_encrypted=New network detected, s.s.i.d. %s, channel %c, network encrypted.
+speech_unencrypted=New network detected, s.s.i.d. %s, channel %c, network open.
+
+# Where do we get our manufacturer fingerprints from? Assumed to be in the
+# default config directory if an absolute path is not given.
+ap_manuf=ap_manuf
+client_manuf=client_manuf
+
+# Use metric measurements in the output?
+metric=false
+
+# Do we write waypoints for gpsdrive to load? Note: This is NOT related to
+# recent versions of GPSDrive's native support of Kismet.
+waypoints=false
+# GPSMap waypoint file. This WILL be truncated.
+waypointdata=%h/.gpsdrive/way_kismet.txt
+
+# How many alerts do we backlog for new clients? Only change this if you have
+# a -very- low memory system and need those extra bytes, or if you have a high
+# memory system and a huge number of alert conditions.
+alertbacklog=50
+
+# File types to log, comma seperated
+# dump - raw packet dump
+# network - plaintext detected networks
+# csv - plaintext detected networks in CSV format
+# xml - XML formatted network and cisco log
+# weak - weak packets (in airsnort format)
+# cisco - cisco equipment CDP broadcasts
+# gps - gps coordinates
+logtypes=dump,network,csv,xml,weak,cisco,gps
+
+# Do we track probe responses and merge probe networks into their owners?
+# This isn't always desireable, depending on the type of monitoring you're
+# trying to do.
+trackprobenets=true
+
+# Do we log "noise" packets that we can't decipher? I tend to not, since
+# they don't have anything interesting at all in them.
+noiselog=false
+
+# Do we log corrupt packets? Corrupt packets have enough header information
+# to see what they are, but someting is wrong with them that prevents us from
+# completely dissecting them. Logging these is usually not a bad idea.
+corruptlog=true
+
+# Do we log beacon packets or do we filter them out of the dumpfile
+beaconlog=true
+
+# Do we log PHY layer packets or do we filter them out of the dumpfile
+phylog=true
+
+# Do we mangle packets if we can decrypt them or if they're fuzzy-detected
+mangledatalog=true
+
+# Do we do "fuzzy" crypt detection? (byte-based detection instead of 802.11
+# frame headers)
+# valid option: Comma seperated list of card types to perform fuzzy detection
+# on, or 'all'
+fuzzycrypt=wtapfile,wlanng,wlanng_legacy,wlanng_avs,hostap,wlanng_wext
+
+# What type of dump do we generate?
+# valid option: "wiretap"
+dumptype=wiretap
+# Do we limit the size of dump logs? Sometimes ethereal can't handle big ones.
+# 0 = No limit
+# Anything else = Max number of packets to log to a single file before closing
+# and opening a new one.
+dumplimit=0
+
+# Do we write data packets to a FIFO for an external data-IDS (such as Snort)?
+# See the docs before enabling this.
+#fifo=/tmp/kismet_dump
+
+# Default log title
+logdefault=Kismet
+
+# logtemplate - Filename logging template.
+# This is, at first glance, really nasty and ugly, but you'll hardly ever
+# have to touch it so don't complain too much.
+#
+# %n is replaced by the logging instance name
+# %d is replaced by the current date as Mon-DD-YYYY
+# %D is replaced by the current date as YYYYMMDD
+# %t is replaced by the starting log time
+# %i is replaced by the increment log in the case of multiple logs
+# %l is replaced by the log type (dump, status, crypt, etc)
+# %h is replaced by the home directory
+# ie, "netlogs/%n-%d-%i.dump" called with a logging name of "Pok" could expand
+# to something like "netlogs/Pok-Dec-20-01-1.dump" for the first instance and
+# "netlogs/Pok-Dec-20-01-2.%l" for the second logfile generated.
+# %h/netlots/%n-%d-%i.dump could expand to
+# /home/foo/netlogs/Pok-Dec-20-01-2.dump
+#
+# Other possibilities: Sorting by directory
+# logtemplate=%l/%n-%d-%i
+# Would expand to, for example,
+# dump/Pok-Dec-20-01-1
+# crypt/Pok-Dec-20-01-1
+# and so on. The "dump", "crypt", etc, dirs must exist before kismet is run
+# in this case.
+logtemplate=/tmp/%n-%d-%i.%l
+
+# Where do we store the pid file of the server?
+piddir=/var/run/
+
+# Where state info, etc, is stored. You shouldnt ever need to change this.
+# This is a directory.
+configdir=%h/.kismet/
+
+# cloaked SSID file. You shouldn't ever need to change this.
+ssidmap=ssid_map
+
+# Group map file. You shouldn't ever need to change this.
+groupmap=group_map
+
+# IP range map file. You shouldn't ever need to change this.
+ipmap=ip_map
+
diff --git a/packages/kismet/kismet-2004-04-R1/no-lib-modules-uname-include.diff b/packages/kismet/kismet-2004-04-R1/no-lib-modules-uname-include.diff
index e69de29bb2..6b2b5f74a6 100644
--- a/packages/kismet/kismet-2004-04-R1/no-lib-modules-uname-include.diff
+++ b/packages/kismet/kismet-2004-04-R1/no-lib-modules-uname-include.diff
@@ -0,0 +1,15 @@
+--- configure.o 2004-10-18 13:37:48.208863080 +0200
++++ configure 2004-10-18 13:39:16.298471424 +0200
+@@ -5805,9 +5805,9 @@
+ if test "$wireless" = "yes"; then
+ # If we're compiling under linux and we need the wireless extentions,
+ # then we should try to look in the current kernel module build dir, too.
+- if test "$linux" = "yes"; then
+- CPPFLAGS="$CPPFLAGS -I/lib/modules/\`uname -r\`/build/include/"
+- fi
++ #if test "$linux" = "yes"; then
++ # CPPFLAGS="$CPPFLAGS -I/lib/modules/\`uname -r\`/build/include/"
++ #fi
+
+ echo "$as_me:$LINENO: checking that linux/wireless.h is what we expect" >&5
+ echo $ECHO_N "checking that linux/wireless.h is what we expect... $ECHO_C" >&6
diff --git a/packages/kismet/kismet-2004-04-R1/packet_friend_fix.patch b/packages/kismet/kismet-2004-04-R1/packet_friend_fix.patch
index e69de29bb2..1b72cf8ce7 100644
--- a/packages/kismet/kismet-2004-04-R1/packet_friend_fix.patch
+++ b/packages/kismet/kismet-2004-04-R1/packet_friend_fix.patch
@@ -0,0 +1,19 @@
+--- kismet-2004-04-R1/packet.h.orig 2005-02-04 09:12:36.000000000 +0000
++++ kismet-2004-04-R1/packet.h 2005-02-04 09:13:14.000000000 +0000
+@@ -550,7 +550,7 @@
+ // This isn't quite like STL iterators, because I'm too damned lazy to deal with all
+ // the nasty STL hoop-jumping. This does provide a somewhat-stl-ish interface to
+ // iterating through the singleton and masked maps
+- friend class iterator {
++ class iterator {
+ friend class macmap;
+
+ public:
+@@ -643,6 +643,7 @@
+ int vector_itr;
+ macmap<T> *owner;
+ };
++ friend class iterator;
+
+ iterator begin() {
+ iterator ret(this);
diff --git a/packages/kismet/kismet-2005-01-R1/.mtn2git_empty b/packages/kismet/kismet-2005-01-R1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/kismet/kismet-2005-01-R1/.mtn2git_empty
diff --git a/packages/kismet/kismet-2005-01-R1/no-lib-modules-uname-include.diff b/packages/kismet/kismet-2005-01-R1/no-lib-modules-uname-include.diff
index e69de29bb2..9be6fd3bd0 100644
--- a/packages/kismet/kismet-2005-01-R1/no-lib-modules-uname-include.diff
+++ b/packages/kismet/kismet-2005-01-R1/no-lib-modules-uname-include.diff
@@ -0,0 +1,15 @@
+--- configure.orig 2005-02-21 12:12:23.061566024 +0000
++++ configure 2005-02-21 12:12:34.560817872 +0000
+@@ -6225,9 +6225,9 @@
+ if test "$wireless" = "yes"; then
+ # If we're compiling under linux and we need the wireless extentions,
+ # then we should try to look in the current kernel module build dir, too.
+- if test "$linux" = "yes"; then
+- CPPFLAGS="$CPPFLAGS -I/lib/modules/$(uname -r)/build/include/"
+- fi
++ #if test "$linux" = "yes"; then
++ # CPPFLAGS="$CPPFLAGS -I/lib/modules/$(uname -r)/build/include/"
++ #fi
+
+ echo "$as_me:$LINENO: checking that linux/wireless.h is what we expect" >&5
+ echo $ECHO_N "checking that linux/wireless.h is what we expect... $ECHO_C" >&6
diff --git a/packages/kismet/kismet_2005-01-R1.bb b/packages/kismet/kismet_2005-01-R1.bb
index e69de29bb2..1ab7048863 100644
--- a/packages/kismet/kismet_2005-01-R1.bb
+++ b/packages/kismet/kismet_2005-01-R1.bb
@@ -0,0 +1,33 @@
+SECTION = "console/network"
+DESCRIPTION = "Kismet is an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
+HOMEPAGE = "http://www.kismetwireless.net/"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPLv2"
+DEPENDS = "expat gmp"
+
+SRC_URI = "http://www.kismetwireless.net/code/kismet-2005-01-R1.tar.gz \
+ file://no-strip.diff;patch=1;pnum=0 \
+ file://no-chmod.diff;patch=1;pnum=0 \
+ file://no-lib-modules-uname-include.diff;patch=1;pnum=0 \
+ file://glibc3.3.2-getopt-throw.diff;patch=1;pnum=0"
+
+
+EXTRA_OECONF = "--with-pcap=linux --disable-setuid"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+
+do_install_append() {
+ if test -e ${WORKDIR}/kismet.conf; then
+ install -m 644 ${WORKDIR}/kismet.conf ${D}${sysconfdir}/
+ fi
+}
+
+PACKAGES =+ "kismet-sounds"
+FILES_kismet-sounds = "/usr/share/kismet/wav"
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/kismet.conf"
diff --git a/packages/kismet/kismet_2005-04-R1.bb b/packages/kismet/kismet_2005-04-R1.bb
index e69de29bb2..181c2a3a17 100644
--- a/packages/kismet/kismet_2005-04-R1.bb
+++ b/packages/kismet/kismet_2005-04-R1.bb
@@ -0,0 +1,31 @@
+SECTION = "console/network"
+DESCRIPTION = "Kismet is an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
+HOMEPAGE = "http://www.kismetwireless.net/"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPLv2"
+DEPENDS = "expat gmp"
+
+SRC_URI = "http://www.kismetwireless.net/code/kismet-2005-04-R1.tar.gz \
+ file://no-strip.diff;patch=1;pnum=0 \
+ file://no-chmod.diff;patch=1;pnum=0 \
+ file://glibc3.3.2-getopt-throw.diff;patch=1;pnum=0"
+
+
+EXTRA_OECONF = "--with-pcap=linux --disable-setuid --with-linuxheaders=${STAGING_KERNEL_DIR}/include"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+do_install_append() {
+ if test -e ${WORKDIR}/kismet.conf; then
+ install -m 644 ${WORKDIR}/kismet.conf ${D}${sysconfdir}/
+ fi
+}
+
+PACKAGES =+ "kismet-sounds"
+FILES_kismet-sounds = "/usr/share/kismet/wav"
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/kismet.conf"