aboutsummaryrefslogtreecommitdiffstats
path: root/packages/less
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-10-14 05:20:25 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-10-14 05:20:25 +0000
commite093c8f4c2ecc7b514b7f5521e3c3de170b7a4d5 (patch)
treeca50db9da95316f1920cf77b028a8a2827ffcb33 /packages/less
parentd4ce3c6e6693f0bca5a55ba19507d5afcd4108c9 (diff)
downloadopenembedded-e093c8f4c2ecc7b514b7f5521e3c3de170b7a4d5.tar.gz
less 382: Use update-alternatives for less since busybox provides less as
well. As report in #1472.
Diffstat (limited to 'packages/less')
-rw-r--r--packages/less/less_382.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/packages/less/less_382.bb b/packages/less/less_382.bb
index b489722edb..f336a59ad6 100644
--- a/packages/less/less_382.bb
+++ b/packages/less/less_382.bb
@@ -1,16 +1,22 @@
-SECTION = "console/utils"
-DEPENDS = "ncurses"
DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
based program for viewing text files and the output from other \
programs. Less offers many features beyond those that more does."
HOMEPAGE = "http://www.greenwoodsoftware.com/"
+SECTION = "console/utils"
LICENSE = "BSD"
+DEPENDS = "ncurses"
+PR = "r1"
SRC_URI = "${GNU_MIRROR}/less/less-${PV}.tar.gz \
- file://configure.patch;patch=1"
+ file://configure.patch;patch=1"
-inherit autotools
+inherit autotools update-alternatives
do_install () {
- oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+ oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+ mv ${D}${bindir}/less ${D}${bindir}/less.${PN}
}
+
+ALTERNATIVE_NAME = "less"
+ALTERNATIVE_PATH = "less.${PN}"
+ALTERNATIVE_PRIORITY = "100"