aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libao
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-24 23:06:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-24 23:06:37 +0000
commitc2626bcd2980854c6cddce5d2625ae22475732c5 (patch)
tree1bbf825a37a7d440c2355c51d2153cbf702b1b80 /packages/libao
parent0d9a48d586c544d2c1da58356a6d92c68a939f7e (diff)
downloadopenembedded-c2626bcd2980854c6cddce5d2625ae22475732c5.tar.gz
Update libao to latest version
Diffstat (limited to 'packages/libao')
-rw-r--r--packages/libao/libao_0.8.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/libao/libao_0.8.6.bb b/packages/libao/libao_0.8.6.bb
new file mode 100644
index 0000000000..8c2601bce8
--- /dev/null
+++ b/packages/libao/libao_0.8.6.bb
@@ -0,0 +1,26 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cross platform audio library"
+HOMEPAGE = "http://www.xiph.org/ao/"
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r0"
+
+SRC_URI = "http://www.xiph.org/ao/src/libao-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-esd --disable-esdtest \
+ --disable-alsa --disable-alsa09 \
+ --disable-arts --disable-nas"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/ao
+ install -m 0644 ${S}/include/ao/ao.h ${S}/include/ao/os_types.h \
+ ${S}/include/ao/plugin.h ${STAGING_INCDIR}/ao/
+
+ oe_libinstall -so -C src libao ${STAGING_LIBDIR}
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ao.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+FILES_${PN} += "${libdir}/ao/plugins-2/*.so"