aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libelf
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
commit9c9c7139952b06112d99b5b11bfa3d36435a6459 (patch)
treefd0778f2b3d3d14f05cd4ff4b4cb341573e92d82 /packages/libelf
parentf73398ac656a31e2bbd214a3b2c3dc92eddaaecf (diff)
downloadopenembedded-9c9c7139952b06112d99b5b11bfa3d36435a6459.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/31 14:27:40-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 14:27:30-08:00 (none)!ggilbert Add many licenses 2004/12/31 21:28:22+00:00 nexus.co.uk!pb fix typo introduced with recent LICENSE patches 2004/12/31 21:12:38+00:00 nexus.co.uk!pb gpe-soundbite is GPL 2004/12/31 21:11:57+00:00 nexus.co.uk!pb gpe-question is GPL 2004/12/31 21:11:12+00:00 nexus.co.uk!pb gpe-nmf is GPL 2004/12/31 21:10:28+00:00 nexus.co.uk!pb gpe-gallery is GPL 2004/12/31 21:09:42+00:00 nexus.co.uk!pb gpe-edit is GPL 2004/12/31 21:07:12+00:00 nexus.co.uk!pb gpe-ownerinfo is GPL 2004/12/31 21:03:44+00:00 nexus.co.uk!pb delete old gpe-bootsplash with no LICENSE 2004/12/31 21:02:29+00:00 nexus.co.uk!pb delete some old gpe-clock versions with no LICENSE 2004/12/31 21:00:16+00:00 nexus.co.uk!pb delete old hotplug-dbus versions with no LICENSE 2004/12/31 20:59:20+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2004/12/31 13:35:00-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 13:34:19-08:00 (none)!ggilbert More licenses 2004/12/31 20:59:03+00:00 nexus.co.uk!pb add LICENSE for gpe-confd, and blow away some old versions BKrev: 41d5d25dQOnhk1FZOyFZXNL3fxoihA
Diffstat (limited to 'packages/libelf')
-rw-r--r--packages/libelf/libelf_0.8.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/libelf/libelf_0.8.3.bb b/packages/libelf/libelf_0.8.3.bb
index e69de29bb2..9332b1802f 100644
--- a/packages/libelf/libelf_0.8.3.bb
+++ b/packages/libelf/libelf_0.8.3.bb
@@ -0,0 +1,33 @@
+SECTION = "libs"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DESCRIPTION = "an ELF object file access library \
+The elf library provides routines to access, and manipulate, Elf object \
+files. It is still not complete, but is required for a number of programs, \
+such as Eli (a state of the art compiler generation system), and Elk (the \
+Extension Language Kit - an implementation of the Scheme programming \
+language.)"
+LICENSE = "LGPL"
+SRC_URI = "http://www.stud.uni-hannover.de/~michael/software/libelf-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure_prepend () {
+ if test ! -e acinclude.m4; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
+ 'libdir=${D}${libdir}' 'includedir=${D}${includedir}' \
+ install
+}
+
+do_stage () {
+ oe_libinstall -so -C lib libelf ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/libelf
+ for i in libelf.h nlist.h gelf.h sys_elf.h; do
+ install -m 0644 lib/$i ${STAGING_INCDIR}/libelf/
+ done
+ make includedir=${STAGING_INCDIR} install-compat
+}