aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libetpan/files
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-05-09 10:06:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-09 10:06:07 +0000
commit7dcec34e18da3d41ba29a0997f0a2395655674c3 (patch)
treec855616df4aaf070fc3adc69d92eba8b44177352 /packages/libetpan/files
parent54a4531a696110179198dacbf16a9d9b63f24cc6 (diff)
downloadopenembedded-7dcec34e18da3d41ba29a0997f0a2395655674c3.tar.gz
packages/libetpan/libetpan_0.45.bb : new version of libetpan required for
sylpheed-claws. This version I have fixed building with threads so it is slightly more than just a version bump so other users of libetpan please check for regressions. packages/sylpheed/sylpheed-claws_2.2.0.bb : add sylpheed-claws, the brother of sylpheed with more dev/unstable work.
Diffstat (limited to 'packages/libetpan/files')
-rw-r--r--packages/libetpan/files/configure-pthreads.patch11
-rw-r--r--packages/libetpan/files/mailstream.patch21
2 files changed, 32 insertions, 0 deletions
diff --git a/packages/libetpan/files/configure-pthreads.patch b/packages/libetpan/files/configure-pthreads.patch
new file mode 100644
index 0000000000..c8f9566bd9
--- /dev/null
+++ b/packages/libetpan/files/configure-pthreads.patch
@@ -0,0 +1,11 @@
+--- libetpan-0.45/configure.in.orig 2006-05-09 09:48:36.000000000 +0100
++++ libetpan-0.45/configure.in 2006-05-09 09:48:55.000000000 +0100
+@@ -350,7 +350,7 @@
+ LDFLAGS="-$flag $LDFLAGS"
+ AC_TRY_LINK([], [pthread_create();],
+ [pthflag=yes; checkpthread=no],
+- [pthflag=no; LDFLAGS="$OLDCFLAGS"])
++ [pthflag=no; LDFLAGS="$OLDFLAGS"])
+ AC_MSG_RESULT($pthflag)
+ fi
+ done
diff --git a/packages/libetpan/files/mailstream.patch b/packages/libetpan/files/mailstream.patch
new file mode 100644
index 0000000000..2d0dad06fd
--- /dev/null
+++ b/packages/libetpan/files/mailstream.patch
@@ -0,0 +1,21 @@
+diff -urNad libetpan-0.45~/src/data-types/mailstream_ssl.c libetpan-0.45/src/data-types/mailstream_ssl.c
+--- libetpan-0.45~/src/data-types/mailstream_ssl.c 2006-02-17 23:45:14.000000000 +0300
++++ libetpan-0.45/src/data-types/mailstream_ssl.c 2006-04-17 19:11:48.609551256 +0400
+@@ -448,7 +448,7 @@
+ break;
+
+ default:
+- return r;
++ return -1;
+ }
+ }
+ }
+@@ -486,7 +486,7 @@
+ break;
+
+ default:
+- return r;
++ return -1;
+ }
+ }
+ }