aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libetpan
diff options
context:
space:
mode:
authoralwin@zeckescompany.nl <alwin@zeckescompany.nl>2005-03-11 21:07:56 +0000
committeralwin@zeckescompany.nl <alwin@zeckescompany.nl>2005-03-11 21:07:56 +0000
commit6f3456774eeb819e7ec4942b3a35df9c0b12c37a (patch)
tree4f04eeddc040fe08a2f0a2c4ecbbf700064b3e9c /packages/libetpan
parent243e93c1e6d78c34ed7ee5338adf6a4b06daf13b (diff)
downloadopenembedded-6f3456774eeb819e7ec4942b3a35df9c0b12c37a.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into zeckescompany.nl:/home/ral/progs/Zaurus/oe/openembedded 2005/03/11 22:07:26+01:00 zeckescompany.nl!alwin try to get libetpan gnutls ready. It doesn't work this moment on ARM platforms so openssl is default BKrev: 423208acRY3QQy8e70AUIRKk4c-zNg
Diffstat (limited to 'packages/libetpan')
-rw-r--r--packages/libetpan/libetpan-0.36/etpan_configure.patch55
-rw-r--r--packages/libetpan/libetpan-0.36/gnutls.patch0
-rw-r--r--packages/libetpan/libetpan_0.36.bb5
3 files changed, 58 insertions, 2 deletions
diff --git a/packages/libetpan/libetpan-0.36/etpan_configure.patch b/packages/libetpan/libetpan-0.36/etpan_configure.patch
index e69de29bb2..3572339010 100644
--- a/packages/libetpan/libetpan-0.36/etpan_configure.patch
+++ b/packages/libetpan/libetpan-0.36/etpan_configure.patch
@@ -0,0 +1,55 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- libetpan/configure.in~etpan_configure 2005-03-10 10:11:29.000000000 +0100
++++ libetpan/configure.in 2005-03-11 13:57:00.232491234 +0100
+@@ -76,6 +76,38 @@
+ esac
+ fi
+
++dnl GNUTLS
++AC_ARG_WITH(gnutls, [ --with-gnutls[=DIR] include GnuTLS support (default=no)],
++ [], [with_gnutls=no])
++if test "x$with_gnutls" != "xno"; then
++ OCPPFLAGS="$CPPFLAGS"
++ OLDFLAGS="$LDFLAGS"
++ if test "x$with_gnutls" != "xyes" ; then
++ CPPFLAGS="CRPPFLAGS -I$with_gnutls/include"
++ LDFLAGS="$LDFLAGS -L$with_gnutls/lib"
++ fi
++ GNUTLSLIBS=""
++ AC_CHECK_HEADER(gnutls/gnutls.h, [
++ AC_CHECK_LIB(gnutls, gnutls_global_deinit, with_gnutls=yes,[GNUTLSLIBS="-lgnutls -lgnutls-openssl"])
++ ])
++ if test "x$with_gnutls" != "xyes"; then
++ CPPFLAGS="$OCPPFLAGS"
++ LDFLAGS="$OLDFLAGS"
++ else
++ with_openssl="no"
++ fi
++fi
++
++if test "x$with_gnutls" = "xyes"; then
++ AC_DEFINE([USE_GNUTLS],1, [Define to use GnuTLS])
++ AC_DEFINE([USE_SSL], 1, [Define to use OpenSSL])
++ GNUTLSLIBS="-lgnutls -lgnutls-openssl"
++else
++ AC_MSG_WARN([GnuTLS support disabled.])
++ GNUTLSLIBS=""
++fi
++AC_SUBST(GNUTLSLIBS)
++
+ dnl OpenSSL -- very primitive right now
+ AC_ARG_WITH(openssl, [ --with-openssl[=DIR] include OpenSSL support (default=auto)],
+ [], [with_openssl=yes])
+@@ -336,7 +368,7 @@
+ REENTRANT=1
+ else
+ REENTRANT=0
+- LIBSUFFIX=-no-mt
++ LIBSUFFIX=
+ fi
+ AC_SUBST(LIBSUFFIX)
+ AC_SUBST(REENTRANT)
diff --git a/packages/libetpan/libetpan-0.36/gnutls.patch b/packages/libetpan/libetpan-0.36/gnutls.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libetpan/libetpan-0.36/gnutls.patch
diff --git a/packages/libetpan/libetpan_0.36.bb b/packages/libetpan/libetpan_0.36.bb
index 4ec2be81bd..1a6c989d5a 100644
--- a/packages/libetpan/libetpan_0.36.bb
+++ b/packages/libetpan/libetpan_0.36.bb
@@ -3,13 +3,14 @@ SMTP, POP, IMAP and NNTP"
SECTION = "libs"
DEPENDS = "openssl"
PV = "0.36"
-PR = "r1"
+PR = "r3"
S = "${WORKDIR}/libetpan"
TAG="rel-0-36"
LICENSE = "BSD"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/libetpan;tag=${TAG};module=libetpan \
file://etpan_configure.patch;patch=1 \
- file://reentrant.patch;patch=1 "
+ file://reentrant.patch;patch=1 \
+ file://gnutls.patch;patch=1 "
inherit autotools pkgconfig gettext