aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libfakekey
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-04-21 21:53:26 +0000
committerKoen Kooi <koen@openembedded.org>2005-04-21 21:53:26 +0000
commita5069468b48642a47db7bfcfeee81504301d1734 (patch)
tree9ac64b48eac97b56481dbabb3e5f32aebfa7ddde /packages/libfakekey
parent429b2bb0e8e465b75ad63420e920d8e58b3afa98 (diff)
downloadopenembedded-a5069468b48642a47db7bfcfeee81504301d1734.tar.gz
libfakekey_svn.bb:
use oe_libinstall stage the libs stage header correctly stage a header BKrev: 426820d6mPh1CFF918oXuzxhWfe-CQ
Diffstat (limited to 'packages/libfakekey')
-rw-r--r--packages/libfakekey/libfakekey_svn.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/libfakekey/libfakekey_svn.bb b/packages/libfakekey/libfakekey_svn.bb
index e69de29bb2..3e8db0e59e 100644
--- a/packages/libfakekey/libfakekey_svn.bb
+++ b/packages/libfakekey/libfakekey_svn.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Matchbox keyboard"
+LICENSE = "GPL"
+DEPENDS = "xtst"
+SECTION = "x11/wm"
+PR="r1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+
+S = ${WORKDIR}/${PN}
+
+inherit autotools pkgconfig gettext
+
+FILES_${PN} = "${libdir} \
+ ${datadir}/applications \
+ ${datadir}/pixmaps"
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/fakekey
+ install -m 0644 ${S}/fakekey/fakekey.h ${STAGING_INCDIR}/fakekey
+ oe_libinstall -so -C src libfakekey ${STAGING_LIBDIR}
+}
+