aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libgcrypt
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-24 01:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-24 01:40:08 +0000
commita702a4829935cbe81edef1de716bc81664f94e0a (patch)
treeb9e32f8d19be7ba4b12a7d1a55c2e5ff74b14209 /packages/libgcrypt
parent58b704b108847c779bf8fef38bd523183207c1ae (diff)
downloadopenembedded-a702a4829935cbe81edef1de716bc81664f94e0a.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 19:29:51-06:00 ti.com!kergoth Rename gnupg-devel to gnupg2, since this development branch has the binaries postfixed that way, so is clearly for the upcoming 2.x stable release. Also change libexecdir from /usr/libexec to /usr/libexec/gnupg2, as it was resulting in the gnupg binaries ending up in the root of /usr/libexec, rather than by packagename. 2005/02/23 19:24:52-06:00 ti.com!kergoth Fix the ipk rootfs/image classes to use ${libdir}/ipkg, now that ipkg does so as well. 2005/02/23 19:22:38-06:00 ti.com!kergoth Add a development version of gnupg (version 1.9.15) as gnupg-devel. Note that the 'gpgsm' and 'scdaemon' binaries are not currently being built, due to the additional dependencies they introduce. If you need them, let me know. One issue that needs to be fixed is that the gnupg-devel build needs to prefix or postfix its binaries, or conflict with 'gnupg', to ensure they don't step on one another's toes. 2005/02/23 19:18:34-06:00 ti.com!kergoth Add libgpg-error 1.0 (required by gnupg 0.9.15) and make the libgpg-error .bb's inherit binconfig. 2005/02/23 19:17:35-06:00 ti.com!kergoth Add libgcrypt 1.2.1 and make the libgcrypt .bb's inherit binconfig. 2005/02/23 19:16:20-06:00 ti.com!kergoth Add libassuan 0.6.9 (required by gnupg 0.9.15) and make the libassuan .bb's inherit binconfig. BKrev: 421d3078taXhU4QcW7mi0rDTzgYsgA
Diffstat (limited to 'packages/libgcrypt')
-rw-r--r--packages/libgcrypt/libgcrypt_1.1.91.bb33
-rw-r--r--packages/libgcrypt/libgcrypt_1.2.0.bb29
-rw-r--r--packages/libgcrypt/libgcrypt_1.2.1.bb0
3 files changed, 62 insertions, 0 deletions
diff --git a/packages/libgcrypt/libgcrypt_1.1.91.bb b/packages/libgcrypt/libgcrypt_1.1.91.bb
index e69de29bb2..c4259eb0f3 100644
--- a/packages/libgcrypt/libgcrypt_1.1.91.bb
+++ b/packages/libgcrypt/libgcrypt_1.1.91.bb
@@ -0,0 +1,33 @@
+PR = "r3"
+DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+DEPENDS = "libgpg-error"
+
+PACKAGES =+ "libgcrypt-pthread libgcrypt-pthread-dev"
+
+# move libgcrypt-config into -dev package
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"
+FILES_libgcrypt-pthread = "${libdir}/libgcrypt-pthread.so.*"
+FILES_libgcrypt-pthread-dev = "${libdir}/libgcrypt-pthread.*"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/libgcrypt-${PV}.tar.gz"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--without-pth"
+
+do_stage() {
+ oe_libinstall -so -C src libgcrypt ${STAGING_LIBDIR}
+ oe_libinstall -so -C src libgcrypt-pthread ${STAGING_LIBDIR}
+ install -m 0755 src/libgcrypt-config ${STAGING_BINDIR}/
+
+ install -d ${STAGING_INCDIR}/
+ for X in gcrypt.h gcrypt-module.h
+ do
+ install -m 0644 src/${X} ${STAGING_INCDIR}/${X}
+ done
+
+}
diff --git a/packages/libgcrypt/libgcrypt_1.2.0.bb b/packages/libgcrypt/libgcrypt_1.2.0.bb
index e69de29bb2..d961e4f84a 100644
--- a/packages/libgcrypt/libgcrypt_1.2.0.bb
+++ b/packages/libgcrypt/libgcrypt_1.2.0.bb
@@ -0,0 +1,29 @@
+PR = "r2"
+DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+DEPENDS = "libgpg-error"
+
+# move libgcrypt-config into -dev package
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz"
+
+inherit autotools binconfig
+
+EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
+
+do_stage() {
+ oe_libinstall -so -C src libgcrypt ${STAGING_LIBDIR}
+ oe_libinstall -so -C src libgcrypt-pthread ${STAGING_LIBDIR}
+ install -m 0755 src/libgcrypt-config ${STAGING_BINDIR}/
+
+ install -d ${STAGING_INCDIR}/
+ for X in gcrypt.h gcrypt-module.h
+ do
+ install -m 0644 src/${X} ${STAGING_INCDIR}/${X}
+ done
+
+}
diff --git a/packages/libgcrypt/libgcrypt_1.2.1.bb b/packages/libgcrypt/libgcrypt_1.2.1.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libgcrypt/libgcrypt_1.2.1.bb