aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libgpevtype
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2005-02-05 00:07:26 +0000
committerPhil Blundell <philb@gnu.org>2005-02-05 00:07:26 +0000
commitd3e318c4947e7bfafdc033d6b9c16e9ad9edd6ad (patch)
treecc3c78c26953b1f0d39d931b804e51745493c7da /packages/libgpevtype
parent517f4b77bafd26664c8de0096d94bffbf8c7530b (diff)
downloadopenembedded-d3e318c4947e7bfafdc033d6b9c16e9ad9edd6ad.tar.gz
adjust libgpevtype do_compile() to avoid gtk-doc requirement
BKrev: 42040e3ecLKpPMuaMnNSRLRkrb84RQ
Diffstat (limited to 'packages/libgpevtype')
-rw-r--r--packages/libgpevtype/libgpevtype_0.7.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/libgpevtype/libgpevtype_0.7.bb b/packages/libgpevtype/libgpevtype_0.7.bb
index e69de29bb2..feacea6ce6 100644
--- a/packages/libgpevtype/libgpevtype_0.7.bb
+++ b/packages/libgpevtype/libgpevtype_0.7.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Data interchange library for GPE"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+MAINTAINER = "Philip Blundell <pb@handhelds.org>"
+DEPENDS = "libmimedir"
+PR = "r1"
+
+inherit pkgconfig gpe
+
+headers = "tag-db.h vcard.h vevent.h vtodo.h"
+
+do_compile() {
+ oe_runmake libgpevtype.so libgpevtype.pc
+}
+
+do_stage () {
+ oe_libinstall -so libgpevtype ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/${h}
+ done
+}