aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libsdl
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-01-19 16:05:56 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-19 16:05:56 +0000
commit6a60da3999e56c05836b20df3bbd058438edf2e3 (patch)
tree968b50608f9c797941b8591956a6840bca2e9e2f /packages/libsdl
parented064a37b1109867c31c21f792a5f11760e63bbc (diff)
downloadopenembedded-6a60da3999e56c05836b20df3bbd058438edf2e3.tar.gz
libsdl-(qpe|x11|mixer): update to cleaned state from .dev
- rev 849f38b93223ee6bb8e862ca52fb93cf822597c7 - libsdl-mixer: set SDL_CONFIG (see bug #500) - rev beeae2bd3ca26555bfc0b9e933ce7e51fc53ab80 - libsdl-x11 1.2.7: enable cdrom support, need for scummvm. Also bump PR for -qpe version - rev e5ed779bbcac2d7c6e324cc7fcabb5259dbed245 - libsdl: disable building static lib, don't install libtool .la file - libsdl-qpe: fix sdl-config flags for compatibility with libsdl-x11 taken from .dev
Diffstat (limited to 'packages/libsdl')
-rw-r--r--packages/libsdl/libsdl-mixer_1.2.6.bb3
-rw-r--r--packages/libsdl/libsdl-qpe-1.2.7/fixlibs.patch25
-rw-r--r--packages/libsdl/libsdl-qpe_1.2.7.bb8
-rw-r--r--packages/libsdl/libsdl-x11_1.2.7.bb7
4 files changed, 37 insertions, 6 deletions
diff --git a/packages/libsdl/libsdl-mixer_1.2.6.bb b/packages/libsdl/libsdl-mixer_1.2.6.bb
index 4a273fffed..3aafa18d0c 100644
--- a/packages/libsdl/libsdl-mixer_1.2.6.bb
+++ b/packages/libsdl/libsdl-mixer_1.2.6.bb
@@ -4,10 +4,13 @@ PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
DEPENDS = "virtual/libsdl"
LICENSE = "LGPL"
+PR = "r1"
SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
S = "${WORKDIR}/SDL_mixer-${PV}"
+export SDL_CONFIG = "${STAGING_BINDIR}/sdl-config"
+
inherit autotools
EXTRA_OECONF = "--disable-music-mp3 --disable-music-libmikmod"
diff --git a/packages/libsdl/libsdl-qpe-1.2.7/fixlibs.patch b/packages/libsdl/libsdl-qpe-1.2.7/fixlibs.patch
new file mode 100644
index 0000000000..899e31482c
--- /dev/null
+++ b/packages/libsdl/libsdl-qpe-1.2.7/fixlibs.patch
@@ -0,0 +1,25 @@
+--- SDL-1.2.7/configure.in~fixlibs 2005-10-06 10:27:59.025396872 +0200
++++ SDL-1.2.7/configure.in 2005-10-06 10:30:16.963087411 +0200
+@@ -1508,8 +1508,8 @@
+ AC_MSG_RESULT($video_qtopia)
+ if test x$video_qtopia = xyes; then
+ CFLAGS="$CFLAGS -DENABLE_QTOPIA -DQT_QWS_EBX -DQT_QWS_CUSTOM -DQWS -I${QPEDIR}/include -I${QTDIR}/include/ -DNO_DEBUG -fno-rtti -fno-exceptions"
+- SDL_LIBS="$SDL_LIBS -L${QPEDIR}/lib -L${QTDIR}/lib/ -lqpe -lqte"
+- SDL_CFLAGS="$SDL_CFLAGS -DQWS"
++ SDL_LIBS="$SDL_LIBS -Wl,-rpath-link -Wl,${QPEDIR}/lib -Wl,-rpath-link -Wl,${QTDIR}/lib"
++ SYSTEM_LIBS="$SYSTEM_LIBS -L${QPEDIR}/lib -L${QTDIR}/lib/ -lqpe -lqte"
+ VIDEO_SUBDIRS="$VIDEO_SUBDIRS qtopia"
+ VIDEO_DRIVERS="$VIDEO_DRIVERS qtopia/libvideo_qtopia.la"
+ else
+@@ -1803,11 +1803,6 @@
+ CheckPTHREAD
+ CheckSIGACTION
+ CheckAltivec
+- # Set up files for the main() stub
+- if test "x$video_qtopia" = "xyes"; then
+- SDL_CFLAGS="$SDL_CFLAGS -Dmain=SDL_main"
+-
+- fi
+ # Set up files for the audio library
+ # We use the OSS and ALSA API's, not the Sun audio API
+ #if test x$enable_audio = xyes; then
diff --git a/packages/libsdl/libsdl-qpe_1.2.7.bb b/packages/libsdl/libsdl-qpe_1.2.7.bb
index 54dc975fb5..5eaf9c54b0 100644
--- a/packages/libsdl/libsdl-qpe_1.2.7.bb
+++ b/packages/libsdl/libsdl-qpe_1.2.7.bb
@@ -7,7 +7,7 @@ PROVIDES = "virtual/libsdl"
LICENSE = "LGPL"
# NOTE: make sure to keep PR in sync with libsdl-x11
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://agawa-piro-mickey.patch;patch=1 \
@@ -16,12 +16,13 @@ SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://mouse.patch;patch=1 \
file://kill-stdc++.patch;patch=1 \
file://ipaq.patch;patch=1 \
- file://SDL-Akita.patch;patch=1"
+ file://SDL-Akita.patch;patch=1 \
+ file://fixlibs.patch;patch=1"
S = "${WORKDIR}/SDL-${PV}"
inherit autotools binconfig
-EXTRA_OECONF = "--disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
+EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
--enable-file --enable-oss --disable-alsa --disable-esd --disable-arts \
--disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
--disable-mintaudio --disable-nasm --disable-video-x11 --disable-video-dga \
@@ -35,6 +36,7 @@ FILES_${PN}-dev += "${bindir}/*config"
do_stage() {
oe_libinstall -so -C src libSDL ${STAGING_LIBDIR}
+ rm ${STAGING_LIBDIR}/libSDL.la
ln -sf libSDL.so ${STAGING_LIBDIR}/libSDL-1.2.so
install -m 0655 src/main/libSDLmain.a src/main/.libs/
oe_libinstall -a -C src/main libSDLmain ${STAGING_LIBDIR}
diff --git a/packages/libsdl/libsdl-x11_1.2.7.bb b/packages/libsdl/libsdl-x11_1.2.7.bb
index d79f91937a..e65fe4fba3 100644
--- a/packages/libsdl/libsdl-x11_1.2.7.bb
+++ b/packages/libsdl/libsdl-x11_1.2.7.bb
@@ -1,13 +1,13 @@
DESCRIPTION = "Simple DirectMedia Layer - X11 Edition"
SECTION = "libs"
PRIORITY = "optional"
-MAINTAINER = "Phil Blundell <pb@nexus.co.uk>"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
DEPENDS = "x11 xext"
PROVIDES = "virtual/libsdl"
LICENSE = "LGPL"
# NOTE: make sure to keep PR in sync with libsdl-qpe
-PR = "r6"
+PR = "r7"
SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://extra-keys.patch;patch=1 \
@@ -16,7 +16,7 @@ S = "${WORKDIR}/SDL-${PV}"
inherit autotools binconfig
-EXTRA_OECONF = "--disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
+EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
--enable-file --enable-oss --enable-alsa --disable-esd --disable-arts \
--disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
--disable-mintaudio --disable-nasm --enable-video-x11 --disable-video-dga \
@@ -43,6 +43,7 @@ do_configure_append () {
do_stage() {
oe_libinstall -so -C src libSDL ${STAGING_LIBDIR}
+ rm ${STAGING_LIBDIR}/libSDL.la
ln -sf libSDL.so ${STAGING_LIBDIR}/libSDL-1.2.so
#oe_libinstall -a -C src/main libSDLmain ${STAGING_LIBDIR}
install -m 0644 src/main/libSDLmain.a ${STAGING_LIBDIR}