aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libsdl
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/libsdl
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/libsdl')
-rw-r--r--packages/libsdl/.mtn2git_empty0
-rw-r--r--packages/libsdl/libsdl-gfx_2.0.11.bb19
-rw-r--r--packages/libsdl/libsdl-image_1.2.3.bb18
-rw-r--r--packages/libsdl/libsdl-mixer_1.2.6.bb22
-rw-r--r--packages/libsdl/libsdl-net_1.2.5.bb18
-rw-r--r--packages/libsdl/libsdl-qpe-1.2.7/.mtn2git_empty0
-rw-r--r--packages/libsdl/libsdl-qpe-1.2.7/acinclude.m4189
-rw-r--r--packages/libsdl/libsdl-qpe-1.2.7/gcc34.patch176
-rw-r--r--packages/libsdl/libsdl-qpe-1.2.7/mouse.patch47
-rw-r--r--packages/libsdl/libsdl-ttf-2.0.3/.mtn2git_empty0
-rw-r--r--packages/libsdl/libsdl-ttf-2.0.3/new-freetype-includes.patch17
-rw-r--r--packages/libsdl/libsdl-ttf_2.0.3.bb18
-rw-r--r--packages/libsdl/libsdl-x11-1.2.7/.mtn2git_empty0
-rw-r--r--packages/libsdl/libsdl-x11-1.2.7/acinclude.m4189
-rw-r--r--packages/libsdl/libsdl-x11-1.2.7/extra-keys.patch53
15 files changed, 766 insertions, 0 deletions
diff --git a/packages/libsdl/.mtn2git_empty b/packages/libsdl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libsdl/.mtn2git_empty
diff --git a/packages/libsdl/libsdl-gfx_2.0.11.bb b/packages/libsdl/libsdl-gfx_2.0.11.bb
index e69de29bb2..96cf7c502d 100644
--- a/packages/libsdl/libsdl-gfx_2.0.11.bb
+++ b/packages/libsdl/libsdl-gfx_2.0.11.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Simple DirectMedia Layer graphic primitives library."
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "zlib libpng jpeg virtual/libsdl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.ferzkopp.net/~aschiffler/Software/SDL_gfx-2.0/SDL_gfx-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_gfx-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-mmx"
+
+do_stage() {
+ oe_libinstall -so libSDL_gfx ${STAGING_LIBDIR}
+ install -m 0644 *.h ${STAGING_INCDIR}/SDL/
+}
+
diff --git a/packages/libsdl/libsdl-image_1.2.3.bb b/packages/libsdl/libsdl-image_1.2.3.bb
index e69de29bb2..c8568473e4 100644
--- a/packages/libsdl/libsdl-image_1.2.3.bb
+++ b/packages/libsdl/libsdl-image_1.2.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Simple DirectMedia Layer image library."
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "zlib libpng jpeg virtual/libsdl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_image-${PV}"
+
+inherit autotools
+
+do_stage() {
+ oe_libinstall -so libSDL_image ${STAGING_LIBDIR}
+ ln -sf libSDL_image.so ${STAGING_LIBDIR}/libSDL_image-1.2.so
+ install -m 0644 SDL_image.h ${STAGING_INCDIR}/SDL/SDL_image.h
+}
+
diff --git a/packages/libsdl/libsdl-mixer_1.2.6.bb b/packages/libsdl/libsdl-mixer_1.2.6.bb
index e69de29bb2..4a273fffed 100644
--- a/packages/libsdl/libsdl-mixer_1.2.6.bb
+++ b/packages/libsdl/libsdl-mixer_1.2.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "virtual/libsdl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-music-mp3 --disable-music-libmikmod"
+# although we build smpeg... need to find out how
+# to deal with optional dependencies
+
+do_stage() {
+ oe_libinstall -so libSDL_mixer ${STAGING_LIBDIR}
+ ln -sf libSDL_mixer.so ${STAGING_LIBDIR}/libSDL_mixer-1.2.so
+ install -m 0644 SDL_mixer.h ${STAGING_INCDIR}/SDL/SDL_mixer.h
+}
+
diff --git a/packages/libsdl/libsdl-net_1.2.5.bb b/packages/libsdl/libsdl-net_1.2.5.bb
index e69de29bb2..1e5f9f81c2 100644
--- a/packages/libsdl/libsdl-net_1.2.5.bb
+++ b/packages/libsdl/libsdl-net_1.2.5.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Simple DirectMedia Layer networking library."
+SECTION = "libs/network"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "virtual/libsdl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_net/release/SDL_net-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_net-${PV}"
+
+inherit autotools
+
+do_stage() {
+ oe_libinstall -so libSDL_net ${STAGING_LIBDIR}
+ ln -sf libSDL_net.so ${STAGING_LIBDIR}/libSDL_net-1.2.so
+ install -m 0644 SDL_net.h ${STAGING_INCDIR}/SDL/SDL_net.h
+}
+
diff --git a/packages/libsdl/libsdl-qpe-1.2.7/.mtn2git_empty b/packages/libsdl/libsdl-qpe-1.2.7/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libsdl/libsdl-qpe-1.2.7/.mtn2git_empty
diff --git a/packages/libsdl/libsdl-qpe-1.2.7/acinclude.m4 b/packages/libsdl/libsdl-qpe-1.2.7/acinclude.m4
index e69de29bb2..ca2df9d5e5 100644
--- a/packages/libsdl/libsdl-qpe-1.2.7/acinclude.m4
+++ b/packages/libsdl/libsdl-qpe-1.2.7/acinclude.m4
@@ -0,0 +1,189 @@
+# Local macros for the SDL configure.in script
+
+dnl Function to link an architecture specific file
+dnl LINK_ARCH_SRC(source_dir, arch, source_file)
+AC_DEFUN([COPY_ARCH_SRC],
+[
+ old="$srcdir/$1/$2/$3"
+ new="$1/$3"
+ if test ! -d $1; then
+ echo "Creating directory $1"
+ mkdir -p $1
+ fi
+ echo "Copying $old -> $new"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+])
+
+#
+# --- esd.m4 ---
+#
+# Configure paths for ESD
+# Manish Singh 98-9-30
+# stolen back from Frank Belew
+# stolen from Manish Singh
+# Shamelessly stolen from Owen Taylor
+
+dnl AM_PATH_ESD([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+dnl Test for ESD, and define ESD_CFLAGS and ESD_LIBS
+dnl
+AC_DEFUN([AM_PATH_ESD],
+[dnl
+dnl Get the cflags and libraries from the esd-config script
+dnl
+AC_ARG_WITH(esd-prefix,[ --with-esd-prefix=PFX Prefix where ESD is installed (optional)],
+ esd_prefix="$withval", esd_prefix="")
+AC_ARG_WITH(esd-exec-prefix,[ --with-esd-exec-prefix=PFX Exec prefix where ESD is installed (optional)],
+ esd_exec_prefix="$withval", esd_exec_prefix="")
+AC_ARG_ENABLE(esdtest, [ --disable-esdtest Do not try to compile and run a test ESD program],
+ , enable_esdtest=yes)
+
+ if test x$esd_exec_prefix != x ; then
+ esd_args="$esd_args --exec-prefix=$esd_exec_prefix"
+ if test x${ESD_CONFIG+set} != xset ; then
+ ESD_CONFIG=$esd_exec_prefix/bin/esd-config
+ fi
+ fi
+ if test x$esd_prefix != x ; then
+ esd_args="$esd_args --prefix=$esd_prefix"
+ if test x${ESD_CONFIG+set} != xset ; then
+ ESD_CONFIG=$esd_prefix/bin/esd-config
+ fi
+ fi
+
+ AC_PATH_PROG(ESD_CONFIG, esd-config, no)
+ min_esd_version=ifelse([$1], ,0.2.7,$1)
+ AC_MSG_CHECKING(for ESD - version >= $min_esd_version)
+ no_esd=""
+ if test "$ESD_CONFIG" = "no" ; then
+ no_esd=yes
+ else
+ ESD_CFLAGS=`$ESD_CONFIG $esdconf_args --cflags`
+ ESD_LIBS=`$ESD_CONFIG $esdconf_args --libs`
+
+ esd_major_version=`$ESD_CONFIG $esd_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+ esd_minor_version=`$ESD_CONFIG $esd_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+ esd_micro_version=`$ESD_CONFIG $esd_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ if test "x$enable_esdtest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $ESD_CFLAGS"
+ LIBS="$LIBS $ESD_LIBS"
+dnl
+dnl Now check if the installed ESD is sufficiently new. (Also sanity
+dnl checks the results of esd-config to some extent
+dnl
+ rm -f conf.esdtest
+ AC_TRY_RUN([
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <esd.h>
+
+char*
+my_strdup (char *str)
+{
+ char *new_str;
+
+ if (str)
+ {
+ new_str = malloc ((strlen (str) + 1) * sizeof(char));
+ strcpy (new_str, str);
+ }
+ else
+ new_str = NULL;
+
+ return new_str;
+}
+
+int main ()
+{
+ int major, minor, micro;
+ char *tmp_version;
+
+ system ("touch conf.esdtest");
+
+ /* HP/UX 9 (%@#!) writes to sscanf strings */
+ tmp_version = my_strdup("$min_esd_version");
+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
+ printf("%s, bad version string\n", "$min_esd_version");
+ exit(1);
+ }
+
+ if (($esd_major_version > major) ||
+ (($esd_major_version == major) && ($esd_minor_version > minor)) ||
+ (($esd_major_version == major) && ($esd_minor_version == minor) && ($esd_micro_version >= micro)))
+ {
+ return 0;
+ }
+ else
+ {
+ printf("\n*** 'esd-config --version' returned %d.%d.%d, but the minimum version\n", $esd_major_version, $esd_minor_version, $esd_micro_version);
+ printf("*** of ESD required is %d.%d.%d. If esd-config is correct, then it is\n", major, minor, micro);
+ printf("*** best to upgrade to the required version.\n");
+ printf("*** If esd-config was wrong, set the environment variable ESD_CONFIG\n");
+ printf("*** to point to the correct copy of esd-config, and remove the file\n");
+ printf("*** config.cache before re-running configure\n");
+ return 1;
+ }
+}
+
+],, no_esd=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ if test "x$no_esd" = x ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$2], , :, [$2])
+ else
+ AC_MSG_RESULT(no)
+ if test "$ESD_CONFIG" = "no" ; then
+ echo "*** The esd-config script installed by ESD could not be found"
+ echo "*** If ESD was installed in PREFIX, make sure PREFIX/bin is in"
+ echo "*** your path, or set the ESD_CONFIG environment variable to the"
+ echo "*** full path to esd-config."
+ else
+ if test -f conf.esdtest ; then
+ :
+ else
+ echo "*** Could not run ESD test program, checking why..."
+ CFLAGS="$CFLAGS $ESD_CFLAGS"
+ LIBS="$LIBS $ESD_LIBS"
+ AC_TRY_LINK([
+#include <stdio.h>
+#include <esd.h>
+], [ return 0; ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding ESD or finding the wrong"
+ echo "*** version of ESD. If it is not finding ESD, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means ESD was incorrectly installed"
+ echo "*** or that you have moved ESD since it was installed. In the latter case, you"
+ echo "*** may want to edit the esd-config script: $ESD_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ ESD_CFLAGS=""
+ ESD_LIBS=""
+ ifelse([$3], , :, [$3])
+ fi
+ AC_SUBST(ESD_CFLAGS)
+ AC_SUBST(ESD_LIBS)
+ rm -f conf.esdtest
+])
+
diff --git a/packages/libsdl/libsdl-qpe-1.2.7/gcc34.patch b/packages/libsdl/libsdl-qpe-1.2.7/gcc34.patch
index e69de29bb2..e3738e961e 100644
--- a/packages/libsdl/libsdl-qpe-1.2.7/gcc34.patch
+++ b/packages/libsdl/libsdl-qpe-1.2.7/gcc34.patch
@@ -0,0 +1,176 @@
+diff -ru SDL-1.2.7/src/audio/SDL_mixer_MMX.c SDL-1.2.7.mod/src/audio/SDL_mixer_MMX.c
+--- SDL-1.2.7/src/audio/SDL_mixer_MMX.c 2002-11-09 07:13:28.000000000 +0100
++++ SDL-1.2.7.mod/src/audio/SDL_mixer_MMX.c 2004-04-25 18:15:46.335228624 +0200
+@@ -19,9 +19,9 @@
+ " movl %1,%%esi\n" // esi = src
+ " movl %3,%%eax\n" // eax = volume
+
+-" movl %2,%%ebx\n" // ebx = size
++" movl %2,%%edx\n" // edx = size
+
+-" shrl $4,%%ebx\n" // process 16 bytes per iteration = 8 samples
++" shrl $4,%%edx\n" // process 16 bytes per iteration = 8 samples
+
+ " jz .endS16\n"
+
+@@ -95,7 +95,7 @@
+
+ " addl $16,%%edi\n"
+
+-" dec %%ebx\n"
++" dec %%edx\n"
+
+ " jnz .mixloopS16\n"
+
+@@ -105,7 +105,7 @@
+ :
+ : "m" (dst), "m"(src),"m"(size),
+ "m"(volume)
+- : "eax","ebx", "esi", "edi","memory"
++ : "eax","edx", "esi", "edi","memory"
+ );
+ }
+
+@@ -123,7 +123,7 @@
+ " movl %1,%%esi\n" // esi = src
+ " movl %3,%%eax\n" // eax = volume
+
+-" movd %%ebx,%%mm0\n"
++" movd %%edx,%%mm0\n"
+ " movq %%mm0,%%mm1\n"
+ " psllq $16,%%mm0\n"
+ " por %%mm1,%%mm0\n"
+@@ -132,10 +132,10 @@
+ " psllq $16,%%mm0\n"
+ " por %%mm1,%%mm0\n"
+
+-" movl %2,%%ebx\n" // ebx = size
+-" shr $3,%%ebx\n" // process 8 bytes per iteration = 8 samples
++" movl %2,%%edx\n" // edx = size
++" shr $3,%%edx\n" // process 8 bytes per iteration = 8 samples
+
+-" cmp $0,%%ebx\n"
++" cmp $0,%%edx\n"
+ " je .endS8\n"
+
+ ".align 16\n"
+@@ -169,7 +169,7 @@
+ " movq %%mm3,(%%edi)\n" // store back to ram
+ " addl $8,%%edi\n"
+
+-" dec %%ebx\n"
++" dec %%edx\n"
+
+ " jnz .mixloopS8\n"
+
+@@ -178,7 +178,7 @@
+ :
+ : "m" (dst), "m"(src),"m"(size),
+ "m"(volume)
+- : "eax","ebx", "esi", "edi","memory"
++ : "eax","edx", "esi", "edi","memory"
+ );
+ }
+ #endif
+diff -ru SDL-1.2.7/src/cpuinfo/SDL_cpuinfo.c SDL-1.2.7.mod/src/cpuinfo/SDL_cpuinfo.c
+--- SDL-1.2.7/src/cpuinfo/SDL_cpuinfo.c 2004-02-10 16:31:35.000000000 +0100
++++ SDL-1.2.7.mod/src/cpuinfo/SDL_cpuinfo.c 2004-04-25 18:15:46.336228472 +0200
+@@ -118,7 +118,7 @@
+ " movl %%edi,%%ebx\n"
+ : "=m" (features)
+ :
+- : "%eax", "%ebx", "%ecx", "%edx", "%edi"
++ : "%eax", "%ecx", "%edx", "%edi"
+ );
+ #elif defined(_MSC_VER)
+ __asm {
+@@ -153,7 +153,7 @@
+ " movl %%edi,%%ebx\n"
+ : "=m" (features)
+ :
+- : "%eax", "%ebx", "%ecx", "%edx", "%edi"
++ : "%eax", "%ecx", "%edx", "%edi"
+ );
+ #elif defined(_MSC_VER)
+ __asm {
+diff -ru SDL-1.2.7/src/video/SDL_yuv_mmx.c SDL-1.2.7.mod/src/video/SDL_yuv_mmx.c
+--- SDL-1.2.7/src/video/SDL_yuv_mmx.c 2004-02-18 18:22:04.000000000 +0100
++++ SDL-1.2.7.mod/src/video/SDL_yuv_mmx.c 2004-04-25 18:15:46.337228320 +0200
+@@ -120,12 +120,12 @@
+ "movd (%2), %%mm2\n" // 0 0 0 0 l3 l2 l1 l0
+ "punpcklbw %%mm7,%%mm1\n" // 0 v3 0 v2 00 v1 00 v0
+ "punpckldq %%mm1,%%mm1\n" // 00 v1 00 v0 00 v1 00 v0
+- "psubw _MMX_0080w,%%mm1\n" // mm1-128:r1 r1 r0 r0 r1 r1 r0 r0
++ "psubw %[_MMX_0080w],%%mm1\n" // mm1-128:r1 r1 r0 r0 r1 r1 r0 r0
+
+ // create Cr_g (result in mm0)
+ "movq %%mm1,%%mm0\n" // r1 r1 r0 r0 r1 r1 r0 r0
+- "pmullw _MMX_VgrnRGB,%%mm0\n"// red*-46dec=0.7136*64
+- "pmullw _MMX_VredRGB,%%mm1\n"// red*89dec=1.4013*64
++ "pmullw %[_MMX_VgrnRGB],%%mm0\n"// red*-46dec=0.7136*64
++ "pmullw %[_MMX_VredRGB],%%mm1\n"// red*89dec=1.4013*64
+ "psraw $6, %%mm0\n" // red=red/64
+ "psraw $6, %%mm1\n" // red=red/64
+
+@@ -134,8 +134,8 @@
+ "movq (%2,%4),%%mm3\n" // 0 0 0 0 L3 L2 L1 L0
+ "punpckldq %%mm3,%%mm2\n" // L3 L2 L1 L0 l3 l2 l1 l0
+ "movq %%mm2,%%mm4\n" // L3 L2 L1 L0 l3 l2 l1 l0
+- "pand _MMX_FF00w,%%mm2\n" // L3 0 L1 0 l3 0 l1 0
+- "pand _MMX_00FFw,%%mm4\n" // 0 L2 0 L0 0 l2 0 l0
++ "pand %[_MMX_FF00w],%%mm2\n" // L3 0 L1 0 l3 0 l1 0
++ "pand %[_MMX_00FFw],%%mm4\n" // 0 L2 0 L0 0 l2 0 l0
+ "psrlw $8,%%mm2\n" // 0 L3 0 L1 0 l3 0 l1
+
+ // create R (result in mm6)
+@@ -152,11 +152,11 @@
+ "movd (%1), %%mm1\n" // 0 0 0 0 u3 u2 u1 u0
+ "punpcklbw %%mm7,%%mm1\n" // 0 u3 0 u2 00 u1 00 u0
+ "punpckldq %%mm1,%%mm1\n" // 00 u1 00 u0 00 u1 00 u0
+- "psubw _MMX_0080w,%%mm1\n" // mm1-128:u1 u1 u0 u0 u1 u1 u0 u0
++ "psubw %[_MMX_0080w],%%mm1\n" // mm1-128:u1 u1 u0 u0 u1 u1 u0 u0
+ // create Cb_g (result in mm5)
+ "movq %%mm1,%%mm5\n" // u1 u1 u0 u0 u1 u1 u0 u0
+- "pmullw _MMX_UgrnRGB,%%mm5\n" // blue*-109dec=1.7129*64
+- "pmullw _MMX_UbluRGB,%%mm1\n" // blue*114dec=1.78125*64
++ "pmullw %[_MMX_UgrnRGB],%%mm5\n" // blue*-109dec=1.7129*64
++ "pmullw %[_MMX_UbluRGB],%%mm1\n" // blue*114dec=1.78125*64
+ "psraw $6, %%mm5\n" // blue=red/64
+ "psraw $6, %%mm1\n" // blue=blue/64
+
+@@ -238,8 +238,14 @@
+ "popl %%ebx\n"
+ :
+ : "m" (cr), "r"(cb),"r"(lum),
+- "r"(row1),"r"(cols),"r"(row2),"m"(x),"m"(y),"m"(mod)
+- : "%ebx"
++ "r"(row1),"r"(cols),"r"(row2),"m"(x),"m"(y),"m"(mod),
++ [_MMX_0080w] "m" (*_MMX_0080w),
++ [_MMX_00FFw] "m" (*_MMX_00FFw),
++ [_MMX_FF00w] "m" (*_MMX_FF00w),
++ [_MMX_VgrnRGB] "m" (*_MMX_VgrnRGB),
++ [_MMX_VredRGB] "m" (*_MMX_VredRGB),
++ [_MMX_UgrnRGB] "m" (*_MMX_UgrnRGB),
++ [_MMX_UbluRGB] "m" (*_MMX_UbluRGB)
+ );
+ }
+
+@@ -413,8 +419,16 @@
+ "popl %%ebx\n"
+ :
+ :"m" (cr), "r"(cb),"r"(lum),
+- "r"(row1),"r"(cols),"r"(row2),"m"(x),"m"(y),"m"(mod)
+- : "%ebx"
++ "r"(row1),"r"(cols),"r"(row2),"m"(x),"m"(y),"m"(mod),
++ [_MMX_0080w] "m" (*_MMX_0080w),
++ [_MMX_Ugrn565] "m" (*_MMX_Ugrn565),
++ [_MMX_Ublu5x5] "m" (*_MMX_Ublu5x5),
++ [_MMX_00FFw] "m" (*_MMX_00FFw),
++ [_MMX_Vgrn565] "m" (*_MMX_Vgrn565),
++ [_MMX_Vred5x5] "m" (*_MMX_Vred5x5),
++ [_MMX_Ycoeff] "m" (*_MMX_Ycoeff),
++ [_MMX_red565] "m" (*_MMX_red565),
++ [_MMX_grn565] "m" (*_MMX_grn565)
+ );
+ }
+
diff --git a/packages/libsdl/libsdl-qpe-1.2.7/mouse.patch b/packages/libsdl/libsdl-qpe-1.2.7/mouse.patch
index e69de29bb2..99320fad0d 100644
--- a/packages/libsdl/libsdl-qpe-1.2.7/mouse.patch
+++ b/packages/libsdl/libsdl-qpe-1.2.7/mouse.patch
@@ -0,0 +1,47 @@
+--- ./src/video/qtopia/SDL_QWin.cc.old 2004-05-16 20:28:36.000000000 +0930
++++ ./src/video/qtopia/SDL_QWin.cc 2004-05-16 20:31:39.000000000 +0930
+@@ -169,7 +169,12 @@
+ Qt::ButtonState button = e->button();
+ int sdlstate = 0;
+ if( (button & Qt::LeftButton)) {
+- sdlstate |= SDL_BUTTON_LMASK;
++ if (mouse_button_mode == 3)
++ sdlstate |= SDL_BUTTON_RMASK;
++ else if (mouse_button_mode == 2)
++ sdlstate |= SDL_BUTTON_MMASK;
++ else
++ sdlstate |= SDL_BUTTON_LMASK;
+ }
+ if( (button & Qt::RightButton)) {
+ sdlstate |= SDL_BUTTON_RMASK;
+@@ -539,20 +544,20 @@
+ case Qt::Key_F6: scancode = SDLK_F6; break;
+ case Qt::Key_F7: scancode = SDLK_F7; break;
+ case Qt::Key_F8: scancode = SDLK_F8; break;
+- case Qt::Key_F9: scancode = SDLK_F9; break;
+- case Qt::Key_F10:
+- scancode = SDLK_F10;
++ case Qt::Key_F9:
++ scancode = SDLK_F9;
+ mouse_button_mode=1;
+ break;
+- case Qt::Key_F11:
+- scancode = SDLK_F11;
+- mouse_button_mode=3;
+- break;
+- case Qt::Key_F12:
+- scancode = SDLK_F12;
++ case Qt::Key_F10:
++ scancode = SDLK_F10;
+ mouse_button_mode=2;
+ break;
+- case Qt::Key_F13: scancode = SDLK_F13; break;
++ case Qt::Key_F11: scancode = SDLK_F11; break;
++ case Qt::Key_F12: scancode = SDLK_F12; break;
++ case Qt::Key_F13:
++ scancode = SDLK_F13;
++ mouse_button_mode=3;
++ break;
+ case Qt::Key_F14: scancode = SDLK_F14; break;
+ case Qt::Key_F15: scancode = SDLK_F15; break;
+ case Qt::Key_Super_L: scancode = SDLK_LSUPER; break;
diff --git a/packages/libsdl/libsdl-ttf-2.0.3/.mtn2git_empty b/packages/libsdl/libsdl-ttf-2.0.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libsdl/libsdl-ttf-2.0.3/.mtn2git_empty
diff --git a/packages/libsdl/libsdl-ttf-2.0.3/new-freetype-includes.patch b/packages/libsdl/libsdl-ttf-2.0.3/new-freetype-includes.patch
index e69de29bb2..856c9947ee 100644
--- a/packages/libsdl/libsdl-ttf-2.0.3/new-freetype-includes.patch
+++ b/packages/libsdl/libsdl-ttf-2.0.3/new-freetype-includes.patch
@@ -0,0 +1,17 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- SDL_ttf-2.0.3/SDL_ttf.c~new-freetype-includes 2001-06-21 07:22:00.000000000 +0200
++++ SDL_ttf-2.0.3/SDL_ttf.c 2004-01-21 23:07:04.000000000 +0100
+@@ -4,6 +4,9 @@
+ #include <string.h>
+ #include <assert.h>
+
++#include <ft2build.h>
++#include FT_FREETYPE_H
++
+ #include <freetype/freetype.h>
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
diff --git a/packages/libsdl/libsdl-ttf_2.0.3.bb b/packages/libsdl/libsdl-ttf_2.0.3.bb
index e69de29bb2..6099021f88 100644
--- a/packages/libsdl/libsdl-ttf_2.0.3.bb
+++ b/packages/libsdl/libsdl-ttf_2.0.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Simple DirectMedia Layer truetype font library."
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "virtual/libsdl freetype"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-${PV}.tar.gz \
+ file://new-freetype-includes.patch;patch=1"
+S = "${WORKDIR}/SDL_ttf-${PV}"
+
+inherit autotools
+
+do_stage() {
+ oe_libinstall -so libSDL_ttf ${STAGING_LIBDIR}
+ ln -sf libSDL_ttf.so ${STAGING_LIBDIR}/libSDL_ttf-2.0.so
+ install -m 0644 SDL_ttf.h ${STAGING_INCDIR}/SDL/SDL_ttf.h
+}
diff --git a/packages/libsdl/libsdl-x11-1.2.7/.mtn2git_empty b/packages/libsdl/libsdl-x11-1.2.7/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libsdl/libsdl-x11-1.2.7/.mtn2git_empty
diff --git a/packages/libsdl/libsdl-x11-1.2.7/acinclude.m4 b/packages/libsdl/libsdl-x11-1.2.7/acinclude.m4
index e69de29bb2..ca2df9d5e5 100644
--- a/packages/libsdl/libsdl-x11-1.2.7/acinclude.m4
+++ b/packages/libsdl/libsdl-x11-1.2.7/acinclude.m4
@@ -0,0 +1,189 @@
+# Local macros for the SDL configure.in script
+
+dnl Function to link an architecture specific file
+dnl LINK_ARCH_SRC(source_dir, arch, source_file)
+AC_DEFUN([COPY_ARCH_SRC],
+[
+ old="$srcdir/$1/$2/$3"
+ new="$1/$3"
+ if test ! -d $1; then
+ echo "Creating directory $1"
+ mkdir -p $1
+ fi
+ echo "Copying $old -> $new"
+ cat >$new <<__EOF__
+/* WARNING: This file was automatically generated!
+ * Original: $old
+ */
+__EOF__
+ cat >>$new <$old
+])
+
+#
+# --- esd.m4 ---
+#
+# Configure paths for ESD
+# Manish Singh 98-9-30
+# stolen back from Frank Belew
+# stolen from Manish Singh
+# Shamelessly stolen from Owen Taylor
+
+dnl AM_PATH_ESD([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+dnl Test for ESD, and define ESD_CFLAGS and ESD_LIBS
+dnl
+AC_DEFUN([AM_PATH_ESD],
+[dnl
+dnl Get the cflags and libraries from the esd-config script
+dnl
+AC_ARG_WITH(esd-prefix,[ --with-esd-prefix=PFX Prefix where ESD is installed (optional)],
+ esd_prefix="$withval", esd_prefix="")
+AC_ARG_WITH(esd-exec-prefix,[ --with-esd-exec-prefix=PFX Exec prefix where ESD is installed (optional)],
+ esd_exec_prefix="$withval", esd_exec_prefix="")
+AC_ARG_ENABLE(esdtest, [ --disable-esdtest Do not try to compile and run a test ESD program],
+ , enable_esdtest=yes)
+
+ if test x$esd_exec_prefix != x ; then
+ esd_args="$esd_args --exec-prefix=$esd_exec_prefix"
+ if test x${ESD_CONFIG+set} != xset ; then
+ ESD_CONFIG=$esd_exec_prefix/bin/esd-config
+ fi
+ fi
+ if test x$esd_prefix != x ; then
+ esd_args="$esd_args --prefix=$esd_prefix"
+ if test x${ESD_CONFIG+set} != xset ; then
+ ESD_CONFIG=$esd_prefix/bin/esd-config
+ fi
+ fi
+
+ AC_PATH_PROG(ESD_CONFIG, esd-config, no)
+ min_esd_version=ifelse([$1], ,0.2.7,$1)
+ AC_MSG_CHECKING(for ESD - version >= $min_esd_version)
+ no_esd=""
+ if test "$ESD_CONFIG" = "no" ; then
+ no_esd=yes
+ else
+ ESD_CFLAGS=`$ESD_CONFIG $esdconf_args --cflags`
+ ESD_LIBS=`$ESD_CONFIG $esdconf_args --libs`
+
+ esd_major_version=`$ESD_CONFIG $esd_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+ esd_minor_version=`$ESD_CONFIG $esd_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+ esd_micro_version=`$ESD_CONFIG $esd_config_args --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ if test "x$enable_esdtest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $ESD_CFLAGS"
+ LIBS="$LIBS $ESD_LIBS"
+dnl
+dnl Now check if the installed ESD is sufficiently new. (Also sanity
+dnl checks the results of esd-config to some extent
+dnl
+ rm -f conf.esdtest
+ AC_TRY_RUN([
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <esd.h>
+
+char*
+my_strdup (char *str)
+{
+ char *new_str;
+
+ if (str)
+ {
+ new_str = malloc ((strlen (str) + 1) * sizeof(char));
+ strcpy (new_str, str);
+ }
+ else
+ new_str = NULL;
+
+ return new_str;
+}
+
+int main ()
+{
+ int major, minor, micro;
+ char *tmp_version;
+
+ system ("touch conf.esdtest");
+
+ /* HP/UX 9 (%@#!) writes to sscanf strings */
+ tmp_version = my_strdup("$min_esd_version");
+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
+ printf("%s, bad version string\n", "$min_esd_version");
+ exit(1);
+ }
+
+ if (($esd_major_version > major) ||
+ (($esd_major_version == major) && ($esd_minor_version > minor)) ||
+ (($esd_major_version == major) && ($esd_minor_version == minor) && ($esd_micro_version >= micro)))
+ {
+ return 0;
+ }
+ else
+ {
+ printf("\n*** 'esd-config --version' returned %d.%d.%d, but the minimum version\n", $esd_major_version, $esd_minor_version, $esd_micro_version);
+ printf("*** of ESD required is %d.%d.%d. If esd-config is correct, then it is\n", major, minor, micro);
+ printf("*** best to upgrade to the required version.\n");
+ printf("*** If esd-config was wrong, set the environment variable ESD_CONFIG\n");
+ printf("*** to point to the correct copy of esd-config, and remove the file\n");
+ printf("*** config.cache before re-running configure\n");
+ return 1;
+ }
+}
+
+],, no_esd=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ if test "x$no_esd" = x ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$2], , :, [$2])
+ else
+ AC_MSG_RESULT(no)
+ if test "$ESD_CONFIG" = "no" ; then
+ echo "*** The esd-config script installed by ESD could not be found"
+ echo "*** If ESD was installed in PREFIX, make sure PREFIX/bin is in"
+ echo "*** your path, or set the ESD_CONFIG environment variable to the"
+ echo "*** full path to esd-config."
+ else
+ if test -f conf.esdtest ; then
+ :
+ else
+ echo "*** Could not run ESD test program, checking why..."
+ CFLAGS="$CFLAGS $ESD_CFLAGS"
+ LIBS="$LIBS $ESD_LIBS"
+ AC_TRY_LINK([
+#include <stdio.h>
+#include <esd.h>
+], [ return 0; ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding ESD or finding the wrong"
+ echo "*** version of ESD. If it is not finding ESD, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means ESD was incorrectly installed"
+ echo "*** or that you have moved ESD since it was installed. In the latter case, you"
+ echo "*** may want to edit the esd-config script: $ESD_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ ESD_CFLAGS=""
+ ESD_LIBS=""
+ ifelse([$3], , :, [$3])
+ fi
+ AC_SUBST(ESD_CFLAGS)
+ AC_SUBST(ESD_LIBS)
+ rm -f conf.esdtest
+])
+
diff --git a/packages/libsdl/libsdl-x11-1.2.7/extra-keys.patch b/packages/libsdl/libsdl-x11-1.2.7/extra-keys.patch
index e69de29bb2..f12f0c7efb 100644
--- a/packages/libsdl/libsdl-x11-1.2.7/extra-keys.patch
+++ b/packages/libsdl/libsdl-x11-1.2.7/extra-keys.patch
@@ -0,0 +1,53 @@
+diff -upr --exclude=configure --exclude=Makefile --exclude=Makefile.in libsdl1.2-1.2.4/include/SDL_keysym.h libsdl1.2-1.2.4-arm/include/SDL_keysym.h
+--- libsdl1.2-1.2.4/include/SDL_keysym.h 2002-03-06 11:23:01.000000000 +0000
++++ libsdl1.2-1.2.4-arm/include/SDL_keysym.h 2002-11-08 20:43:09.000000000 +0000
+@@ -286,6 +286,12 @@ typedef enum {
+ SDLK_EURO = 321, /* Some european keyboards */
+ SDLK_UNDO = 322, /* Atari keyboard has Undo */
+
++ SDLK_RECORD = 322,
++ SDLK_CALENDAR = 323,
++ SDLK_TELEPHONE = 324,
++ SDLK_MAIL = 325,
++ SDLK_START = 326,
++
+ /* Add any other keys here */
+
+ SDLK_LAST
+diff -upr --exclude=configure --exclude=Makefile --exclude=Makefile.in libsdl1.2-1.2.4/src/video/x11/SDL_x11events.c libsdl1.2-1.2.4-arm/src/video/x11/SDL_x11events.c
+--- libsdl1.2-1.2.4/src/video/x11/SDL_x11events.c 2002-03-06 11:23:08.000000000 +0000
++++ libsdl1.2-1.2.4-arm/src/video/x11/SDL_x11events.c 2002-11-08 21:01:41.000000000 +0000
+@@ -34,6 +34,7 @@ static char rcsid =
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+ #include <X11/keysym.h>
++#include <X11/XF86keysym.h>
+ #ifdef __SVR4
+ #include <X11/Sunkeysym.h>
+ #endif
+@@ -655,6 +656,25 @@ SDL_keysym *X11_TranslateKey(Display *di
+ case 0xFF:
+ keysym->sym = MISC_keymap[xsym&0xFF];
+ break;
++ case 0x1008ff:
++ switch (xsym) {
++ case XF86XK_AudioRecord:
++ keysym->sym = SDLK_RECORD;
++ break;
++ case XF86XK_PowerDown:
++ keysym->sym = SDLK_POWER;
++ break;
++ case XF86XK_Calendar:
++ keysym->sym = SDLK_CALENDAR;
++ break;
++ case XF86XK_Mail:
++ keysym->sym = SDLK_MAIL;
++ break;
++ case XF86XK_Start:
++ keysym->sym = SDLK_START;
++ break;
++ }
++ break;
+ default:
+ fprintf(stderr,
+ "X11: Unknown xsym, sym = 0x%04x\n",