aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libssh
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/libssh
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/libssh')
-rw-r--r--packages/libssh/libssh_0.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/libssh/libssh_0.1.bb b/packages/libssh/libssh_0.1.bb
index e69de29bb2..f55ea09f3b 100644
--- a/packages/libssh/libssh_0.1.bb
+++ b/packages/libssh/libssh_0.1.bb
@@ -0,0 +1,33 @@
+SECTION = "libs"
+DESCRIPTION = "The SSH library is a C library to authenticate in a \
+simple manner to one or more SSH servers. The goal of this project \
+is to provide a library much simpler to use than OpenSSHs one. It \
+includes SFTP support, and a sample SSH client is provided."
+DEPENDS = "openssl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.0xbadc0de.be/projects/libssh/libssh-${PV}.tgz"
+
+inherit autotools
+
+EXTRA_OECONF = "--cache-file=${S}/config.cache"
+
+do_stage () {
+ set -x
+ install -d ${STAGING_INCDIR}/libssh
+ for i in crypto.h libssh.h sftp.h ssh2.h; do
+ install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
+ done
+ oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake "prefix=${D}/${prefix}" \
+ "exec_prefix=${D}/${exec_prefix}" \
+ "bindir=${D}/${bindir}" \
+ "incldir=${D}/${includedir}" \
+ "infodir=${D}/${infodir}" \
+ "mandir=${D}/${mandir}/man1" \
+ "libdir=${D}/${libdir}" \
+ install
+}