aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libtool/libtool-native_1.5.10.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-15 12:52:57 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-15 12:52:57 +0000
commit002caab239157d1062a3f49b62efb06ef0489280 (patch)
treed8a1d1b7cdf6df0ce608e0487bc53b7cb34fc474 /packages/libtool/libtool-native_1.5.10.bb
parent0d0b837b8a9c247f7ca16f6efafc33eaedaf7b3f (diff)
downloadopenembedded-002caab239157d1062a3f49b62efb06ef0489280.tar.gz
libtool, autotools.bbclass: merge fixes for 1.5.10 from poky
* NOTE: 1.5.22 has to be updated as well
Diffstat (limited to 'packages/libtool/libtool-native_1.5.10.bb')
-rw-r--r--packages/libtool/libtool-native_1.5.10.bb26
1 files changed, 7 insertions, 19 deletions
diff --git a/packages/libtool/libtool-native_1.5.10.bb b/packages/libtool/libtool-native_1.5.10.bb
index 78e69e06b4..6d8b1a1d7c 100644
--- a/packages/libtool/libtool-native_1.5.10.bb
+++ b/packages/libtool/libtool-native_1.5.10.bb
@@ -1,7 +1,7 @@
SECTION = "devel"
require libtool_${PV}.bb
-PR = "r4"
+PR = "r5"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
SRC_URI_append = " file://libdir-la.patch;patch=1 \
file://prefix.patch;patch=1 \
@@ -10,8 +10,6 @@ SRC_URI_append = " file://libdir-la.patch;patch=1 \
file://install-path-check.patch;patch=1"
S = "${WORKDIR}/libtool-${PV}"
-STAGING_DATADIR_safe := "${STAGING_DATADIR}"
-
inherit native
do_stage () {
@@ -19,22 +17,12 @@ do_stage () {
install -m 0755 libtoolize ${STAGING_BINDIR}/libtoolize
oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
- for dir in ${STAGING_DATADIR} ${STAGING_DATADIR_safe}; do
- ltdldir="${dir}/libtool/libltdl"
- install -d $dir/libtool \
- $ltdldir \
- $dir/aclocal
- install -c config.guess $dir/libtool/config.guess
- install -c config.sub $dir/libtool/config.sub
- install -c -m 0644 ltmain.sh $dir/libtool/
- install -c -m 0644 libtool.m4 $dir/aclocal/
- install -c -m 0644 ltdl.m4 $dir/aclocal/
-
- for src in README COPYING.LIB Makefile.am configure.ac \
- config-h.in ltdl.c ltdl.h; do
- install -m 0644 libltdl/${src} ${ltdldir}
- done
- done
+ install -d ${STAGING_DATADIR}/libtool ${STAGING_DATADIR}/aclocal
+ install -c config.guess ${STAGING_DATADIR}/libtool/
+ install -c config.sub ${STAGING_DATADIR}/libtool/
+ install -c -m 0644 ltmain.sh ${STAGING_DATADIR}/libtool/
+ install -c -m 0644 libtool.m4 ${STAGING_DATADIR}/aclocal/
+ install -c -m 0644 ltdl.m4 ${STAGING_DATADIR}/aclocal/
}
do_install () {