aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libtool/libtool_1.5.24.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-08-03 14:30:20 +0000
committerPhilip Balister <philip@balister.org>2007-08-03 14:30:20 +0000
commit3e2ebecea5437f254baa675df3e36a75fea95d42 (patch)
tree099b52625076e8ae36dddc15e728bc125bf6fadf /packages/libtool/libtool_1.5.24.bb
parentfa52b5bb47dd65353901a1218ddd9dc8a6042f3e (diff)
downloadopenembedded-3e2ebecea5437f254baa675df3e36a75fea95d42.tar.gz
libtool : Add bb files for libtool-1.5.24 support. This version seems to
help solve problems when libtool install does a relink.
Diffstat (limited to 'packages/libtool/libtool_1.5.24.bb')
-rw-r--r--packages/libtool/libtool_1.5.24.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/libtool/libtool_1.5.24.bb b/packages/libtool/libtool_1.5.24.bb
new file mode 100644
index 0000000000..de91370ac5
--- /dev/null
+++ b/packages/libtool/libtool_1.5.24.bb
@@ -0,0 +1,38 @@
+DEFAULT_PREFERENCE = "-1"
+
+DESCRIPTION = "Generic library support script \
+This is GNU libtool, a generic library support script. Libtool hides \
+the complexity of generating special library types (such as shared \
+libraries) behind a consistent interface."
+HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
+LICENSE = "GPL"
+SECTION = "devel"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
+ file://autotools.patch;patch=1 \
+ file://uclibc.patch;patch=1 \
+ file://never-ever-do-rpath.patch;patch=1"
+
+S = "${WORKDIR}/libtool-${PV}"
+
+PACKAGES = "libltdl libltdl-dev ${PN}"
+FILES_${PN} += "${datadir}/aclocal*"
+FILES_libltdl = "${libdir}/libltdl.so.*"
+FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
+
+inherit autotools
+
+EXTRA_AUTORECONF = "--exclude=libtoolize"
+
+do_configure () {
+ find ${S} -name acinclude.m4 | for m4 in `cat`; do
+ cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
+ done
+ autotools_do_configure
+}
+
+do_stage () {
+ oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
+ install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
+}