aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxine
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-09-18 16:58:06 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-09-18 16:58:06 +0000
commit1175ce4794017d24cd6030e97453359a9515e28b (patch)
treea0569cef02fff0373cb6592f857cdcc3b5eaf0fe /packages/libxine
parent53ca56100345afcfbbd96cf6321fd2e90046de78 (diff)
downloadopenembedded-1175ce4794017d24cd6030e97453359a9515e28b.tar.gz
libxine 1.1.0 add gcc4.1.1 patch (static vs. nonstatic declaration)
Diffstat (limited to 'packages/libxine')
-rw-r--r--packages/libxine/libxine-1.1.0/gcc41.patch13
-rw-r--r--packages/libxine/libxine_1.1.0.bb3
2 files changed, 15 insertions, 1 deletions
diff --git a/packages/libxine/libxine-1.1.0/gcc41.patch b/packages/libxine/libxine-1.1.0/gcc41.patch
new file mode 100644
index 0000000000..f201a5e38b
--- /dev/null
+++ b/packages/libxine/libxine-1.1.0/gcc41.patch
@@ -0,0 +1,13 @@
+Index: xine-lib-1.1.0/src/libffmpeg/libavcodec/mpegvideo.h
+===================================================================
+--- xine-lib-1.1.0.orig/src/libffmpeg/libavcodec/mpegvideo.h
++++ xine-lib-1.1.0/src/libffmpeg/libavcodec/mpegvideo.h
+@@ -928,7 +928,7 @@ int ff_mpeg4_get_video_packet_prefix_len
+ int ff_h263_resync(MpegEncContext *s);
+ int ff_h263_get_gob_height(MpegEncContext *s);
+ int ff_mpeg4_set_direct_mv(MpegEncContext *s, int mx, int my);
+-int ff_h263_round_chroma(int x);
++static int ff_h263_round_chroma(int x);
+ void ff_h263_encode_motion(MpegEncContext * s, int val, int f_code);
+ int ff_mpeg4_find_frame_end(ParseContext *pc, const uint8_t *buf, int buf_size);
+
diff --git a/packages/libxine/libxine_1.1.0.bb b/packages/libxine/libxine_1.1.0.bb
index b4ab063063..735a18510c 100644
--- a/packages/libxine/libxine_1.1.0.bb
+++ b/packages/libxine/libxine_1.1.0.bb
@@ -5,7 +5,7 @@ PRIORITY = "optional"
LICENSE = "GPL"
DEPENDS = "zlib libogg libvorbis tremor libmad libmodplug esound-gpe virtual/libx11 libxext libpng"
PROVIDES = "virtual/libxine"
-PR = "r0"
+PR = "r1"
inherit autotools pkgconfig gettext binconfig
@@ -22,6 +22,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/xine/xine-lib-${PV}.tar.gz \
file://mpegvideo-static-inlinine.patch;patch=1 \
file://no-caca.patch;patch=1 \
file://dont-have-xv.patch;patch=1 \
+ file://gcc41.patch;patch=1"
"
DEFAULT_PREFERENCE = "-1"