aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxine
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/libxine
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/libxine')
-rw-r--r--packages/libxine/libxine-opie_1.0.bb97
-rw-r--r--packages/libxine/libxine_1.0.0-beta12.bb90
-rw-r--r--packages/libxine/libxine_1.0.0-rc5.bb70
-rw-r--r--packages/libxine/libxine_1.0.bb108
4 files changed, 365 insertions, 0 deletions
diff --git a/packages/libxine/libxine-opie_1.0.bb b/packages/libxine/libxine-opie_1.0.bb
index e69de29bb2..246b3705f5 100644
--- a/packages/libxine/libxine-opie_1.0.bb
+++ b/packages/libxine/libxine-opie_1.0.bb
@@ -0,0 +1,97 @@
+LICENSE = GPL
+# libxine OE build file
+# Modified by Advanced Micro Devices, Inc.
+
+DESCRIPTION = "libxine compiled for Opie"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
+DEPENDS = "zlib libogg tremor libmad"
+PROVIDES = "virtual/libxine"
+
+inherit autotools pkgconfig gettext
+
+S = "${WORKDIR}/xine-lib-${PV}"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/xine/xine-lib-${PV}.tar.gz \
+ file://cpu-${PV}.patch;patch=1 \
+ file://configure-${PV}.patch;patch=1 \
+ file://demuxogg.patch;patch=1 \
+ file://fix-syntax.patch;patch=1 \
+ file://libxine-cut-memusage.patch;patch=1 \
+ file://libxine-ffmpeg-enable-arm.patch;patch=1 \
+ file://libxine-libvorbis.patch;patch=1 \
+ file://libxine-tremor-autoconf.patch;patch=1 \
+ file://mpegvideo-static-inlinine.patch;patch=1 \
+ file://libxine-arm-configure.patch;patch=1 "
+
+
+
+SOV = "1.0.7"
+
+# Omit the annoying xine-config in ${bindir}
+FILES_${PN}="${libdir}/*.so*"
+
+# And include it in the dev package
+FILES_${PN}-dev += " ${bindir}"
+
+EXTRA_OECONF="-with-zlib-path=${STAGING_DIR}/${HOST_SYS} \
+ --with-vorbis-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --disable-oggtest \
+ --with-ogg-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --disable-altivec --disable-vis --disable-mlib \
+ --enable-shared --disable-static \
+ --disable-fb --disable-alsa --disable-vcd \
+ --disable-asf --disable-faad --disable-iconv \
+ --disable-aalib \
+ --without-v4l --without-arts --without-sdl \
+ --disable-dxr3 --without-xv --without-xvmc \
+ --without-xxmc --without-Xshm --without-x "
+
+do_compile() {
+ oe_runmake LIBTOOL=${S}/${TARGET_SYS}-libtool
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} LIBTOOL=${S}/${TARGET_SYS}-libtool install
+}
+
+HEADERS="src/xine-engine/xineintl.h src/xine-utils/xineutils.h \
+ src/xine-engine/xine_internal.h src/xine-engine/xine_plugin.h \
+ src/xine-utils/xine_buffer.h src/xine-engine/video_out.h \
+ src/xine-engine/buffer.h src/xine-engine/vo_scale.h \
+ src/xine-engine/configfile.h src/xine-utils/attributes.h \
+ src/xine-engine/info_helper.h src/xine-engine/scratch.h \
+ src/xine-engine/audio_decoder.h src/input/input_plugin.h \
+ src/xine-engine/spu_decoder.h src/xine-engine/audio_out.h \
+ src/xine-engine/io_helper.h src/xine-engine/video_decoder.h \
+ src/xine-engine/broadcaster.h src/xine-engine/metronom.h \
+ src/xine-utils/xmllexer.h src/xine-engine/osd.h \
+ src/xine-engine/video_overlay.h src/xine-utils/xmlparser.h \
+ src/xine-utils/compat.h src/xine-engine/plugin_catalog.h \
+ src/xine-engine/post.h src/demuxers/demux.h \
+ src/xine-engine/resample.h lib/os_types.h \
+ src/xine-engine/refcounter.h"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xine
+
+ install -m 0644 ${S}/include/xine.h ${STAGING_INCDIR}
+
+ for file in ${HEADERS}; do
+ cp ${S}/$file ${STAGING_INCDIR}/xine/`basename $file`
+ done
+
+ oe_libinstall -so -C src/xine-engine libxine ${STAGING_LIBDIR}
+}
+
+python populate_packages_prepend () {
+ plugindir = bb.data.expand('${libdir}/xine/plugins/1.0.0', d)
+ do_split_packages(d, plugindir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
+
+ postdir = bb.data.expand('${libdir}/xine/plugins/1.0.0/post', d)
+ do_split_packages(d, postdir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
+
+ fontdir = bb.data.expand('${datadir}/xine/libxine1/fonts', d)
+ do_split_packages(d, fontdir, '^(.*).xinefont.gz$', 'libxine-font-%s', 'Xine font %s', extra_depends='' )
+}
diff --git a/packages/libxine/libxine_1.0.0-beta12.bb b/packages/libxine/libxine_1.0.0-beta12.bb
index e69de29bb2..6f3558c095 100644
--- a/packages/libxine/libxine_1.0.0-beta12.bb
+++ b/packages/libxine/libxine_1.0.0-beta12.bb
@@ -0,0 +1,90 @@
+LICENSE = GPL
+DESCRIPTION = "libxine is a library for multimedia players. \
+It plays back CDs, DVDs, and VCDs. It also decodes multimedia \
+files like AVI, MOV, WMV, and MP3 from local disk drives, \
+and displays multimedia streamed over the Internet. It interprets \
+many of the most common multimedia formats available - \
+and some of the most uncommon formats, too."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib libogg tremor libmad"
+PR = "r4"
+
+inherit autotools pkgconfig binconfig gettext
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/xine/xine-lib-1-beta12.tar.gz \
+ file://full.patch;patch=1 \
+ file://libvorbis.patch;patch=1 \
+ file://demux_ogg.patch;patch=1 \
+ file://configure.ac.patch;patch=1 \
+ file://vo_scale.patch;patch=1 \
+ file://oss.patch;patch=1;pnum=0 \
+ file://fix-oss-plugin.patch;patch=1 \
+ file://mpegvideo-static-inlining.patch;patch=1 \
+ file://fix-syntax-xine-vorbis-decoder.patch;patch=1 \
+ file://fftscope-static-inlining.patch;patch=1"
+S = "${WORKDIR}/xine-lib-1-beta12"
+
+SOV = "1.0.6"
+
+do_configure() {
+ ./autogen.sh --host ${TARGET_SYS} --build ${BUILD_SYS} \
+ --enable-shared --disable-static --prefix=${prefix} \
+ --with-zlib-path=${STAGING_DIR}/${HOST_SYS} --with-vorbis-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --disable-oggtest --with-ogg-prefix=${STAGING_DIR}/${HOST_SYS} --without-x \
+ --disable-iconv --without-arts --without-sdl \
+ --disable-aalib
+}
+
+do_compile() {
+ oe_runmake LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool OGG_LIBS=${STAGING_LIBDIR}/libogg.so
+}
+
+do_stage() {
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool \
+ -C src install-data \
+ 'prefix=${STAGING_DIR}' 'exec_prefix=${STAGING_DIR}' \
+ 'libdir=${STAGING_LIBDIR}' \
+ 'includedir=${STAGING_INCDIR}'
+
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool \
+ -C include install-data \
+ 'prefix=${STAGING_DIR}' 'exec_prefix=${STAGING_DIR}' \
+ 'libdir=${STAGING_LIBDIR}' \
+ 'includedir=${STAGING_INCDIR}'
+
+ for plugin in `find ${S}/src -type f -name xineplug*.la`; do
+ dir=`dirname $plugin`
+ libname=`basename $plugin|sed -e's,\.la,,'`
+ oe_libinstall -so -C $dir $libname ${STAGING_LIBDIR}/xine/plugins/1.0.0
+ done
+
+ oe_libinstall -so -C src/xine-engine libxine ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool \
+ -C src install-data \
+ 'prefix=${D}' 'exec_prefix=${D}' 'libdir=${D}/${libdir}' \
+ 'includedir=${D}/${includedir}'
+
+ oe_runmake -e LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool \
+ -C include install-data \
+ 'prefix=${D}' 'exec_prefix=${D}' 'libdir=${D}/${libdir}' \
+ 'includedir=${D}/${includedir}'
+
+ for plugin in `find ${S}/src -type f -name xineplug*.la`; do
+ dir=`dirname $plugin`
+ libname=`basename $plugin|sed -e's,\.la,,'`
+ oe_libinstall -so -C $dir $libname ${D}/${libdir}/xine/plugins/1.0.0
+ done
+
+ oe_libinstall -so -C src/xine-engine libxine ${D}/${libdir}
+}
+
+python populate_packages_prepend () {
+ plugins_dir = bb.data.expand('${libdir}/xine/plugins/1.0.0/', d)
+
+ do_split_packages(d, plugins_dir, file_regex='^xineplug_(.*).so$', output_pattern='libxine-plugin-%s', description='Xine plugin - %s')
+}
+
diff --git a/packages/libxine/libxine_1.0.0-rc5.bb b/packages/libxine/libxine_1.0.0-rc5.bb
index e69de29bb2..ee85eb12a3 100644
--- a/packages/libxine/libxine_1.0.0-rc5.bb
+++ b/packages/libxine/libxine_1.0.0-rc5.bb
@@ -0,0 +1,70 @@
+LICENSE = GPL
+# libxine OE build file
+# Modified by Advanced Micro Devices, Inc.
+
+DESCRIPTION = "libxine"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
+DEPENDS = "zlib libogg libvorbis libmad"
+
+inherit autotools pkgconfig gettext
+
+S = "${WORKDIR}/xine-lib-1-rc5"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/xine/xine-lib-1-rc5.tar.gz \
+ file://cpu.patch;patch=1 \
+ file://configure.patch;patch=1"
+
+SOV = "1.0.6"
+
+# Omit the annoying xine-config in ${bindir}
+FILES_${PN}="${libdir}/*.so*"
+
+# And include it in the dev package
+FILES_${PN}-dev += " ${bindir}"
+
+EXTRA_OECONF="-with-zlib-path=${STAGING_DIR}/${HOST_SYS} \
+ --with-vorbis-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --disable-oggtest \
+ --with-ogg-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --disable-altivec --disable-vis --disable-mlib \
+ --disable-fb --disable-alsa --disable-vcd \
+ --disable-asf --disable-faad --disable-iconv \
+ --disable-aalib \
+ --without-v4l --without-arts --without-sdl"
+
+do_compile() {
+ oe_runmake LIBTOOL=${S}/${TARGET_SYS}-libtool
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} LIBTOOL=${S}/${TARGET_SYS}-libtool install
+}
+
+HEADERS="src/xine-engine/xineintl.h src/xine-utils/xineutils.h \
+ src/xine-engine/xine_internal.h src/xine-engine/xine_plugin.h \
+ src/xine-utils/xine_buffer.h"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xine
+
+ install -m 0644 ${S}/include/xine.h ${STAGING_INCDIR}
+
+ for file in ${HEADERS}; do
+ cp ${S}/$file ${STAGING_INCDIR}/xine/`basename $file`
+ done
+
+ oe_libinstall -so -C src/xine-engine libxine ${STAGING_LIBDIR}
+}
+
+python populate_packages_prepend () {
+ plugindir = bb.data.expand('${libdir}/xine/plugins/1.0.0', d)
+ do_split_packages(d, plugindir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s')
+
+ postdir = bb.data.expand('${libdir}/xine/plugins/1.0.0/post', d)
+ do_split_packages(d, postdir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s')
+
+ fontdir = bb.data.expand('${datadir}/xine/libxine1/fonts', d)
+ do_split_packages(d, fontdir, '^(.*).xinefont.gz$', 'libxine-font-%s', 'Xine font %s')
+}
diff --git a/packages/libxine/libxine_1.0.bb b/packages/libxine/libxine_1.0.bb
index e69de29bb2..0d77d48b38 100644
--- a/packages/libxine/libxine_1.0.bb
+++ b/packages/libxine/libxine_1.0.bb
@@ -0,0 +1,108 @@
+LICENSE = GPL
+# libxine OE build file
+# Modified by Advanced Micro Devices, Inc.
+
+#FIXME: libxine doesn't build when X11 has been built before:
+#| In file included from video_out_dxr3.c:55:
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:16: error: parse error before "Bool"
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:17: error: parse error before '*' token
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:20: warning: type defaults to `int' in declaration of
+#`XineramaQueryExtension'
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:20: warning: data definition has no type or storage class
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:22: error: parse error before "XineramaQueryVersion"
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:23: error: parse error before '*' token
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:26: warning: type defaults to `int' in declaration of
+#`XineramaQueryVersion'
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:26: warning: data definition has no type or storage class
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:28: error: parse error before "XineramaIsActive"
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:28: error: parse error before '*' token
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:28: warning: type defaults to `int' in declaration of
+#`XineramaIsActive'
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:28: warning: data definition has no type or storage class
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/X11/extensions/Xinerama.h:41: error: parse error before '*' token
+#| In file included from /local/pkg/oe/collie/tmp/staging/arm-linux/include/inttypes.h:28,
+#| from ../../src/xine-engine/xine_internal.h:31,
+#| from video_out_dxr3.c:65:
+#| /local/pkg/oe/collie/tmp/staging/arm-linux/include/stdint.h:49: error: syntax error before "typedef"
+
+DESCRIPTION = "libxine"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
+DEPENDS = "zlib libogg libvorbis libmad"
+PROVIDES = "virtual/libxine"
+
+inherit autotools pkgconfig gettext
+
+S = "${WORKDIR}/xine-lib-${PV}"
+
+SRC_URI = "http://heanet.dl.sourceforge.net/sourceforge/xine/xine-lib-${PV}.tar.gz \
+ file://cpu-${PV}.patch;patch=1 \
+ file://configure-${PV}.patch;patch=1"
+
+SOV = "1.0.7"
+
+# Omit the annoying xine-config in ${bindir}
+FILES_${PN}="${libdir}/*.so*"
+
+# And include it in the dev package
+FILES_${PN}-dev += " ${bindir}"
+
+EXTRA_OECONF="-with-zlib-path=${STAGING_DIR}/${HOST_SYS} \
+ --with-vorbis-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --disable-oggtest \
+ --with-ogg-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --disable-altivec --disable-vis --disable-mlib \
+ --enable-shared --disable-static \
+ --disable-fb --disable-alsa --disable-vcd \
+ --disable-asf --disable-faad --disable-iconv \
+ --disable-aalib --with-xv-path=${STAGING_LIBDIR} \
+ --without-v4l --without-arts --without-sdl"
+
+do_compile() {
+ oe_runmake LIBTOOL=${S}/${TARGET_SYS}-libtool
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} LIBTOOL=${S}/${TARGET_SYS}-libtool install
+}
+
+HEADERS="src/xine-engine/xineintl.h src/xine-utils/xineutils.h \
+ src/xine-engine/xine_internal.h src/xine-engine/xine_plugin.h \
+ src/xine-utils/xine_buffer.h src/xine-engine/video_out.h \
+ src/xine-engine/buffer.h src/xine-engine/vo_scale.h \
+ src/xine-engine/configfile.h src/xine-utils/attributes.h \
+ src/xine-engine/info_helper.h src/xine-engine/scratch.h \
+ src/xine-engine/audio_decoder.h src/input/input_plugin.h \
+ src/xine-engine/spu_decoder.h src/xine-engine/audio_out.h \
+ src/xine-engine/io_helper.h src/xine-engine/video_decoder.h \
+ src/xine-engine/broadcaster.h src/xine-engine/metronom.h \
+ src/xine-utils/xmllexer.h src/xine-engine/osd.h \
+ src/xine-engine/video_overlay.h src/xine-utils/xmlparser.h \
+ src/xine-utils/compat.h src/xine-engine/plugin_catalog.h \
+ src/xine-engine/post.h src/demuxers/demux.h \
+ src/xine-engine/resample.h lib/os_types.h \
+ src/xine-engine/refcounter.h"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xine
+
+ install -m 0644 ${S}/include/xine.h ${STAGING_INCDIR}
+
+ for file in ${HEADERS}; do
+ cp ${S}/$file ${STAGING_INCDIR}/xine/`basename $file`
+ done
+
+ oe_libinstall -so -C src/xine-engine libxine ${STAGING_LIBDIR}
+}
+
+python populate_packages_prepend () {
+ plugindir = bb.data.expand('${libdir}/xine/plugins/1.0.0', d)
+ do_split_packages(d, plugindir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
+
+ postdir = bb.data.expand('${libdir}/xine/plugins/1.0.0/post', d)
+ do_split_packages(d, postdir, '^xineplug_(.*)\.so$', 'libxine-plugin-%s', 'Xine plugin for %s', extra_depends='' )
+
+ fontdir = bb.data.expand('${datadir}/xine/libxine1/fonts', d)
+ do_split_packages(d, fontdir, '^(.*).xinefont.gz$', 'libxine-font-%s', 'Xine font %s', extra_depends='' )
+}