aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxine
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-01-23 21:25:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-23 21:25:32 +0000
commitfc1aee6b0d22286c48bb025c8d47faa8b93d96c6 (patch)
tree7a220c3eb0009835ffe9cba9d650df3bedb78ee4 /packages/libxine
parent782dc3c20561aea0fb13529d543fb814fda208f7 (diff)
downloadopenembedded-fc1aee6b0d22286c48bb025c8d47faa8b93d96c6.tar.gz
libxine 1.1.0: Stop it from seeing the host system's Wand-config and getting confused.
Diffstat (limited to 'packages/libxine')
-rw-r--r--packages/libxine/libxine-1.1.0/configure.patch22
-rw-r--r--packages/libxine/libxine_1.1.0.bb2
2 files changed, 19 insertions, 5 deletions
diff --git a/packages/libxine/libxine-1.1.0/configure.patch b/packages/libxine/libxine-1.1.0/configure.patch
index f8d0ea1029..a0078a72f3 100644
--- a/packages/libxine/libxine-1.1.0/configure.patch
+++ b/packages/libxine/libxine-1.1.0/configure.patch
@@ -3,8 +3,10 @@
# Patch managed by http://www.holgerschurig.de/patcher.html
#
---- xine-lib-1.1.0/configure.ac~configure-1.0
-+++ xine-lib-1.1.0/configure.ac
+Index: xine-lib-1.1.0/configure.ac
+===================================================================
+--- xine-lib-1.1.0.orig/configure.ac 2005-07-21 21:10:10.000000000 +0000
++++ xine-lib-1.1.0/configure.ac 2006-01-11 14:30:05.965735856 +0000
@@ -715,6 +715,7 @@
LIBS="$saved_libs"
fi
@@ -103,7 +105,17 @@
AC_SUBST(MNG_LIBS)
dnl ---------------------------------------------
-@@ -1153,7 +1120,7 @@
+@@ -1134,6 +1101,9 @@
+ dnl ---------------------------------------------
+
+ AC_PATH_PROG(WAND_CONFIG, Wand-config, no)
++if ( ! test -f "$WAND_CONFIG" ) && ( ! test -x "$WAND_CONFIG" ) ; then
++ WAND_CONFIG="no"
++fi
+ if test "$WAND_CONFIG" = "no" ; then
+ AC_MSG_RESULT([*** All Imagemagick dependent parts will be disabled, Wand-config not found. ***])
+ else
+@@ -1153,7 +1123,7 @@
dnl freetype2 lib.
dnl ---------------------------------------------
@@ -112,7 +124,7 @@
dnl ---------------------------------------------
-@@ -1196,37 +1163,21 @@
+@@ -1196,37 +1166,21 @@
dnl ESD support
dnl ---------------------------------------------
@@ -153,7 +165,7 @@
dnl ---------------------------------------------
-@@ -1403,75 +1354,7 @@
+@@ -1403,75 +1357,7 @@
],ISOC99_PRAGMA=no)
AC_MSG_RESULT($ISOC99_PRAGMA)
diff --git a/packages/libxine/libxine_1.1.0.bb b/packages/libxine/libxine_1.1.0.bb
index e0c8e5473a..af5561d68a 100644
--- a/packages/libxine/libxine_1.1.0.bb
+++ b/packages/libxine/libxine_1.1.0.bb
@@ -41,6 +41,8 @@ EXTRA_OECONF="-with-zlib-path=${STAGING_DIR}/${HOST_SYS} \
--without-xv --without-xxmc --without-xvmc \
--with-x --x-includes=${STAGING_INCDIR}/X11 --x-libraries=${STAGING_LIBDIR}"
+export WAND_CONFIG="${STAGING_BINDIR}/Wand-config"
+
do_compile() {
oe_runmake LIBTOOL=${S}/${TARGET_SYS}-libtool
}