aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxsettings-client
diff options
context:
space:
mode:
authorPhilippe De Swert <philippedeswert@scarlet.be>2007-02-10 17:33:58 +0000
committerPhilippe De Swert <philippedeswert@scarlet.be>2007-02-10 17:33:58 +0000
commit5c63c5da016ef8df5b634e96c6b4a5794a00cce7 (patch)
tree1731e86a6fcd60504ff9317da2433e39c0891543 /packages/libxsettings-client
parentc915ccb0010bbd09ed63282a679315b2901b1799 (diff)
downloadopenembedded-5c63c5da016ef8df5b634e96c6b4a5794a00cce7.tar.gz
blueprobe_svn:
* added bb recipe * added necessary patches detect-stylus_svn: * added bb recipe * added necessary patches gpe-appmgr_svn: * added bb recipe * added necessary patches gpe-autostarter_svn: * added bb recipe * added necessary patches libxsettings-client_svn: * added bb recipe MAINTAINERS: * added myself (Philippe De Swert) * added packages maintained by me
Diffstat (limited to 'packages/libxsettings-client')
-rw-r--r--packages/libxsettings-client/libxsettings-client_svn.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/libxsettings-client/libxsettings-client_svn.bb b/packages/libxsettings-client/libxsettings-client_svn.bb
new file mode 100644
index 0000000000..111c692603
--- /dev/null
+++ b/packages/libxsettings-client/libxsettings-client_svn.bb
@@ -0,0 +1,26 @@
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+LICENSE = "BSD-X"
+DEPENDS = "libxsettings virtual/libx11 libxt gtk-doc"
+PV = "0.17+svn${SRCDATE}"
+# libxt is required to stop configure breaking builds by
+# including system paths to find it if it isn't present.
+PR = "r0"
+
+inherit autotools pkgconfig gpe
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+do_stage () {
+ oe_libinstall -so libXsettings-client ${STAGING_LIBDIR}
+ mkdir -p ${STAGING_INCDIR}
+ for h in ${headers}; do
+ install -m 0644 ${S}/$h ${STAGING_INCDIR}/$h
+ done
+}
+
+headers = "xsettings-client.h xsettings-common.h"
+
+DEFAULT_PREFERENCE = "-1"