aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxslt
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-09-29 21:39:32 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-09-29 21:39:32 +0000
commit188250803922b2887bf4f6b66f9a88d4f49db75c (patch)
treed519f1f0c598e79503acdf7599b0fadc1c19ce32 /packages/libxslt
parent79a652089c63bd0b00f794ebb2790ab50499c68f (diff)
downloadopenembedded-188250803922b2887bf4f6b66f9a88d4f49db75c.tar.gz
libxslt: added 1.1.17
Diffstat (limited to 'packages/libxslt')
-rw-r--r--packages/libxslt/libxslt-1.1.17/.mtn2git_empty0
-rw-r--r--packages/libxslt/libxslt-1.1.17/destdir.patch10
-rw-r--r--packages/libxslt/libxslt_1.1.17.bb45
3 files changed, 55 insertions, 0 deletions
diff --git a/packages/libxslt/libxslt-1.1.17/.mtn2git_empty b/packages/libxslt/libxslt-1.1.17/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libxslt/libxslt-1.1.17/.mtn2git_empty
diff --git a/packages/libxslt/libxslt-1.1.17/destdir.patch b/packages/libxslt/libxslt-1.1.17/destdir.patch
new file mode 100644
index 0000000000..8df1b206bc
--- /dev/null
+++ b/packages/libxslt/libxslt-1.1.17/destdir.patch
@@ -0,0 +1,10 @@
+Index: libxslt-1.1.17/libxslt/Makefile.am
+===================================================================
+--- libxslt-1.1.17.orig/libxslt/Makefile.am 2005-10-02 11:25:21.000000000 +0200
++++ libxslt-1.1.17/libxslt/Makefile.am 2006-09-29 23:13:35.000000000 +0200
+@@ -61,4 +61,4 @@
+ @(cd ../xsltproc ; $(MAKE))
+
+ install-exec-hook:
+- $(mkinstalldirs) "$(libdir)/libxslt-plugins"
++ $(mkinstalldirs) "$(DESTDIR)$(libdir)/libxslt-plugins"
diff --git a/packages/libxslt/libxslt_1.1.17.bb b/packages/libxslt/libxslt_1.1.17.bb
new file mode 100644
index 0000000000..816b3fdd04
--- /dev/null
+++ b/packages/libxslt/libxslt_1.1.17.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2"
+LICENSE = "MIT"
+PR = "r2"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
+ keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
+ templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
+ xsltexports.h xsltutils.h"
+exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
+
+do_stage () {
+ oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
+ oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxslt
+ for i in ${xsltheaders}; do
+ install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
+ done
+ mkdir -p ${STAGING_INCDIR}/libexslt
+ for i in ${exsltheaders}; do
+ install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
+ done
+
+ cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xslt-config
+ chmod a+rx ${STAGING_BINDIR}/xslt-config
+ install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"