aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxslt
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-09-10 15:11:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-10 15:11:07 +0000
commit91d8b29268f4635631928c9ec890603bb59d4bfd (patch)
tree54d3dd565d076845a091eed9ee6bd0635319e876 /packages/libxslt
parenta5a38c5e523e99b23fbef91647c27fabfd913982 (diff)
downloadopenembedded-91d8b29268f4635631928c9ec890603bb59d4bfd.tar.gz
packages/libxslt/libxslt_1.1.8.bb: add libxslt 1.1.8
Diffstat (limited to 'packages/libxslt')
-rw-r--r--packages/libxslt/libxslt_1.1.8.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/libxslt/libxslt_1.1.8.bb b/packages/libxslt/libxslt_1.1.8.bb
new file mode 100644
index 0000000000..81d4fddead
--- /dev/null
+++ b/packages/libxslt/libxslt_1.1.8.bb
@@ -0,0 +1,45 @@
+PR = "r1"
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "libxml2"
+LICENSE = "MIT"
+PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"
+
+SRC_URI = "http://xmlsoft.org/sources/old/libxslt-${PV}.tar.gz"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug"
+
+xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
+ keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
+ templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
+ xsltexports.h xsltutils.h"
+exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
+
+do_stage () {
+ oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
+ oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxslt
+ for i in ${xsltheaders}; do
+ install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
+ done
+ mkdir -p ${STAGING_INCDIR}/libexslt
+ for i in ${exsltheaders}; do
+ install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
+ done
+
+ cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xslt-config
+ chmod a+rx ${STAGING_BINDIR}/xslt-config
+ install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
+}