aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libxslt
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
commit9c9c7139952b06112d99b5b11bfa3d36435a6459 (patch)
treefd0778f2b3d3d14f05cd4ff4b4cb341573e92d82 /packages/libxslt
parentf73398ac656a31e2bbd214a3b2c3dc92eddaaecf (diff)
downloadopenembedded-9c9c7139952b06112d99b5b11bfa3d36435a6459.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/31 14:27:40-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 14:27:30-08:00 (none)!ggilbert Add many licenses 2004/12/31 21:28:22+00:00 nexus.co.uk!pb fix typo introduced with recent LICENSE patches 2004/12/31 21:12:38+00:00 nexus.co.uk!pb gpe-soundbite is GPL 2004/12/31 21:11:57+00:00 nexus.co.uk!pb gpe-question is GPL 2004/12/31 21:11:12+00:00 nexus.co.uk!pb gpe-nmf is GPL 2004/12/31 21:10:28+00:00 nexus.co.uk!pb gpe-gallery is GPL 2004/12/31 21:09:42+00:00 nexus.co.uk!pb gpe-edit is GPL 2004/12/31 21:07:12+00:00 nexus.co.uk!pb gpe-ownerinfo is GPL 2004/12/31 21:03:44+00:00 nexus.co.uk!pb delete old gpe-bootsplash with no LICENSE 2004/12/31 21:02:29+00:00 nexus.co.uk!pb delete some old gpe-clock versions with no LICENSE 2004/12/31 21:00:16+00:00 nexus.co.uk!pb delete old hotplug-dbus versions with no LICENSE 2004/12/31 20:59:20+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2004/12/31 13:35:00-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 13:34:19-08:00 (none)!ggilbert More licenses 2004/12/31 20:59:03+00:00 nexus.co.uk!pb add LICENSE for gpe-confd, and blow away some old versions BKrev: 41d5d25dQOnhk1FZOyFZXNL3fxoihA
Diffstat (limited to 'packages/libxslt')
-rw-r--r--packages/libxslt/libxslt_1.1.7.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/libxslt/libxslt_1.1.7.bb b/packages/libxslt/libxslt_1.1.7.bb
index e69de29bb2..c1cb486def 100644
--- a/packages/libxslt/libxslt_1.1.7.bb
+++ b/packages/libxslt/libxslt_1.1.7.bb
@@ -0,0 +1,45 @@
+PR = "r0"
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+DEPENDS = "libxml2"
+LICENSE = "MIT"
+PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"
+
+SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug"
+
+xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
+ keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
+ templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
+ xsltexports.h xsltutils.h"
+exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
+
+do_stage () {
+ oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
+ oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxslt
+ for i in ${headers}; do
+ install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
+ done
+ mkdir -p ${STAGING_INCDIR}/libexslt
+ for i in ${headers}; do
+ install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
+ done
+
+ cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xslt-config
+ chmod a+rx ${STAGING_BINDIR}/xslt-config
+ install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
+}