aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux-hotplug
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/linux-hotplug
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/linux-hotplug')
-rw-r--r--packages/linux-hotplug/linux-hotplug_20040920.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/packages/linux-hotplug/linux-hotplug_20040920.bb b/packages/linux-hotplug/linux-hotplug_20040920.bb
index e69de29bb2..764cca82e9 100644
--- a/packages/linux-hotplug/linux-hotplug_20040920.bb
+++ b/packages/linux-hotplug/linux-hotplug_20040920.bb
@@ -0,0 +1,67 @@
+DESCRIPTION = "This package contains the scripts necessary \
+for hotplug Linux support, and lets you plug in new devices \
+and use them immediately."
+HOMEPAGE = "http://linux-hotplug.sourceforge.net/"
+LICENSE = "GPL"
+RPROVIDES = "hotplug"
+RCONFLICTS = "hotplug"
+RREPLACES = "hotplug"
+SECTION = "base"
+RSUGGESTS = "pciutils usbutils"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-2004_09_20.tar.gz \
+ file://userspecified_hcd.patch;patch=1 \
+ file://hotplug-net-agent-usb.patch;patch=1 \
+ file://fix-net.agent \
+ file://update-usb.usermap \
+ file://logcheck-ignore \
+ file://sleeve.agent \
+ file://sleeve.rc \
+ file://mmc.agent \
+ file://usbd.agent \
+ file://usbd \
+ file://sysconfig-hotplug \
+ file://sysconfig-usb \
+ file://isapnp-exit.diff;patch=1 \
+ file://usb-storage"
+
+S = "${WORKDIR}/hotplug-2004_09_20"
+
+INITSCRIPT_NAME = "hotplug"
+INITSCRIPT_PARAMS = "start 40 S . stop 89 0 6 ."
+
+inherit update-rc.d
+
+do_compile () {
+ :
+}
+
+oldmandir := "${mandir}"
+oldsbindir := "${sbindir}"
+prefix = ""
+exec_prefix = ""
+FILES_hotplug_append = " ${oldsbindir}"
+FILES_hotplug-doc_append = " ${oldmandir}"
+
+export DEBFIX = "sed -e 's:sysconfig/usb:default/hotplug.usb:'"
+do_install () {
+ install -d ${D}/${sysconfdir}/logcheck/ignore.d
+ install -d ${D}/${oldmandir}
+ install -d ${D}/${oldsbindir}
+ #install -d ${D}/${sysconfdir}/default
+ oe_runmake prefix=${D}${prefix} exec_prefix=${D}${exec_prefix} \
+ etcdir=${D}${sysconfdir} sbindir=${D}${sbindir} \
+ mandir=${D}${oldmandir} install
+ sh ${WORKDIR}/fix-net.agent ${D} || :
+ install -m 0755 ${WORKDIR}/update-usb.usermap ${D}/${oldsbindir}/
+ install -m 0644 ${WORKDIR}/logcheck-ignore ${D}/${sysconfdir}/logcheck/ignore.d/hotplug
+ install -m 0755 ${WORKDIR}/sleeve.agent ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/sleeve.rc ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/mmc.agent ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/usbd.agent ${D}${sysconfdir}/hotplug/
+ #install -m 0755 ${WORKDIR}/usbd ${D}${sysconfdir}/default/usbd
+ install -d ${D}${sysconfdir}/sysconfig
+ install -m 0644 ${WORKDIR}/sysconfig-hotplug ${D}${sysconfdir}/sysconfig/hotplug
+ install -m 0644 ${WORKDIR}/sysconfig-usb ${D}/${sysconfdir}/sysconfig/usb
+ install -m 0755 ${WORKDIR}/usb-storage ${D}${sysconfdir}/hotplug/usb
+}