aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux-libc-headers
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-03-20 10:48:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-20 10:48:37 +0000
commite404d3f4b1ea1b7a4578d34398a3fcfde8a01870 (patch)
tree40facfd5c0caa2d3faa6c7ebad1e4fdd3cd6feae /packages/linux-libc-headers
parent86629673742ddb672f54f224a85d668aee7955c7 (diff)
downloadopenembedded-e404d3f4b1ea1b7a4578d34398a3fcfde8a01870.tar.gz
linux-libc-headers-2.6.15.99: fix linux/videodev2.h
Diffstat (limited to 'packages/linux-libc-headers')
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-videodev2.patch45
-rw-r--r--packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb6
2 files changed, 49 insertions, 2 deletions
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-videodev2.patch b/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-videodev2.patch
new file mode 100644
index 0000000000..95335c99b6
--- /dev/null
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.15.99/linux-videodev2.patch
@@ -0,0 +1,45 @@
+--- linux-libc-headers-2.6.15.99/include/linux/videodev2.h.orig 2006-03-20 11:14:35.000000000 +0100
++++ linux-libc-headers-2.6.15.99/include/linux/videodev2.h 2006-03-20 11:14:37.000000000 +0100
+@@ -15,7 +15,32 @@
+ */
+ #include <sys/time.h> /* need struct timeval */
+ #include <asm/types.h> /* needed __u64 */
+-
++
++#define OBSOLETE_OWNER 1 /* It will be removed for 2.6.15 */
++#define HAVE_V4L2 1
++
++/*
++ * Common stuff for both V4L1 and V4L2
++ * Moved from videodev.h
++ */
++
++#define VIDEO_MAX_FRAME 32
++
++#define VID_TYPE_CAPTURE 1 /* Can capture */
++#define VID_TYPE_TUNER 2 /* Can tune */
++#define VID_TYPE_TELETEXT 4 /* Does teletext */
++#define VID_TYPE_OVERLAY 8 /* Overlay onto frame buffer */
++#define VID_TYPE_CHROMAKEY 16 /* Overlay by chromakey */
++#define VID_TYPE_CLIPPING 32 /* Can clip */
++#define VID_TYPE_FRAMERAM 64 /* Uses the frame buffer memory */
++#define VID_TYPE_SCALES 128 /* Scalable */
++#define VID_TYPE_MONOCHROME 256 /* Monochrome only */
++#define VID_TYPE_SUBCAPTURE 512 /* Can capture subareas of the image */
++#define VID_TYPE_MPEG_DECODER 1024 /* Can decode MPEG streams */
++#define VID_TYPE_MPEG_ENCODER 2048 /* Can encode MPEG streams */
++#define VID_TYPE_MJPEG_DECODER 4096 /* Can decode MJPEG streams */
++#define VID_TYPE_MJPEG_ENCODER 8192 /* Can encode MJPEG streams */
++
+ /*
+ * M I S C E L L A N E O U S
+ */
+@@ -464,7 +489,7 @@
+ struct v4l2_clip
+ {
+ struct v4l2_rect c;
+- struct v4l2_clip __user *next;
++ struct v4l2_clip *next;
+ };
+
+ struct v4l2_window
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
index f00f4790e5..e8b6e6bb13 100644
--- a/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
+++ b/packages/linux-libc-headers/linux-libc-headers_2.6.15.99.bb
@@ -14,11 +14,13 @@ DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
LICENSE = "GPL"
DEFAULT_PREFERENCE = "-1"
INHIBIT_DEFAULT_DEPS = "1"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://ewi546.ewi.utwente.nl/OE/eabi/linux-libc-headers-${PV}.tar.bz2 \
file://keyboard.patch;patch=1 \
- file://linux-rtc.patch;patch=1"
+ file://asm-arch-irqs.patch;patch=1 \
+ file://linux-rtc.patch;patch=1 \
+ file://linux-videodev2.patch;patch=1"
S = "${WORKDIR}/linux-libc-headers-${PV}"