aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/linux-xxs1500_2.4.21.bb
diff options
context:
space:
mode:
authorNigel Kostiuck <emte@labotomy.net>2004-12-09 22:29:30 +0000
committerNigel Kostiuck <emte@labotomy.net>2004-12-09 22:29:30 +0000
commit9f29948adec0e69b5ec47b712f99b8e9cba52e6f (patch)
tree82b22116050c768bc2737518fe906313fc7de715 /packages/linux/linux-xxs1500_2.4.21.bb
parent85f320d50f9756d1a4e63774721796410e79e433 (diff)
downloadopenembedded-9f29948adec0e69b5ec47b712f99b8e9cba52e6f.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into t.(none):/home/OE/speedracer/packages 2004/12/09 16:29:29-06:00 ti.com!kergoth In some kernel packages, move the set of PACKAGE_ARCH to below the inherit of kernel. BKrev: 41b8d1capsuSJAmgsLcGU1QsukrfIA
Diffstat (limited to 'packages/linux/linux-xxs1500_2.4.21.bb')
-rw-r--r--packages/linux/linux-xxs1500_2.4.21.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/linux/linux-xxs1500_2.4.21.bb b/packages/linux/linux-xxs1500_2.4.21.bb
index e69de29bb2..e4f7fac776 100644
--- a/packages/linux/linux-xxs1500_2.4.21.bb
+++ b/packages/linux/linux-xxs1500_2.4.21.bb
@@ -0,0 +1,36 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for mycable xxs1500"
+LICENSE = "GPL"
+KV = "2.4.21"
+PV = "${KV}"
+
+SRC_URI = "http://mycable.de/xxs1500/cms/index.php?download=linux-2.4.21-20040514.1522.tgz \
+ file://Makefile \
+ file://defconfig-xxs1500 \
+ file://zboot-Makefile-flags.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/linux"
+
+inherit kernel
+
+PACKAGE_ARCH = "xxs1500"
+ARCH = "mips"
+KERNEL_OUTPUT = "arch/mips/zboot/images/xxs1500.flash.srec"
+KERNEL_IMAGETYPE = "zImage.flash"
+KERNEL_IMAGEDEST = "tmp"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig-xxs1500 ${S}/.config
+ cp ${WORKDIR}/Makefile ${S}/arch/mips
+}
+
+FILES_kernel += " /tmp"
+
+do_deploy() {
+ install -d ${DEPLOY_DIR}/images
+ install -m 0644 ${KERNEL_OUTPUT} ${DEPLOY_DIR}/images/${MACHINE}-${KV}-${KERNEL_IMAGETYPE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile