aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/nslu2-kernel.inc
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-24 23:40:41 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-24 23:40:41 +0000
commit52fc464946f780b1302fe9ac47176415faf5ef9a (patch)
tree8ab0bf85e935c741ab1e90dcd9cd96a660562c26 /packages/linux/nslu2-kernel.inc
parent6fdac80bba1c2ccc0e675e2428f830a127fb3fb5 (diff)
downloadopenembedded-52fc464946f780b1302fe9ac47176415faf5ef9a.tar.gz
nslu2-kernel, openslug-kernel: 2.6.14-rc2 (ixp425-eth will not build with this)
Diffstat (limited to 'packages/linux/nslu2-kernel.inc')
-rw-r--r--packages/linux/nslu2-kernel.inc7
1 files changed, 4 insertions, 3 deletions
diff --git a/packages/linux/nslu2-kernel.inc b/packages/linux/nslu2-kernel.inc
index 33867b0e34..695268eb18 100644
--- a/packages/linux/nslu2-kernel.inc
+++ b/packages/linux/nslu2-kernel.inc
@@ -212,12 +212,13 @@ inherit kernel
ARCH = "arm"
KERNEL_IMAGETYPE = "zImage"
# To specify the console set KERNEL_CONSOLE in the .bb file.
-# CMDLINE_ROOT contains the boot options
-CMDLINE_REBOOT ?= "reboot=s"
+# CMDLINE_ROOT contains the boot options, CMDLINE_KERNEL_OPTIONS
+# contains the things for a specific kernel.
+CMDLINE_KERNEL_OPTIONS ?= "reboot=s"
CMDLINE_ROOT ?= "root=/dev/mtdblock4 rw rootfstype=jffs2 mem=32M@0x00000000 init=/linuxrc"
# Add distro specific debug (or non-debug) options to this
CMDLINE_DEBUG ?= ""
-CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_REBOOT} ${CMDLINE_DEBUG} ${CMDLINE_CONSOLE}"
+CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_KERNEL_OPTIONS} ${CMDLINE_DEBUG} ${CMDLINE_CONSOLE}"
# Add the architecture compiler flags to KERNEL_CC and KERNEL_LD as
# required. Notice that this has to be done for each separately built