aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/openslug-kernel_2.6.11.2.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-11 07:07:34 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-11 07:07:34 +0000
commita90c73d1c0f133ae4e0b32ec9c290597be03b876 (patch)
tree9f741a92308f44b03640e34601343fcad55841dd /packages/linux/openslug-kernel_2.6.11.2.bb
parent894b7f2a3c1ab1fd49948ae812010d23520fc554 (diff)
downloadopenembedded-a90c73d1c0f133ae4e0b32ec9c290597be03b876.tar.gz
nslu2-kernel: cleanup openslug, ucslugc and slugos kernels, ALL
- remove old kernel versions - remove openslug-kernel - move patches from openslug-kernel - fix kernel UTS_RELEASE handling (requires change in kernel.bbclass) - fix nslu2-kernel MM build - move to 2.6.14.1 (important security fix)
Diffstat (limited to 'packages/linux/openslug-kernel_2.6.11.2.bb')
-rw-r--r--packages/linux/openslug-kernel_2.6.11.2.bb64
1 files changed, 0 insertions, 64 deletions
diff --git a/packages/linux/openslug-kernel_2.6.11.2.bb b/packages/linux/openslug-kernel_2.6.11.2.bb
deleted file mode 100644
index 8e2555d014..0000000000
--- a/packages/linux/openslug-kernel_2.6.11.2.bb
+++ /dev/null
@@ -1,64 +0,0 @@
-SECTION = "kernel"
-DESCRIPTION = "Linux kernel for the Linksys NSLU2 device"
-LICENSE = "GPL"
-MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
-PR = "r15"
-
-KERNEL_SUFFIX = "openslug"
-
-SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.11.2.tar.bz2 \
- file://nslu2_2.6.11.patch;patch=1 \
- file://usbnet.patch;patch=1 \
- file://ixp4xx_copy_from.patch;patch=1 \
- file://anonymiser.patch;patch=1 \
- file://xscale-reset.patch;patch=1 \
- file://mtd-shutdown.patch;patch=1 \
- file://defconfig \
- file://x1205-rtc.c \
- file://nslu2-io.c \
- file://nslu2-setup.c \
- file://nslu2-pci.c \
- file://nslu2-part.c \
- file://nslu2.h"
-S = "${WORKDIR}/linux-2.6.11.2"
-
-COMPATIBLE_HOST = 'arm.*-linux'
-
-inherit kernel
-
-ARCH = "arm"
-KERNEL_IMAGETYPE = "zImage"
-CMDLINE_CONSOLE ?= "ttyS0,115200n8"
-CMDLINE_ROOT ?= "root=/dev/mtdblock4 rw rootfstype=jffs2 mem=32M@0x00000000 init=/linuxrc reboot=s"
-#CMDLINE_ROOT ?= "root=/dev/ram0 rw rootfstype=ext2,jffs2 initrd=0x01000000,10M init=/linuxrc mem=32M@0x00000000"
-CMDLINE = "${CMDLINE_ROOT} ${CMDLINE_CONSOLE}"
-
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/defconfig ${S}/.config
- install -m 0644 ${WORKDIR}/x1205-rtc.c ${S}/drivers/i2c/chips/x1205-rtc.c
- install -m 0644 ${WORKDIR}/nslu2-io.c ${S}/arch/arm/mach-ixp4xx/nslu2-io.c
- install -m 0644 ${WORKDIR}/nslu2-setup.c ${S}/arch/arm/mach-ixp4xx/nslu2-setup.c
- install -m 0644 ${WORKDIR}/nslu2-pci.c ${S}/arch/arm/mach-ixp4xx/nslu2-pci.c
- install -m 0644 ${WORKDIR}/nslu2-part.c ${S}/arch/arm/mach-ixp4xx/nslu2-part.c
- install -m 0644 ${WORKDIR}/nslu2.h ${S}/include/asm-arm/arch-ixp4xx/nslu2.h
- echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
- rm -rf ${S}/include/asm-arm/arch ${S}/include/asm-arm/proc \
- ${S}/include/asm-arm/.proc ${S}/include/asm-arm/.arch
-}
-
-do_deploy() {
- install -d ${DEPLOY_DIR}/images
- install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}-${KERNEL_SUFFIX}
-}
-
-do_deploy[dirs] = "${S}"
-
-addtask deploy before do_build after do_compile
-
-python () {
- # Don't build openslug kernel unless we're targeting an nslu2
- mach = bb.data.getVar("MACHINE", d, 1)
- dist = bb.data.getVar("DISTRO", d, 1)
- if mach != 'nslu2' or dist != 'openslug':
- raise bb.parse.SkipPackage("OpenSlug only builds for the Linksys NSLU2")
-}