aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-12-18 23:53:14 +0800
committerJohn Lee <john_lee@openmoko.org>2008-12-18 23:59:14 +0800
commit5c6f095127528bb59c3922fbdfae0800bb687621 (patch)
tree1e54369ebb25449d7666cb858090b5b241fb20c4 /packages/linux
parentc8bcd04b41eef0170427b90494dbd1bbdc84cff6 (diff)
downloadopenembedded-5c6f095127528bb59c3922fbdfae0800bb687621.tar.gz
linux-openmoko: don't flash kernel if using SD card.
modify the post-install script then it will not flash kernel image after upgrade kernel if people boot from SD card.
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-openmoko-devel_git.bb2
-rw-r--r--packages/linux/linux-openmoko.inc9
-rw-r--r--packages/linux/linux-openmoko_2.6.24+git.bb2
3 files changed, 10 insertions, 3 deletions
diff --git a/packages/linux/linux-openmoko-devel_git.bb b/packages/linux/linux-openmoko-devel_git.bb
index d3f5d3fdfe..94cc8eb8d3 100644
--- a/packages/linux/linux-openmoko-devel_git.bb
+++ b/packages/linux/linux-openmoko-devel_git.bb
@@ -10,7 +10,7 @@ KERNEL_VERSION = "${KERNEL_RELEASE}"
OEV = "oe2"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
diff --git a/packages/linux/linux-openmoko.inc b/packages/linux/linux-openmoko.inc
index c986975851..278a01d5ee 100644
--- a/packages/linux/linux-openmoko.inc
+++ b/packages/linux/linux-openmoko.inc
@@ -56,9 +56,14 @@ do_deploy_append() {
RDEPENDS_kernel-image += "mtd-utils"
pkg_postinst_kernel-image () {
+
+# Get the lastest root file system value of boot args
+boot_arg=`cat /proc/cmdline |tr " " "\n"|grep "root=" |tail -n 1`
+has_mtdblock=`echo $boot_arg |grep mtdblock`
+
if test "x$D" != "x"; then
exit 1
-else
+elif test "empty$has_mtdblock" != "empty"; then
if [ -f ${sysconfdir}/default/flashkernel ] ; then
echo "Upgrading Kernel in Flash"
echo "DO NOT stop this process"
@@ -79,6 +84,8 @@ else
else
touch ${sysconfdir}/default/flashkernel
fi
+else
+ echo "You are not booting from NAND, don't flash kernel into mtdblock."
fi
}
diff --git a/packages/linux/linux-openmoko_2.6.24+git.bb b/packages/linux/linux-openmoko_2.6.24+git.bb
index 6f62b3dbdf..48b7effd55 100644
--- a/packages/linux/linux-openmoko_2.6.24+git.bb
+++ b/packages/linux/linux-openmoko_2.6.24+git.bb
@@ -8,7 +8,7 @@ KERNEL_VERSION = "${KERNEL_RELEASE}"
OEV = "oe3"
PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "\
git://git.openmoko.org/git/kernel.git;protocol=git;branch=stable \