aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-25 05:35:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-25 05:35:46 +0000
commit700b8e3f9bad98c84f78a1088e0699614812fff8 (patch)
treed3aeb42fe5f5dc0b559468c5382ec3f3bd13ddd5 /packages/linux
parente7dbecaf9328062a579ab0537cfea34769bafd04 (diff)
downloadopenembedded-700b8e3f9bad98c84f78a1088e0699614812fff8.tar.gz
nslu2-kernel: minor fix for a header file error
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/nslu2-kernel/2.6.14/15-ixp4xx-writesb-l-w.patch31
-rw-r--r--packages/linux/nslu2-kernel_2.6.14-rc2.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/packages/linux/nslu2-kernel/2.6.14/15-ixp4xx-writesb-l-w.patch b/packages/linux/nslu2-kernel/2.6.14/15-ixp4xx-writesb-l-w.patch
new file mode 100644
index 0000000000..6ac0807f1e
--- /dev/null
+++ b/packages/linux/nslu2-kernel/2.6.14/15-ixp4xx-writesb-l-w.patch
@@ -0,0 +1,31 @@
+# The inline caller of these APIs were changed to have
+# const vaddr parameters...
+--- linux-2.6.13/include/asm-arm/arch-ixp4xx/io.h.orig 2005-09-24 17:06:19.968099976 -0700
++++ linux-2.6.13/include/asm-arm/arch-ixp4xx/io.h 2005-09-24 17:06:52.542149731 -0700
+@@ -113,7 +113,7 @@
+ }
+
+ static inline void
+-__ixp4xx_writesb(u32 bus_addr, u8 *vaddr, int count)
++__ixp4xx_writesb(u32 bus_addr, const u8 *vaddr, int count)
+ {
+ while (count--)
+ writeb(*vaddr++, bus_addr);
+@@ -136,7 +136,7 @@
+ }
+
+ static inline void
+-__ixp4xx_writesw(u32 bus_addr, u16 *vaddr, int count)
++__ixp4xx_writesw(u32 bus_addr, const u16 *vaddr, int count)
+ {
+ while (count--)
+ writew(*vaddr++, bus_addr);
+@@ -154,7 +154,7 @@
+ }
+
+ static inline void
+-__ixp4xx_writesl(u32 bus_addr, u32 *vaddr, int count)
++__ixp4xx_writesl(u32 bus_addr, const u32 *vaddr, int count)
+ {
+ while (count--)
+ writel(*vaddr++, bus_addr);
diff --git a/packages/linux/nslu2-kernel_2.6.14-rc2.bb b/packages/linux/nslu2-kernel_2.6.14-rc2.bb
index 601003e0cf..6430abc86a 100644
--- a/packages/linux/nslu2-kernel_2.6.14-rc2.bb
+++ b/packages/linux/nslu2-kernel_2.6.14-rc2.bb
@@ -27,6 +27,7 @@ N2K_PATCHES = "\
file://10-ixp4xx-copy-from.patch;patch=1 \
file://10-ixp4xx-gpio.patch;patch=1 \
file://10-ixp4xx-ticks.patch;patch=1 \
+ file://15-ixp4xx-writesb-l-w.patch;patch=1 \
file://30-i2c-x1205.patch;patch=1 \
file://50-nslu2-arch.patch;patch=1 \
file://50-nslu2-general.patch;patch=1 \