aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-09-17 15:30:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-17 15:30:28 +0000
commitc9ed87ab7acd3ca88fc79a5326233aea1f7c6cb9 (patch)
treeca37682343e691f799d89d14f3ecc9dfc6b4dc0f /packages/linux
parent27c6f0fc343c4148dd82578e784201ce3255327d (diff)
downloadopenembedded-c9ed87ab7acd3ca88fc79a5326233aea1f7c6cb9.tar.gz
linux-oz-2.6: Fix the pcmcia card resume problem (introduced by the pcmcia maintainer). Add tosa to the list of devices to enforce a kernel size limit on.
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-openzaurus_2.6.13-mm3.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/packages/linux/linux-openzaurus_2.6.13-mm3.bb b/packages/linux/linux-openzaurus_2.6.13-mm3.bb
index cc9ec6df0d..1e714ea9c5 100644
--- a/packages/linux/linux-openzaurus_2.6.13-mm3.bb
+++ b/packages/linux/linux-openzaurus_2.6.13-mm3.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
#KV = "${@bb.data.getVar('PV',d,True).split('-')[0]}"
KV = "${@bb.data.getVar('PV',d,True)}"
-PR = "r0"
+PR = "r1"
DOSRC = "http://www.do13.in-berlin.de/openzaurus/patches"
RPSRC = "http://www.rpsys.net/openzaurus/patches"
@@ -33,6 +33,7 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.13.tar.gz \
${RPSRC}/poodle_mmc-r0.patch;patch=1 \
${RPSRC}/poodle_irda-r0.patch;patch=1 \
${RPSRC}/pxa_i2c_fixes-r0.patch;patch=1 \
+ ${RPSRC}/pcmcia_really_resume-r0.patch;patch=1 \
${RPSRC}/spitz_usbsuspend-r0.patch;patch=1 \
${RPSRC}/pxa_ohci_platform-r0.patch;patch=1 \
${RPSRC}/sharpsl_pm-r8.patch;patch=1 \
@@ -178,7 +179,7 @@ do_configure() {
# Check the kernel is below the 1272*1024 byte limit for the PXA Zaurii
do_compile_append() {
case ${MACHINE} in
- c7x0 | akita | poodle | spitz | borzoi )
+ c7x0 | akita | poodle | spitz | borzoi | tosa )
size=`ls arch/${ARCH}/boot/${KERNEL_IMAGETYPE} -s | cut -d ' ' -f 1`
if [ $size -ge 1271 ]; then
rm arch/${ARCH}/boot/${KERNEL_IMAGETYPE}