aboutsummaryrefslogtreecommitdiffstats
path: root/packages/logrotate
diff options
context:
space:
mode:
authorhillct-oe <hillct-oe@pinnacledigital.com>2007-03-18 00:06:47 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-03-18 00:06:47 +0000
commitf86bf9cfd0a9e5eb9f22354211b75c99d187cb31 (patch)
tree3601abad9c0a4fadd1d13abdd8a59aaa8b17af0b /packages/logrotate
parent4ea3fadb1ee5e445a40d2dff48b30024e1ee3c9f (diff)
downloadopenembedded-f86bf9cfd0a9e5eb9f22354211b75c99d187cb31.tar.gz
logrotate 3.7.1: Eliminated hard coded paths, removed recommendation of gzip
since it's typically provided by busybox which we can expect to always be present. Also added proper config file specification. Closes #2014.
Diffstat (limited to 'packages/logrotate')
-rw-r--r--packages/logrotate/logrotate_3.7.1.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/packages/logrotate/logrotate_3.7.1.bb b/packages/logrotate/logrotate_3.7.1.bb
index 2697607cfd..b903e60201 100644
--- a/packages/logrotate/logrotate_3.7.1.bb
+++ b/packages/logrotate/logrotate_3.7.1.bb
@@ -1,12 +1,11 @@
DESCRIPTION = "Rotates, compresses, removes and mails system log files"
HOMEPAGE = "http://packages.debian.org/unstable/admin/logrotate"
RCONFLICTS = "logrotate-script"
-RRECOMMENDS = "gzip"
DEPENDS = "popt"
RDEPENDS = "cron"
SECTION = "admin"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://ftp.debian.org/debian/pool/main/l/logrotate/logrotate_${PV}.orig.tar.gz \
file://logrotate-3.7.1.patch;patch=1 \
@@ -22,18 +21,20 @@ do_compile() {
do_install () {
# Install the binary and conf file
- install -D -s -m 0755 ${WORKDIR}/logrotate-${PV}/logrotate ${D}${base_sbindir}/logrotate
+ install -D -s -m 0755 ${S}/logrotate ${D}${base_sbindir}/logrotate
install -D -m 0644 ${WORKDIR}/logrotate.conf ${D}${sysconfdir}/logrotate.conf
install -m 0755 -d ${D}${sysconfdir}/logrotate.d
}
pkg_postinst () {
# Add the logrotate line to /etc/crontab
- grep -q "/sbin/logrotate" ${sysconfdir}/crontab || echo "*/5 * * * * /sbin/logrotate /etc/logrotate.conf" >> ${sysconfdir}/crontab
+ grep -q "${base_sbindir}/logrotate" ${sysconfdir}/crontab || echo "*/5 * * * * ${base_sbindir}/logrotate ${sysconfdir}/logrotate.conf" >> ${sysconfdir}/crontab
}
pkg_postrm() {
# Remove the logrotate line from /etc/crontab
- grep -v /sbin/logrotate ${sysconfdir}/crontab > ${sysconfdir}/crontab.no-${PF}
+ grep -v ${base_sbindir}/logrotate ${sysconfdir}/crontab > ${sysconfdir}/crontab.no-${PF}
mv ${sysconfdir}/crontab.no-${PF} ${sysconfdir}/crontab
}
+
+CONFFILES += "${sysconfdir}/logrotate.conf"