aboutsummaryrefslogtreecommitdiffstats
path: root/packages/madwifi
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-08-04 07:48:35 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-08-04 07:48:35 +0000
commite09578d22ab64c421ae3cc0c14b58e48a3699829 (patch)
tree1052b0aa08c43d6eb1aa96e2d3120237aaa317f0 /packages/madwifi
parent3e6c814794c2b9ad699b999e397cea8e95db139e (diff)
downloadopenembedded-e09578d22ab64c421ae3cc0c14b58e48a3699829.tar.gz
madwifi-ng r1692: Add madwifi snapshot 1692, which is the same as the 0.9.2
madwifi release (apart from the version number). This brings in a lot of fixes and makes it far more stable on my sh4 based device. I've decided not to use the actual 0.9.2 release .tar files for now since the snapshot and release version number are not really compatible and some solution for that would be needed first.
Diffstat (limited to 'packages/madwifi')
-rw-r--r--packages/madwifi/madwifi-ng_r.inc49
-rw-r--r--packages/madwifi/madwifi-ng_r1527-20060425.bb49
-rw-r--r--packages/madwifi/madwifi-ng_r1692-20060723.bb2
3 files changed, 52 insertions, 48 deletions
diff --git a/packages/madwifi/madwifi-ng_r.inc b/packages/madwifi/madwifi-ng_r.inc
new file mode 100644
index 0000000000..488d9aefa4
--- /dev/null
+++ b/packages/madwifi/madwifi-ng_r.inc
@@ -0,0 +1,49 @@
+DESCRIPTION = "Linux driver for 802.11a/b/g universal NIC cards using Atheros chip sets"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
+LICENSE = "GPL"
+RDEPENDS = "kernel (${KERNEL_VERSION})"
+DEPENDS = "virtual/kernel"
+PR="r0"
+
+SRC_URI = "http://snapshots.madwifi.org/${PN}/${PN}-${PV}.tar.gz \
+ file://10-xscale-be-elf-copts.patch;patch=1 \
+ file://10-xscale-le-elf-copts.patch;patch=1 \
+ file://10-sh4-le-elf-copts.patch;patch=1"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit module-base
+
+EXTRA_OEMAKE = "LDFLAGS= KERNELPATH=${STAGING_KERNEL_DIR} KERNELRELEASE=${KERNEL_VERSION} TOOLPREFIX=${TARGET_PREFIX}"
+
+EXTRA_OEMAKE_prepend_slugos = "TARGET=xscale-${ARCH_BYTE_SEX}-elf "
+
+do_compile() {
+ oe_runmake all
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/${PN}/include
+ install -d ${STAGING_INCDIR}/${PN}/net80211
+ cp --dereference include/compat.h ${STAGING_INCDIR}/${PN}/include/
+ cp --dereference net80211/*.h ${STAGING_INCDIR}/${PN}/net80211/
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ oe_runmake DESTDIR=${D} BINDIR=${sbindir} install
+}
+
+pkg_postinst() {
+if test "x$D" != "x"; then
+ exit 1
+else
+ depmod -ae
+fi
+}
+
+PACKAGES = "${PN}-modules ${PN}-tools"
+FILES_${PN}-modules = "/lib/modules/"
+FILES_${PN}-tools = "/usr/"
diff --git a/packages/madwifi/madwifi-ng_r1527-20060425.bb b/packages/madwifi/madwifi-ng_r1527-20060425.bb
index 488d9aefa4..78966bdb40 100644
--- a/packages/madwifi/madwifi-ng_r1527-20060425.bb
+++ b/packages/madwifi/madwifi-ng_r1527-20060425.bb
@@ -1,49 +1,2 @@
-DESCRIPTION = "Linux driver for 802.11a/b/g universal NIC cards using Atheros chip sets"
-SECTION = "base"
-PRIORITY = "optional"
-MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
-LICENSE = "GPL"
-RDEPENDS = "kernel (${KERNEL_VERSION})"
-DEPENDS = "virtual/kernel"
+include madwifi-ng_r.inc
PR="r0"
-
-SRC_URI = "http://snapshots.madwifi.org/${PN}/${PN}-${PV}.tar.gz \
- file://10-xscale-be-elf-copts.patch;patch=1 \
- file://10-xscale-le-elf-copts.patch;patch=1 \
- file://10-sh4-le-elf-copts.patch;patch=1"
-
-S = "${WORKDIR}/${PN}-${PV}"
-
-inherit module-base
-
-EXTRA_OEMAKE = "LDFLAGS= KERNELPATH=${STAGING_KERNEL_DIR} KERNELRELEASE=${KERNEL_VERSION} TOOLPREFIX=${TARGET_PREFIX}"
-
-EXTRA_OEMAKE_prepend_slugos = "TARGET=xscale-${ARCH_BYTE_SEX}-elf "
-
-do_compile() {
- oe_runmake all
-}
-
-do_stage() {
- install -d ${STAGING_INCDIR}/${PN}/include
- install -d ${STAGING_INCDIR}/${PN}/net80211
- cp --dereference include/compat.h ${STAGING_INCDIR}/${PN}/include/
- cp --dereference net80211/*.h ${STAGING_INCDIR}/${PN}/net80211/
-}
-
-do_install() {
- install -d ${D}${sbindir}
- oe_runmake DESTDIR=${D} BINDIR=${sbindir} install
-}
-
-pkg_postinst() {
-if test "x$D" != "x"; then
- exit 1
-else
- depmod -ae
-fi
-}
-
-PACKAGES = "${PN}-modules ${PN}-tools"
-FILES_${PN}-modules = "/lib/modules/"
-FILES_${PN}-tools = "/usr/"
diff --git a/packages/madwifi/madwifi-ng_r1692-20060723.bb b/packages/madwifi/madwifi-ng_r1692-20060723.bb
new file mode 100644
index 0000000000..78966bdb40
--- /dev/null
+++ b/packages/madwifi/madwifi-ng_r1692-20060723.bb
@@ -0,0 +1,2 @@
+include madwifi-ng_r.inc
+PR="r0"