aboutsummaryrefslogtreecommitdiffstats
path: root/packages/maemo4/libhildonmime.inc
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-02-14 10:04:21 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-02-14 10:04:21 +0000
commit80aae1fa0adb151536096e8354acddb1cf0f8809 (patch)
tree06bb0886036217b98d10b0e244844eecf70cc47e /packages/maemo4/libhildonmime.inc
parent3132647d57bab70919f8207d237878056378345d (diff)
downloadopenembedded-80aae1fa0adb151536096e8354acddb1cf0f8809.tar.gz
Reworked maemo4 packages
hildon-1: Removed, replaced by libhildon hildon-lgpl: Removed (obsolete in Maemo 4.0) hildon-libs: Removed (obsolete in Maemo 4.0) outo: Removed (integrated in libosso). libhildon: Updated to Maemo 4.0 version. libhildonfm: Updated to Maemo 4.0 version. libconic: Updated to Maemo 4.0 version. libosso: Updated to Maemo 4.0 version. mce-dev: Updated to Maemo 4.0 version. osso-gwconnect: Updated to Maemo 4.0 version. hildon-thumbnail: Updated to Maemo 4.0 version. osso-thumbnail: Removed, replaced by hildon-thumbnail. osso-gnome-vf2: New recipe, needed for other OSSO libraries. osso-ic-oss: Adjusted dependencies. libhildonmime: Adjusted dependencies. libhildonhelp: Adjusted dependencies. libgpsbt: Adjusted dependencies. libgpsmgr: Adjusted dependencies. libosso-gsf: Adjusted dependencies.
Diffstat (limited to 'packages/maemo4/libhildonmime.inc')
-rw-r--r--packages/maemo4/libhildonmime.inc17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/maemo4/libhildonmime.inc b/packages/maemo4/libhildonmime.inc
new file mode 100644
index 0000000000..12c74a334b
--- /dev/null
+++ b/packages/maemo4/libhildonmime.inc
@@ -0,0 +1,17 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia hildon mime library"
+
+DEPENDS = "libosso gnome-vfs"
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.in
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+