aboutsummaryrefslogtreecommitdiffstats
path: root/packages/maemo
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-07-01 20:51:02 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-01 20:51:02 +0000
commit6dde4d5dfdfba8b7fe16db6572059ad9bf5ae921 (patch)
treeccac5580ad317c2ebe42b6782fca756adcb53f03 /packages/maemo
parentc0c13ed4c933845dc25fdb387774da8f476875aa (diff)
downloadopenembedded-6dde4d5dfdfba8b7fe16db6572059ad9bf5ae921.tar.gz
Add several utility applications for maemo images.
Diffstat (limited to 'packages/maemo')
-rw-r--r--packages/maemo/osso-app-killer_0.4-3.bb14
-rw-r--r--packages/maemo/osso-screenshot-tool_1.20-1.bb10
-rw-r--r--packages/maemo/tscalib/.mtn2git_empty0
-rw-r--r--packages/maemo/tscalib/makefile.patch24
-rw-r--r--packages/maemo/tscalib_0.0.1-3.bb19
5 files changed, 67 insertions, 0 deletions
diff --git a/packages/maemo/osso-app-killer_0.4-3.bb b/packages/maemo/osso-app-killer_0.4-3.bb
new file mode 100644
index 0000000000..7ecc7723bf
--- /dev/null
+++ b/packages/maemo/osso-app-killer_0.4-3.bb
@@ -0,0 +1,14 @@
+PR = "r0"
+LICENSE = "GPL"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+
+DEPENDS = "libosso"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/o/${PN}/${PN}_${PV}.tar.gz"
+
+S = ${WORKDIR}/${PN}-0.4
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${libdir}/dbus-1.0"
+
diff --git a/packages/maemo/osso-screenshot-tool_1.20-1.bb b/packages/maemo/osso-screenshot-tool_1.20-1.bb
new file mode 100644
index 0000000000..3b039be934
--- /dev/null
+++ b/packages/maemo/osso-screenshot-tool_1.20-1.bb
@@ -0,0 +1,10 @@
+PR = "r0"
+LICENSE = ""
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+
+DEPENDS = "gtk+-2.6.4-1.osso7"
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/o/${PN}/${PN}_${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}-1.20"
+
+inherit pkgconfig autotools
diff --git a/packages/maemo/tscalib/.mtn2git_empty b/packages/maemo/tscalib/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/maemo/tscalib/.mtn2git_empty
diff --git a/packages/maemo/tscalib/makefile.patch b/packages/maemo/tscalib/makefile.patch
new file mode 100644
index 0000000000..7bfab4f142
--- /dev/null
+++ b/packages/maemo/tscalib/makefile.patch
@@ -0,0 +1,24 @@
+--- Makefile.orig 2005-06-20 18:44:26.000000000 +0200
++++ Makefile 2005-06-20 18:43:56.000000000 +0200
+@@ -1,6 +1,4 @@
+
+-CC = gcc
+-CFLAGS = -Os
+ LIBS = -lts
+ PREFIX = /usr/local
+
+@@ -20,11 +18,11 @@
+ rm -rf $(OBJECTS) $(TARGET) .depends
+
+ install: $(TARGET)
+- install -d -m 755 $(PREFIX)/bin
+- install -c -m 755 $(TARGET) $(PREFIX)/bin/$(TARGET)
++ install -d -m 755 $(DESTDIR)/$(PREFIX)/bin
++ install -c -m 755 $(TARGET) $(DESTDIR)/$(PREFIX)/bin/$(TARGET)
+
+ .depends:
+- $(CC) -MM $(SOURCES) > .depends
++ $(CC) -MM $(CFLAGS) $(SOURCES) > .depends
+
+
+ -include .depends
diff --git a/packages/maemo/tscalib_0.0.1-3.bb b/packages/maemo/tscalib_0.0.1-3.bb
new file mode 100644
index 0000000000..6c1a72b185
--- /dev/null
+++ b/packages/maemo/tscalib_0.0.1-3.bb
@@ -0,0 +1,19 @@
+PR = "r0"
+LICENSE = "GPL"
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+DEPENDS = "virtual/xserver tslib"
+
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/t/${PN}/${PN}_${PV}.tar.gz \
+ file://makefile.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+do_compile () {
+ oe_runmake PREFIX=${prefix}
+}
+
+do_install() {
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install
+}