aboutsummaryrefslogtreecommitdiffstats
path: root/packages/make
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-09-10 02:29:21 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-09-10 02:29:21 +0000
commit84d7c28c9f3500d75d9ef71a0214259e8c9eea40 (patch)
tree6e6f539a38bb263d02b58a6036b46ed943c33ed9 /packages/make
parent33166e78814f0664ded6d77db75b67b619c0d687 (diff)
downloadopenembedded-84d7c28c9f3500d75d9ef71a0214259e8c9eea40.tar.gz
make: Add version 3.81 for both make and make-native.
Diffstat (limited to 'packages/make')
-rw-r--r--packages/make/files/.mtn2git_empty0
-rw-r--r--packages/make/files/SCCS.patch (renamed from packages/make/make-3.80/SCCS.patch)0
-rw-r--r--packages/make/make-native_3.80.bb15
-rw-r--r--packages/make/make-native_3.81.bb14
-rw-r--r--packages/make/make.inc11
-rw-r--r--packages/make/make_3.80.bb10
-rw-r--r--packages/make/make_3.81.bb3
7 files changed, 40 insertions, 13 deletions
diff --git a/packages/make/files/.mtn2git_empty b/packages/make/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/make/files/.mtn2git_empty
diff --git a/packages/make/make-3.80/SCCS.patch b/packages/make/files/SCCS.patch
index c998e118ed..c998e118ed 100644
--- a/packages/make/make-3.80/SCCS.patch
+++ b/packages/make/files/SCCS.patch
diff --git a/packages/make/make-native_3.80.bb b/packages/make/make-native_3.80.bb
index e930740d5b..509558c405 100644
--- a/packages/make/make-native_3.80.bb
+++ b/packages/make/make-native_3.80.bb
@@ -1,9 +1,14 @@
-require make_${PV}.bb
-inherit native
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/make-${PV}"
+PR = "r0"
+
S = "${WORKDIR}/make-${PV}"
+inherit native
+
do_stage() {
- install -d ${STAGING_BINDIR}
- install -m 755 make ${STAGING_BINDIR}
+ install -d ${STAGING_BINDIR}
+ install -m 755 make ${STAGING_BINDIR}
}
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/make-${PV}"
+
+require make_${PV}.bb
diff --git a/packages/make/make-native_3.81.bb b/packages/make/make-native_3.81.bb
new file mode 100644
index 0000000000..509558c405
--- /dev/null
+++ b/packages/make/make-native_3.81.bb
@@ -0,0 +1,14 @@
+PR = "r0"
+
+S = "${WORKDIR}/make-${PV}"
+
+inherit native
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 make ${STAGING_BINDIR}
+}
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/make-${PV}"
+
+require make_${PV}.bb
diff --git a/packages/make/make.inc b/packages/make/make.inc
new file mode 100644
index 0000000000..31223cbbf1
--- /dev/null
+++ b/packages/make/make.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "GNU Make examines the timestamps on a set of \
+interdependent files, and, if necessary, issues commands \
+to bring them up-to-date."
+HOMEPAGE = "http://www.gnu.org/software/make/"
+SECTION = "devel"
+LICENSE = "GPL"
+
+SRC_URI = "${GNU_MIRROR}/make/make-${PV}.tar.bz2 \
+ file://SCCS.patch;patch=1"
+
+inherit autotools
diff --git a/packages/make/make_3.80.bb b/packages/make/make_3.80.bb
index 565b460f10..797d26b3be 100644
--- a/packages/make/make_3.80.bb
+++ b/packages/make/make_3.80.bb
@@ -1,9 +1,3 @@
-SECTION = "devel"
-DESCRIPTION = "GNU Make examines the timestamps on a set of \
-interdependent files, and, if necessary, issues commands \
-to bring them up-to-date."
-LICENSE = "GPL"
-SRC_URI = "${GNU_MIRROR}/make/make-${PV}.tar.bz2 \
- file://SCCS.patch;patch=1"
+PR = "r0"
-inherit autotools
+require make.inc
diff --git a/packages/make/make_3.81.bb b/packages/make/make_3.81.bb
new file mode 100644
index 0000000000..797d26b3be
--- /dev/null
+++ b/packages/make/make_3.81.bb
@@ -0,0 +1,3 @@
+PR = "r0"
+
+require make.inc