aboutsummaryrefslogtreecommitdiffstats
path: root/packages/maradns
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/maradns
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/maradns')
-rw-r--r--packages/maradns/maradns_1.0.23.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/maradns/maradns_1.0.23.bb b/packages/maradns/maradns_1.0.23.bb
index e69de29bb2..abb0de5dd7 100644
--- a/packages/maradns/maradns_1.0.23.bb
+++ b/packages/maradns/maradns_1.0.23.bb
@@ -0,0 +1,44 @@
+SECTION = "console/network"
+DESCRIPTION = "A security-aware DNS server"
+HOMEPAGE = "http://www.maradns.org"
+LICENSE = "PD"
+MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
+
+SRC_URI = "http://www.maradns.org/download/maradns-${PV}.tar.bz2 \
+ file://init \
+ file://rng-makefile-build-cc.patch;patch=1;pnum=0"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -d ${D}/${sbindir}
+ install -d ${D}/${sysconfdir}
+ install -d ${D}/${sysconfdir}/mararc
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}/${mandir}/man1
+ install -d ${D}/${mandir}/man5
+ install -d ${D}/${mandir}/man8
+
+ sed -i -e "s:PREFIX/man:PREFIX/share/man:" \
+ -e "s:PREFIX/doc/maradns-\$VERSION:PREFIX/share/doc/${PF}:" \
+ build/install.locations
+
+ oe_runmake \
+ TOPLEVEL=${S} \
+ BUILDDIR=${S}/build \
+ RPM_BUILD_ROOT=${D} \
+ PREFIX=${D}/usr \
+ MAN1=${D}${mandir}/man1 \
+ MAN5=${D}${mandir}/man5 \
+ MAN8=${D}${mandir}/man8 \
+ install
+
+ mv ${D}/${sysconfdir}/mararc/example_mararc ${D}/${sysconfdir}/maradns/mararc
+ rm -r ${D}/${sysconfdir}/mararc/
+ install -m 755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/maradns
+}
+
+PACKAGES = "maradns-zone maradns-ask maradns maradns-doc"
+FILES_maradns-zone = "${sbindir}/zoneserver ${bindir}/getzone"
+FILES_maradns-ask = "${bindir}/askmara"
+
+CONFFILES_${PN}_nylon = "/etc/maradns/mararc"