aboutsummaryrefslogtreecommitdiffstats
path: root/packages/matchbox-panel
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2006-04-06 20:17:01 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-06 20:17:01 +0000
commitdbf50e2a6b64e411d6744fa25d9afba749aa0257 (patch)
treee7647d439162754d46b9d1ad45465f714e49419a /packages/matchbox-panel
parentddc94336e8ec340f4334942cc984bb5c3aba2621 (diff)
downloadopenembedded-dbf50e2a6b64e411d6744fa25d9afba749aa0257.tar.gz
matchbox-panel: add a patch from svn that slightly improves applet resizing (but doesn't fix it entirely)
Diffstat (limited to 'packages/matchbox-panel')
-rw-r--r--packages/matchbox-panel/matchbox-panel-0.9.2/mb-panel-svn-r1162.diff87
-rw-r--r--packages/matchbox-panel/matchbox-panel_0.9.2.bb3
2 files changed, 89 insertions, 1 deletions
diff --git a/packages/matchbox-panel/matchbox-panel-0.9.2/mb-panel-svn-r1162.diff b/packages/matchbox-panel/matchbox-panel-0.9.2/mb-panel-svn-r1162.diff
new file mode 100644
index 0000000000..147a2ef1a6
--- /dev/null
+++ b/packages/matchbox-panel/matchbox-panel-0.9.2/mb-panel-svn-r1162.diff
@@ -0,0 +1,87 @@
+Index: src/panel.c
+===================================================================
+--- src/panel.c (revision 1161)
++++ src/panel.c (revision 1162)
+@@ -1009,10 +1009,6 @@
+ int xfd;
+ Bool had_rotation = False;
+
+- XSelectInput (panel->dpy, panel->win, StructureNotifyMask|ExposureMask|
+- SubstructureRedirectMask|SubstructureNotifyMask|
+- ButtonPressMask|ButtonReleaseMask|PointerMotionMask|
+- PropertyChangeMask);
+
+ XSelectInput (panel->dpy, panel->win_root,
+ PropertyChangeMask|StructureNotifyMask);
+@@ -1090,6 +1086,7 @@
+ &an_event.xconfigurerequest);
+ break;
+ case ConfigureNotify:
++ DBG("%s(): configureNotify\n", __func__);
+ if (an_event.xconfigure.window == panel->win_root)
+ {
+ had_rotation = True;
+@@ -1110,6 +1107,8 @@
+ int diff = 0;
+ MBPanelApp *papp = NULL;
+
++ DBG("mark %i\n", __LINE__);
++
+ if (panel->ignore_next_config)
+ {
+ panel->ignore_next_config = False;
+@@ -1133,6 +1132,8 @@
+
+ had_rotation = False;
+
++ DBG("mark %i\n", __LINE__);
++
+ if ((PANEL_IS_VERTICAL(panel)
+ && (an_event.xconfigure.width == panel->w)
+ )
+@@ -1142,7 +1143,7 @@
+ /* && (an_event.xconfigure.width == dpy_w)
+ && dpy_w != panel->w */ )
+ )
+- {
++ {
+
+ DBG("%s() flipping ....\n", __func__);
+
+@@ -1178,7 +1179,8 @@
+ papp = panel->apps_start_head;
+ else
+ papp = panel->apps_end_head;
+- } else {
++ } else {
++ DBG("mark %i\n", __LINE__);
+ diff = an_event.xconfigure.width - panel->w;
+ if (an_event.xconfigure.x > panel->x)
+ papp = panel->apps_start_head;
+@@ -1903,6 +1905,11 @@
+ dattr_flags,
+ &dattr);
+
++ XSelectInput (panel->dpy, panel->win, StructureNotifyMask|ExposureMask|
++ SubstructureRedirectMask|SubstructureNotifyMask|
++ ButtonPressMask|ButtonReleaseMask|PointerMotionMask|
++ PropertyChangeMask);
++
+ size_hints.flags = PPosition | PSize | PMinSize;
+ size_hints.x = panel->x;
+ size_hints.y = panel->y;
+Index: ChangeLog
+===================================================================
+--- ChangeLog (revision 1161)
++++ ChangeLog (revision 1162)
+@@ -1,3 +1,10 @@
++2005-05-23 mallum,,, <mallum@openedhand.com>
++
++ * src/panel.c: (panel_main), (panel_init):
++ Select for panel win events much earlier so we dont
++ miss initial configure notifys. Much improved panel
++ in titlebar.
++
+ 2005-04-11 mallum,,, <mallum@openedhand.com>
+
+ * configure.ac:
diff --git a/packages/matchbox-panel/matchbox-panel_0.9.2.bb b/packages/matchbox-panel/matchbox-panel_0.9.2.bb
index c33595a2cd..e2a0eb3da9 100644
--- a/packages/matchbox-panel/matchbox-panel_0.9.2.bb
+++ b/packages/matchbox-panel/matchbox-panel_0.9.2.bb
@@ -1,6 +1,6 @@
include matchbox-panel.inc
-PR="r12"
+PR="r13"
SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar.gz \
file://add_hostap.patch;patch=1 \
file://mb-panel-0.9.2-polling.patch;patch=1 \
@@ -8,6 +8,7 @@ SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar
file://mb-applet-battery-repaint.patch;patch=1 \
file://mb-panel-multi-category-matching.patch;patch=1 \
file://mb-panel-allow-disabling-menu-panel.patch;patch=1 \
+ file://mb-panel-svn-r1162.diff;patch=1;pnum=0 \
file://system-monitor-crash-fix.patch;patch=1 "