aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mediatomb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-14 18:52:52 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-14 18:52:52 +0000
commitd754a329cb5d4711db7a8cd5ac4e32b4d11016c3 (patch)
tree3a5f43e2ef2b150d3bd6bfaf680fe7a3eed530c3 /packages/mediatomb
parent1306df3298cce5763637eb409b0e54c0ac8ac032 (diff)
downloadopenembedded-d754a329cb5d4711db7a8cd5ac4e32b4d11016c3.tar.gz
mediatomb: add 0.11.0
Diffstat (limited to 'packages/mediatomb')
-rw-r--r--packages/mediatomb/files/.mtn2git_empty0
-rw-r--r--packages/mediatomb/files/curl.diff20
-rw-r--r--packages/mediatomb/files/inotify.diff45
-rw-r--r--packages/mediatomb/mediatomb_0.11.0.bb35
4 files changed, 100 insertions, 0 deletions
diff --git a/packages/mediatomb/files/.mtn2git_empty b/packages/mediatomb/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/mediatomb/files/.mtn2git_empty
diff --git a/packages/mediatomb/files/curl.diff b/packages/mediatomb/files/curl.diff
new file mode 100644
index 0000000000..f34c9fc26e
--- /dev/null
+++ b/packages/mediatomb/files/curl.diff
@@ -0,0 +1,20 @@
+--- /tmp/url.cc 2008-09-14 20:40:33.000000000 +0200
++++ mediatomb-0.11.0/src/url.cc 2008-09-14 20:40:49.523198000 +0200
+@@ -24,7 +24,7 @@
+ version 2 along with MediaTomb; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301, USA.
+
+- $Id: url.cc 1714 2008-03-01 17:33:21Z lww $
++ $Id$
+ */
+
+ /// \file url.cc
+@@ -75,7 +75,7 @@
+
+ if (only_header)
+ {
+- curl_easy_setopt(curl_handle, CURLOPT_NOBODY);
++ curl_easy_setopt(curl_handle, CURLOPT_NOBODY, 1);
+ curl_easy_setopt(curl_handle, CURLOPT_HEADERFUNCTION, URL::dl);
+ curl_easy_setopt(curl_handle, CURLOPT_HEADERDATA,
+ (void *)buffer.getPtr());
diff --git a/packages/mediatomb/files/inotify.diff b/packages/mediatomb/files/inotify.diff
new file mode 100644
index 0000000000..8c14fc99cc
--- /dev/null
+++ b/packages/mediatomb/files/inotify.diff
@@ -0,0 +1,45 @@
+--- /tmp/configure.ac 2008-09-14 20:31:20.000000000 +0200
++++ mediatomb-0.11.0/configure.ac 2008-09-14 20:32:23.043198000 +0200
+@@ -2888,41 +2888,7 @@
+ fi
+ fi
+
+-if test "x$INOTIFY_EN" != xno; then
+-dnl The check below was inspired by configure.ac from the inotify tools
+-dnl package, see the "Acknowledgements" section in our README file for more
+-dnl information.
+- CXXFLAGS="$CXXFLAGS $INOTIFY_CXXFLAGS"
+- AC_MSG_CHECKING([whether sys/inotify.h works])
+- AC_RUN_IFELSE(
+- AC_LANG_PROGRAM([[#include <sys/inotify.h>]],
+- [[return (-1 == inotify_init());]]
+- ),
+- [
+- AC_MSG_RESULT([yes]);
+- AC_DEFINE([SYS_INOTIFY_H_OK],[1],[sys/inotify.h exists and works on this system])],
+- [
+- AC_MSG_RESULT([no, using own inotify headers])
+- AC_MSG_CHECKING([whether inotify-nosys.h works on this system])
+- AC_RUN_IFELSE(
+- AC_LANG_PROGRAM([[#include "src/inotify-nosys.h"]],
+- [[return (-1 == inotify_init());]]
+- ),
+- [
+- AC_MSG_RESULT([yes]);
+- INOTIFY_OK=yes
+- ],
+- [
+- if test "x$INOTIFY_EN" != xyes; then
+- AC_MSG_RESULT([no, disabling inotify support])
+- else
+- AC_MSG_RESULT([no])
+- fi
+- INOTIFY_OK=missing
+- ])
+-
+- ])
+-fi
++INOTIFY_OK=yes
+
+ if test "x$INOTIFY_OK" = xyes; then
+ AC_DEFINE([HAVE_INOTIFY], [1], [inotify presence])
diff --git a/packages/mediatomb/mediatomb_0.11.0.bb b/packages/mediatomb/mediatomb_0.11.0.bb
new file mode 100644
index 0000000000..f529a55065
--- /dev/null
+++ b/packages/mediatomb/mediatomb_0.11.0.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "MediaTomb - UPnP AV MediaServer for Linux"
+HOMEPAGE = "http://mediatomb.cc/"
+LICENSE = "GPLv2"
+DEPENDS = "expat ffmpeg sqlite3 libexif js zlib file id3lib"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/mediatomb/mediatomb-${PV}.tar.gz \
+ file://curl.diff;patch=1 \
+ file://inotify.diff;patch=1 \
+ "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-mysql \
+ --disable-rpl-malloc \
+ --enable-sqlite3 \
+ --enable-libjs \
+ --enable-libmagic \
+ --enable-id3lib \
+ --enable-libexif \
+ --enable-db-autocreate \
+ --disable-largefile \
+ --with-sqlite3-h=${STAGING_INCDIR} \
+ --with-sqlite3-libs=${STAGING_LIBDIR} \
+ --with-magic-h=${STAGING_INCDIR} \
+ --with-magic-libs=${STAGING_LIBDIR} \
+ --with-exif-h=${STAGING_INCDIR} \
+ --with-exif-libs=${STAGING_LIBDIR} \
+ --with-zlib-h=${STAGING_INCDIR} \
+ --with-zlib-libs=${STAGING_LIBDIR} \
+ --with-js-h=${STAGING_INCDIR}/js \
+ --with-js-libs=${STAGING_LIBDIR} \
+ --with-id3lib-h=${STAGING_INCDIR} \
+ --with-id3lib-libs=${STAGING_LIBDIR} \
+ ac_cv_header_sys_inotify_h=yes"