aboutsummaryrefslogtreecommitdiffstats
path: root/packages/meta/slugos-native.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-11 07:18:34 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-11 07:18:34 +0000
commitdbd1a76089b2b95b9c57fff7dd7d22c67a93a4e3 (patch)
tree7234291c163f9422814908cff50e2f24f5c6f2ca /packages/meta/slugos-native.bb
parent47bb3895991dd77781dee8274159b032ebbc6b31 (diff)
downloadopenembedded-dbd1a76089b2b95b9c57fff7dd7d22c67a93a4e3.tar.gz
openslug, ucslugc: convert to use slugos.conf
- All the openslug/ucslugc specific .bb files are converted in this - change to use generic 'slugos' files with the required configuration - in openslug.conf or ucslugc.conf. This unifies the image and package - build stuff. Old targets should continue to work as the slugos - .bb files PROVIDE the required targets.
Diffstat (limited to 'packages/meta/slugos-native.bb')
-rw-r--r--packages/meta/slugos-native.bb98
1 files changed, 98 insertions, 0 deletions
diff --git a/packages/meta/slugos-native.bb b/packages/meta/slugos-native.bb
new file mode 100644
index 0000000000..85f0c551f5
--- /dev/null
+++ b/packages/meta/slugos-native.bb
@@ -0,0 +1,98 @@
+# SlugOS native build tools
+#
+# For the most part these are generic tools which should work for any
+# SlugOS variant, however there is a dependency on the libc implementation
+#
+DESCRIPTION = "Packages that are required for the SlugOS native build environment"
+LICENSE = "MIT"
+PR = "r0"
+
+INHIBIT_DEFAULT_DEPS = "1"
+EXCLUDE_FROM_WORLD = "1"
+ALLOW_EMPTY = "1"
+PACKAGES = "${PN}"
+PROVIDES += "${SLUGOS_IMAGENAME}-native"
+
+# Run-time only (RDEPENDS) stuff - no package explicitly provides
+# these targets.
+SLUGOS_NATIVE_RT_prepend_linux = "\
+ glibc-extra-nss glibc-utils \
+ libc6 libc6-dev \
+ "
+SLUGOS_NATIVE_RT_prepend_linux-uclibc = "\
+ uclibc-dev uclibc-utils \
+ "
+SLUGOS_NATIVE_RT = "\
+ binutils-dev binutils-symlinks \
+ cpp cpp-symlinks \
+ g++ g++-symlinks \
+ gcc-symlinks \
+ libg2c-dev \
+ libgdbm3 \
+ libperl5 \
+ libreadline4 libreadline-dev \
+ libstdc++-dev \
+ libthread-db1 \
+ ncurses-dev ncurses-terminfo \
+ perl-modules \
+ python-core python-crypt python-io python-lang python-pickle python-shell python-textutils \
+ "
+
+# Run-time and DEPENDS
+SLUGOS_NATIVE_prepend_linux = "\
+ "
+SLUGOS_NATIVE_prepend_linux-uclibc = "\
+ libiconv \
+ uclibc \
+ "
+SLUGOS_NATIVE = "\
+ autoconf \
+ automake \
+ bash \
+ binutils \
+ bison \
+ bzip2 \
+ coreutils \
+ cvs \
+ diffstat \
+ file \
+ flex \
+ gawk \
+ gcc \
+ gnu-config \
+ gzip \
+ libtool \
+ lrzsz \
+ m4 \
+ make \
+ ncurses \
+ patch \
+ perl \
+ pkgconfig \
+ python-core \
+ quilt \
+ sed \
+ tar \
+ util-linux \
+ wget \
+ ${SLUGOS_NATIVE_THUMB_BROKEN} \
+ "
+
+# If a tool won't build *on thumb libc* add it to the following list.
+# Normally such a tool should be built with the ARM instruction set
+# even on a thumb system (and this can be set in the tool's .bb file),
+# however even this doesn't work for very large programs at present
+# (only monotone!)
+SLUGOS_NATIVE_THUMB_BROKEN = "\
+ monotone-5 \
+ "
+
+SLUGOS_NATIVE_THUMB_BROKEN_thumb = ""
+
+# These things are required but are not valid RDEPENDS
+SLUGOS_NATIVE_DP = "\
+ gdbm \
+ "
+
+RDEPENDS = '${SLUGOS_NATIVE_RT} ${SLUGOS_NATIVE}'
+DEPENDS = '${SLUGOS_NATIVE_DP} ${SLUGOS_NATIVE}'