aboutsummaryrefslogtreecommitdiffstats
path: root/packages/modutils
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-03-05 18:55:05 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-03-05 18:55:05 +0000
commit1a12661ce6d62b2bde8ad52332de462a2f2a48d9 (patch)
tree56ea2b361a4da39b9bd34774a345517672b0ced2 /packages/modutils
parent185035435274560fa0d3a418952b51592d39d285 (diff)
downloadopenembedded-1a12661ce6d62b2bde8ad52332de462a2f2a48d9.tar.gz
packages/modutils/modutils-collateral.bb: Modprobe has changed between 2.4 and 2.6 kernels.
The information in /etc/modutils and /etc/modules.conf is not read under 2.6. 2.6 uses a /etc/modprobe.d directory, and it does not need a "/etc/modprobe.conf" file; it reads all the appropriate *.conf files and compiles the information at boot time. This commit closes bug #808
Diffstat (limited to 'packages/modutils')
-rw-r--r--packages/modutils/modutils-collateral.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/packages/modutils/modutils-collateral.bb b/packages/modutils/modutils-collateral.bb
index 5c502021f9..6d010a5754 100644
--- a/packages/modutils/modutils-collateral.bb
+++ b/packages/modutils/modutils-collateral.bb
@@ -1,6 +1,6 @@
SECTION = "base"
DESCRIPTION = "modutils configuration files"
-PR = "r2"
+PR = "r3"
LICENSE = "MIT"
SRC_URI = "file://modules \
@@ -12,5 +12,10 @@ do_compile () {
do_install () {
install -d ${D}${sysconfdir}
install -m 0644 ${WORKDIR}/modules ${D}${sysconfdir}/modules
- install -m 0644 ${WORKDIR}/modules.conf ${D}${sysconfdir}/modules.conf
+ if [ ${MAJOR_KERNEL_VERSION}=2.6 ]; then
+ install -d ${D}${sysconfdir}/modprobe.d
+ else
+ install -m 0644 ${WORKDIR}/modules.conf ${D}${sysconfdir}/modules.conf
+ fi
+
}