aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mozilla
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-29 20:40:50 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-29 20:40:50 +0000
commit0ef5180119e563ea6e7abd527ee19715d7d9e454 (patch)
tree4aff0d6da4357907e729621123b7a4bfe61d9f27 /packages/mozilla
parent8f8ae4bbb78cd7ae5284600b864da3d4d04c1749 (diff)
downloadopenembedded-0ef5180119e563ea6e7abd527ee19715d7d9e454.tar.gz
firefox 3: add patches from mamona
Diffstat (limited to 'packages/mozilla')
-rw-r--r--packages/mozilla/firefox-3.0/0001-Remove-Werror-from-build.patch45
-rw-r--r--packages/mozilla/firefox-3.0/0002-Fix-security-cross-compile-cpu-detection-error.patch42
-rw-r--r--packages/mozilla/firefox_3.0.bb4
3 files changed, 90 insertions, 1 deletions
diff --git a/packages/mozilla/firefox-3.0/0001-Remove-Werror-from-build.patch b/packages/mozilla/firefox-3.0/0001-Remove-Werror-from-build.patch
new file mode 100644
index 0000000000..8fe1087b4d
--- /dev/null
+++ b/packages/mozilla/firefox-3.0/0001-Remove-Werror-from-build.patch
@@ -0,0 +1,45 @@
+From 48a378ae647cbd6f8466bd0e8dbb04400bb175a8 Mon Sep 17 00:00:00 2001
+From: Eduardo Valentin <eduardo.valentin@openpossa.org>
+Date: Thu, 24 Jul 2008 16:05:09 -0400
+Subject: [PATCH 1/1] Remove -Werror from build
+
+Remove -Werror from build
+
+Signed-off-by: Eduardo Valentin <eduardo.valentin@openpossa.org>
+---
+ configure | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure b/configure
+index a2d84ab..402e70a 100755
+--- a/configure
++++ b/configure
+@@ -5344,7 +5344,7 @@ if test "$GNU_CC"; then
+ # Don't allow undefined symbols in libraries
+ DSO_LDOPTS="$DSO_LDOPTS -Wl,-z,defs"
+ fi
+- WARNINGS_AS_ERRORS='-Werror'
++ WARNINGS_AS_ERRORS=''
+ DSO_CFLAGS=''
+ DSO_PIC_CFLAGS='-fPIC'
+ _MOZ_RTTI_FLAGS_ON=${_COMPILER_PREFIX}-frtti
+@@ -6811,7 +6811,7 @@ EOF
+ IMPLIB='emximp -o'
+ FILTER='emxexp -o'
+ LDFLAGS='-Zmap'
+- WARNINGS_AS_ERRORS='-Werror'
++ WARNINGS_AS_ERRORS=''
+ MOZ_DEBUG_FLAGS="-g -fno-inline"
+ MOZ_OPTIMIZE_FLAGS="-O2"
+ MOZ_OPTIMIZE_LDFLAGS="-s -Zlinker /EXEPACK:2 -Zlinker /PACKCODE -Zlinker /PACKDATA"
+@@ -7048,7 +7048,7 @@ else
+ fi
+ rm -f conftest*
+ fi
+- WARNINGS_AS_ERRORS='-Werror'
++ WARNINGS_AS_ERRORS=''
+ MOZ_OPTIMIZE_FLAGS="-xO4"
+ MKSHLIB='$(CXX) $(CXXFLAGS) $(DSO_PIC_FLAGS) $(DSO_LDOPTS) -h $@ -o $@'
+ MKCSHLIB='$(CC) $(CFLAGS) $(DSO_PIC_FLAGS) -G -z muldefs -h $@ -o $@'
+--
+1.5.4.3
diff --git a/packages/mozilla/firefox-3.0/0002-Fix-security-cross-compile-cpu-detection-error.patch b/packages/mozilla/firefox-3.0/0002-Fix-security-cross-compile-cpu-detection-error.patch
new file mode 100644
index 0000000000..ce8d4d9948
--- /dev/null
+++ b/packages/mozilla/firefox-3.0/0002-Fix-security-cross-compile-cpu-detection-error.patch
@@ -0,0 +1,42 @@
+From 599b26141d493ff19633796ce5e19b00315d3821 Mon Sep 17 00:00:00 2001
+From: Eduardo Valentin <eduardo.valentin@openpossa.org>
+Date: Fri, 25 Jul 2008 11:20:02 -0400
+Subject: [PATCH 1/1] Fix security cross compile cpu detection error
+
+Fix security cross compile cpu detection error.
+Reference to bug 376279.
+
+Signed-off-by: Eduardo Valentin <eduardo.valentin@openpossa.org>
+---
+ security/coreconf/arch.mk | 2 ++
+ security/manager/Makefile.in | 1 +
+ 2 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/security/coreconf/arch.mk b/security/coreconf/arch.mk
+index fba38ff..28da32e 100644
+--- a/security/coreconf/arch.mk
++++ b/security/coreconf/arch.mk
+@@ -66,7 +66,9 @@ OS_ARCH := $(subst /,_,$(shell uname -s))
+ # Attempt to differentiate between sparc and x86 Solaris
+ #
+
++ifndef OE_TEST
+ OS_TEST := $(shell uname -m)
++endif
+ ifeq ($(OS_TEST),i86pc)
+ OS_RELEASE := $(shell uname -r)_$(OS_TEST)
+ else
+diff --git a/security/manager/Makefile.in b/security/manager/Makefile.in
+index 86119f7..86c09ca 100644
+--- a/security/manager/Makefile.in
++++ b/security/manager/Makefile.in
+@@ -240,6 +240,7 @@ DEFAULT_GMAKE_FLAGS += \
+ RC="$(RC) $(RCFLAGS)" \
+ OS_ARCH="$(OS_ARCH)" \
+ CPU_ARCH="$(TARGET_CPU)" \
++ OS_TEST="$(TARGET_CPU)" \
+ $(NULL)
+ SKIP_CHK=1
+ endif
+--
+1.5.4.3
diff --git a/packages/mozilla/firefox_3.0.bb b/packages/mozilla/firefox_3.0.bb
index ac2c86e958..20bbae10d0 100644
--- a/packages/mozilla/firefox_3.0.bb
+++ b/packages/mozilla/firefox_3.0.bb
@@ -1,5 +1,5 @@
DEPENDS += "cairo"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.0/source/firefox-${PV}-source.tar.bz2 \
file://jsautocfg.h \
@@ -12,6 +12,8 @@ SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/3.0/source/fi
file://jemalloc-tls.patch;patch=1 \
http://ftp.mozilla.org/pub/mozilla.org/js/js-1.7.0.tar.gz \
http://ftp.debian.org/debian/pool/main/i/iceweasel/iceweasel_3.0~rc2-2.diff.gz;patch=1 \
+ file://0001-Remove-Werror-from-build.patch;patch=1 \
+ file://0002-Fix-security-cross-compile-cpu-detection-error.patch;patch=1 \
"
S = "${WORKDIR}/mozilla"