aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mozilla
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-02-07 14:01:48 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-07 14:01:48 +0000
commiteb613287c594aba337c66d2c2fac15b10e18d35e (patch)
tree7f53eda6e9034460fa29c7ef6a3f906f52a23ca2 /packages/mozilla
parent3f98a75229a7152df0194e43d7961460d8cc4725 (diff)
downloadopenembedded-eb613287c594aba337c66d2c2fac15b10e18d35e.tar.gz
firefox_1.0.7.bb : add the supporting files I forgot.
Diffstat (limited to 'packages/mozilla')
-rw-r--r--packages/mozilla/firefox-1.0.7/.mtn2git_empty0
-rw-r--r--packages/mozilla/firefox-1.0.7/firefox-cc-fix.patch21
-rw-r--r--packages/mozilla/firefox-1.0.7/jsautocfg.h52
-rw-r--r--packages/mozilla/firefox-1.0.7/mozconfig53
4 files changed, 126 insertions, 0 deletions
diff --git a/packages/mozilla/firefox-1.0.7/.mtn2git_empty b/packages/mozilla/firefox-1.0.7/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/mozilla/firefox-1.0.7/.mtn2git_empty
diff --git a/packages/mozilla/firefox-1.0.7/firefox-cc-fix.patch b/packages/mozilla/firefox-1.0.7/firefox-cc-fix.patch
new file mode 100644
index 0000000000..e2df2a390c
--- /dev/null
+++ b/packages/mozilla/firefox-1.0.7/firefox-cc-fix.patch
@@ -0,0 +1,21 @@
+--- mozilla/js/src/Makefile.in 2004-03-31 09:38:54.000000000 -0700
++++ mozilla.new/js/src/Makefile.in 2004-11-12 16:29:32.856436952 -0700
+@@ -342,16 +342,10 @@
+
+ jsopcode.h jsopcode.c: jsopcode.tbl
+
+-ifeq (,$(CROSS_COMPILE)$(filter-out WINNT,$(OS_ARCH)))
++# OE hack - we copy this in
+ jsautocfg.h:
+ touch $@
+-else
+-jsautocfg.h: jscpucfg$(HOST_BIN_SUFFIX)
+- @rm -f $@ jsautocfg.tmp
+- ./jscpucfg > jsautocfg.tmp
+- mv jsautocfg.tmp $@
+-endif
+-
++
+ # jscpucfg is a strange target
+ # Needs to be built with the host compiler but needs to include
+ # the mdcpucfg for the target so it needs the appropriate target defines
diff --git a/packages/mozilla/firefox-1.0.7/jsautocfg.h b/packages/mozilla/firefox-1.0.7/jsautocfg.h
new file mode 100644
index 0000000000..05f3dad50a
--- /dev/null
+++ b/packages/mozilla/firefox-1.0.7/jsautocfg.h
@@ -0,0 +1,52 @@
+#ifndef js_cpucfg___
+#define js_cpucfg___
+
+/* Lovingly crafted by hand avoiding Mozilla stupidity */
+
+#define IS_LITTLE_ENDIAN 1
+#undef IS_BIG_ENDIAN
+
+#define JS_BYTES_PER_BYTE 1L
+#define JS_BYTES_PER_SHORT 2L
+#define JS_BYTES_PER_INT 4L
+#define JS_BYTES_PER_INT64 8L
+#define JS_BYTES_PER_LONG 4L
+#define JS_BYTES_PER_FLOAT 4L
+#define JS_BYTES_PER_DOUBLE 8L
+#define JS_BYTES_PER_WORD 4L
+#define JS_BYTES_PER_DWORD 8L
+
+#define JS_BITS_PER_BYTE 8L
+#define JS_BITS_PER_SHORT 16L
+#define JS_BITS_PER_INT 32L
+#define JS_BITS_PER_INT64 64L
+#define JS_BITS_PER_LONG 32L
+#define JS_BITS_PER_FLOAT 32L
+#define JS_BITS_PER_DOUBLE 64L
+#define JS_BITS_PER_WORD 32L
+
+#define JS_BITS_PER_BYTE_LOG2 3L
+#define JS_BITS_PER_SHORT_LOG2 4L
+#define JS_BITS_PER_INT_LOG2 5L
+#define JS_BITS_PER_INT64_LOG2 6L
+#define JS_BITS_PER_LONG_LOG2 5L
+#define JS_BITS_PER_FLOAT_LOG2 5L
+#define JS_BITS_PER_DOUBLE_LOG2 6L
+#define JS_BITS_PER_WORD_LOG2 5L
+
+#define JS_ALIGN_OF_SHORT 2L
+#define JS_ALIGN_OF_INT 4L
+#define JS_ALIGN_OF_LONG 4L
+#define JS_ALIGN_OF_INT64 4L
+#define JS_ALIGN_OF_FLOAT 4L
+#define JS_ALIGN_OF_DOUBLE 4L
+#define JS_ALIGN_OF_POINTER 4L
+#define JS_ALIGN_OF_WORD 4L
+
+#define JS_BYTES_PER_WORD_LOG2 2L
+#define JS_BYTES_PER_DWORD_LOG2 3L
+#define JS_WORDS_PER_DWORD_LOG2 2L
+
+#define JS_STACK_GROWTH_DIRECTION (-1)
+
+#endif /* js_cpucfg___ */
diff --git a/packages/mozilla/firefox-1.0.7/mozconfig b/packages/mozilla/firefox-1.0.7/mozconfig
new file mode 100644
index 0000000000..025b396ac7
--- /dev/null
+++ b/packages/mozilla/firefox-1.0.7/mozconfig
@@ -0,0 +1,53 @@
+. $topsrcdir/browser/config/mozconfig
+
+# use GTK+-2 widget set with XFT font rendering
+ac_add_options --enable-default-toolkit=gtk2
+ac_add_options --enable-xft
+ac_add_options --disable-freetype2
+
+# enable minimal profile support
+ac_add_options --disable-profilesharing
+ac_add_options --disable-profilelocking
+ac_add_options --enable-single-profile
+
+ac_add_options --with-system-zlib
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-png
+
+ac_add_options --disable-accessibility
+ac_add_options --disable-composer
+#ac_add_options --enable-plaintext-editor-only
+ac_add_options --disable-mailnews
+ac_add_options --disable-ldap
+#ac_add_options --disable-postscript
+ac_add_options --disable-mathml
+ac_add_options --disable-jsd
+ac_add_options --disable-installer
+ac_add_options --disable-xprint
+ac_add_options --disable-necko-disk-cache
+
+# configure necko to allocate smaller network buffers
+ac_add_options --enable-necko-small-buffers
+
+# disable debug logging and tests
+#ac_add_options --disable-dtd-debug
+ac_add_options --disable-logging
+ac_add_options --disable-debug
+ac_add_options --disable-gtktest
+ac_add_options --disable-tests
+
+# build crypto module (PSM + NSS)
+ac_add_options --enable-crypto
+
+# build minimal set of protocol handlers
+ac_add_options --enable-necko-protocols=http,file,res,jar,ftp,about,viewsource
+
+# build minimal set of image decoders
+ac_add_options --enable-image-decoders=png,gif,jpeg
+
+#ac_add_options --enable-reorder
+#ac_add_options --enable-elf-dynstr-gc
+
+# enable static build
+#ac_add_options --disable-shared
+#ac_add_options --enable-static