aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mt-daapd
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-09 18:23:50 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-09 18:23:50 +0000
commit59e9f82f043c54916fa79f6a0d7de63aeeb655e7 (patch)
tree2da32edfd991bcf7e8538f9e250e5964bd4b4df2 /packages/mt-daapd
parent4bd012399e50314e009bd3ef1c413b9fb7225823 (diff)
downloadopenembedded-59e9f82f043c54916fa79f6a0d7de63aeeb655e7.tar.gz
mt-daapd: fix 0.2.1.1 to work with 'iTunes5'
The fix applies a patch copied from www.mt-daapd.org, the patch is copied because the version at the web site has path names (well, no path names) which don't work with OE. This commit also adds a .bb for mt-daapd_0.2.2, but since that hasn't been released it doesn't work (yet) and is DPed out.
Diffstat (limited to 'packages/mt-daapd')
-rw-r--r--packages/mt-daapd/files/itunes-5-fix.patch45
-rw-r--r--packages/mt-daapd/mt-daapd.inc26
-rw-r--r--packages/mt-daapd/mt-daapd_0.2.1.1.bb31
-rw-r--r--packages/mt-daapd/mt-daapd_0.2.2.bb4
4 files changed, 78 insertions, 28 deletions
diff --git a/packages/mt-daapd/files/itunes-5-fix.patch b/packages/mt-daapd/files/itunes-5-fix.patch
new file mode 100644
index 0000000000..e5f597295f
--- /dev/null
+++ b/packages/mt-daapd/files/itunes-5-fix.patch
@@ -0,0 +1,45 @@
+# WARNING: this is a copy of the same file off www.mt-daapd.org with
+# the path names fixed so that it works in OE
+--- S/src/daap.c.orig 2005-09-07 21:41:41.000000000 -0500
++++ S/src/daap.c 2005-09-07 21:44:25.000000000 -0500
+@@ -770,26 +770,28 @@
+ DAAP_BLOCK *daap_response_server_info(char *name, char *client_version) {
+ DAAP_BLOCK *root;
+ int g=1;
++ int mpro = 2 << 16;
++ int apro = 3 << 16;
+
+ DPRINTF(E_DBG,L_DAAP,"Preparing to send server-info for client ver %s\n",client_version);
+
+ root=daap_add_empty(NULL,"msrv");
+
+ if(root) {
+- g = (int)daap_add_int(root,"mstt",200); /* result */
+- if((!client_version)||(!strcmp(client_version,"3.0"))) {
+- g = g && daap_add_int(root,"mpro",2 << 16); /* dmap proto ? */
+- g = g && daap_add_int(root,"apro",3 << 16); /* daap protocol */
+- } else {
+- if(!strcmp(client_version,"1.0")) {
+- g = g && daap_add_int(root,"mpro",1 << 16); /* dmap proto ? */
+- g = g && daap_add_int(root,"apro",1 << 16); /* daap protocol */
+- } else if(!strcmp(client_version,"2.0")) {
+- g = g && daap_add_int(root,"mpro",1 << 16); /* dmap proto ? */
+- g = g && daap_add_int(root,"apro",2 << 16); /* daap protocol */
+- }
++ if((client_version) && (!strcmp(client_version,"1.0"))) {
++ mpro = 1 << 16;
++ apro = 1 << 16;
++ }
++
++ if((client_version) && (!strcmp(client_version,"2.0"))) {
++ mpro = 1 << 16;
++ apro = 2 << 16;
+ }
+
++ g = (int)daap_add_int(root,"mstt",200); /* result */
++ g = g && daap_add_int(root,"mpro",mpro); /* dmap proto ? */
++ g = g && daap_add_int(root,"apro",apro); /* daap protocol */
++
+ g = g && daap_add_string(root,"minm",name); /* server name */
+
+ #if 0
diff --git a/packages/mt-daapd/mt-daapd.inc b/packages/mt-daapd/mt-daapd.inc
new file mode 100644
index 0000000000..28b0a1e284
--- /dev/null
+++ b/packages/mt-daapd/mt-daapd.inc
@@ -0,0 +1,26 @@
+DESCRIPTION = "multi threaded daap server for POSIX Systems: iTunes Server."
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
+DEPENDS = "zlib gdbm libid3tag"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz \
+ file://${PN}.init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "${PN}"
+INITSCRIPT_PARAMS = "defaults 84"
+
+EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes"
+
+do_install() {
+ autotools_do_install
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0644 ${S}/contrib/${PN}.conf ${D}${sysconfdir}
+ install -m 0755 ${WORKDIR}/${PN}.init ${D}${sysconfdir}/init.d/${PN}
+}
+
+CONFFILES_${PN} = "${sysconfdir}/${PN}.conf"
diff --git a/packages/mt-daapd/mt-daapd_0.2.1.1.bb b/packages/mt-daapd/mt-daapd_0.2.1.1.bb
index 5015624f0d..507c2dd60c 100644
--- a/packages/mt-daapd/mt-daapd_0.2.1.1.bb
+++ b/packages/mt-daapd/mt-daapd_0.2.1.1.bb
@@ -1,28 +1,3 @@
-DESCRIPTION = "multi threaded daap server for POSIX Systems: iTunes Server."
-SECTION = "console/network"
-PRIORITY = "optional"
-MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
-DEPENDS = "zlib gdbm libid3tag"
-PR = "r2"
-LICENSE = "GPL"
-
-SRC_URI = "http://optusnet.dl.sourceforge.net/sourceforge/mt-daapd/mt-daapd-0.2.1.1.tar.gz \
- file://mt-daapd.init"
-S = "${WORKDIR}/mt-daapd-0.2.1.1/"
-
-inherit autotools update-rc.d
-
-INITSCRIPT_NAME = "mt-daapd"
-INITSCRIPT_PARAMS = "defaults 84"
-
-EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes"
-
-do_install() {
- autotools_do_install
- install -d ${D}${sysconfdir}
- install -d ${D}${sysconfdir}/init.d
- install -m 0644 ${S}contrib/mt-daapd.conf ${D}${sysconfdir}
- install -m 0755 ${WORKDIR}/mt-daapd.init ${D}${sysconfdir}/init.d/mt-daapd
-}
-
-CONFFILES_${PN} = "${sysconfdir}/mt-daapd.conf"
+include ${PN}.inc
+PR = "r3"
+SRC_URI += "file://itunes-5-fix.patch;patch=1"
diff --git a/packages/mt-daapd/mt-daapd_0.2.2.bb b/packages/mt-daapd/mt-daapd_0.2.2.bb
new file mode 100644
index 0000000000..cf844cd010
--- /dev/null
+++ b/packages/mt-daapd/mt-daapd_0.2.2.bb
@@ -0,0 +1,4 @@
+include ${PN}.inc
+# This has not been released yet!
+DEFAULT_PREFERENCE = -1
+PR = "r0"