aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mt-daapd
diff options
context:
space:
mode:
authorDerek Young <dyoung@nslu2-linux.org>2005-02-28 20:35:43 +0000
committerDerek Young <dyoung@nslu2-linux.org>2005-02-28 20:35:43 +0000
commit67b3dee160db2d18ca9f9dfd43376182b35774d9 (patch)
treee4deeff2c2f59f796fbc8dd95576f1dbc237e77c /packages/mt-daapd
parenta7254eb5476121971a4f3ecf1f3167df2764d24a (diff)
downloadopenembedded-67b3dee160db2d18ca9f9dfd43376182b35774d9.tar.gz
added startup script support
BKrev: 4223809f43lrifI2vSNeQVk-T65ajg
Diffstat (limited to 'packages/mt-daapd')
-rw-r--r--packages/mt-daapd/files/mt-daapd.init0
-rw-r--r--packages/mt-daapd/mt-daapd_0.2.1.1.bb28
2 files changed, 28 insertions, 0 deletions
diff --git a/packages/mt-daapd/files/mt-daapd.init b/packages/mt-daapd/files/mt-daapd.init
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/mt-daapd/files/mt-daapd.init
diff --git a/packages/mt-daapd/mt-daapd_0.2.1.1.bb b/packages/mt-daapd/mt-daapd_0.2.1.1.bb
index e69de29bb2..5fe3961f7a 100644
--- a/packages/mt-daapd/mt-daapd_0.2.1.1.bb
+++ b/packages/mt-daapd/mt-daapd_0.2.1.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "multi threaded daap server for POSIX Systems: iTunes Server."
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
+DEPENDS = "zlib gdbm libid3tag"
+PR = "r2"
+LICENSE = "GPL"
+
+SRC_URI = "http://optusnet.dl.sourceforge.net/sourceforge/mt-daapd-0.2.1.1.tar.gz \
+ file://mt-daapd.init"
+S = "${WORKDIR}/mt-daapd-0.2.1.1/"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "mt-daapd"
+INITSCRIPT_PARAMS = "defaults 84"
+
+EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes"
+
+do_install() {
+ autotools_do_install
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0644 ${S}contrib/mt-daapd.conf ${D}${sysconfdir}
+ install -m 0755 ${WORKDIR}/mt-daapd.init ${D}${sysconfdir}/init.d/mt-daapd
+}
+
+CONFFILES_${PN} = "${sysconfdir}/mt-daapd.conf"