aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mythtv
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-23 10:03:10 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-23 10:03:10 +0000
commit4e0b4f896da2041dfee51d50b8b429467cc07414 (patch)
tree168c44de231970889b00d4cce7cbeb1810c8f78c /packages/mythtv
parentbad255bddb9e34c9a475f247fefda1829e56390b (diff)
downloadopenembedded-4e0b4f896da2041dfee51d50b8b429467cc07414.tar.gz
mythtv: <= 0.21 are qt3 based >= 0.22 are qt4 based, so move inherits around
* update 0.21 to use the fixes branch
Diffstat (limited to 'packages/mythtv')
-rw-r--r--packages/mythtv/mythtv-0.21/.mtn2git_empty0
-rw-r--r--packages/mythtv/mythtv-0.21/configure.patch183
-rw-r--r--packages/mythtv/mythtv.inc2
-rw-r--r--packages/mythtv/mythtv_0.18.1.bb2
-rw-r--r--packages/mythtv/mythtv_0.20.bb2
-rw-r--r--packages/mythtv/mythtv_0.21.bb53
-rw-r--r--packages/mythtv/mythtv_svn.bb7
7 files changed, 234 insertions, 15 deletions
diff --git a/packages/mythtv/mythtv-0.21/.mtn2git_empty b/packages/mythtv/mythtv-0.21/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/mythtv/mythtv-0.21/.mtn2git_empty
diff --git a/packages/mythtv/mythtv-0.21/configure.patch b/packages/mythtv/mythtv-0.21/configure.patch
new file mode 100644
index 0000000000..3b0b9a313a
--- /dev/null
+++ b/packages/mythtv/mythtv-0.21/configure.patch
@@ -0,0 +1,183 @@
+--- /tmp/configure 2008-06-30 08:40:35.000000000 +0200
++++ mythtv/configure 2008-07-23 09:51:41.000000000 +0200
+@@ -475,12 +475,13 @@
+ }
+
+ check_cmd(){
+- log "$@"
++ echo "Checking $@"
++ log "$@"
+ "$@" >>$logfile 2>&1
+ }
+
+ check_cc(){
+- log check_cc "$@"
++ log check_cc "$@"
+ cat >$TMPC
+ log_file $TMPC
+ check_cmd $cc $CFLAGS $ECFLAGS $OPTFLAGS "$@" -c -o $TMPO $TMPC
+@@ -1115,11 +1116,11 @@
+ fi
+
+ # machine
+-arch=`uname -m`
++disabled cross_compile && arch=`uname -m`
+ arch_raw="$arch"
+ cpu="generic"
+ cpu_override="no"
+-processor=`uname -p 2>/dev/null`
++disabled cross_compile && processor=`uname -p 2>/dev/null`
+ processor_flags=""
+ tune="generic"
+
+@@ -1183,7 +1184,7 @@
+ lamemp3="yes"
+ lirc="yes"
+ mac_bundle="no"
+-opengl="yes"
++opengl="no"
+ v4l="yes"
+ x11="yes"
+ x11_include_path="/usr/X11R6/include"
+@@ -1212,7 +1213,7 @@
+ # build settings
+ SHFLAGS='-shared -Wl,-soname,$@'
+ VHOOKSHFLAGS='$(SHFLAGS)'
+-LDLATEFLAGS='-Wl,-rpath-link,\$(BUILD_ROOT)/libavcodec -Wl,-rpath-link,\$(BUILD_ROOT)/libavformat -Wl,-rpath-link,\$(BUILD_ROOT)/libavutil'
++#LDLATEFLAGS='-Wl,-rpath-link,\$(BUILD_ROOT)/libavcodec -Wl,-rpath-link,\$(BUILD_ROOT)/libavformat -Wl,-rpath-link,\$(BUILD_ROOT)/libavutil'
+ FFSERVERLDFLAGS=-Wl,-E
+ LDCONFIG="ldconfig"
+ LIBPREF="lib"
+@@ -1707,7 +1708,7 @@
+
+ has_library()
+ {
+- if test -f /etc/ld.so.conf ; then
++ if test -f /etc/ld.so.conf && disabled cross_compile ; then
+ LIBPATHS=`cat /etc/ld.so.conf | grep -v "#" | grep -v "include"`
+ else
+ LIBPATHS=''
+@@ -1718,7 +1719,7 @@
+ LIBPATHS="$LIBPATHS `echo $DYLD_LIBRARY_PATH | sed s/':'/' '/g` "
+
+ # recurse down just one level, should be enough in most cases
+- if test -f /etc/ld.so.conf ; then
++ if test -f /etc/ld.so.conf && disabled cross_compile ; then
+ INCL=`cat /etc/ld.so.conf | grep -v "#" | grep "^include"`
+ SRCH=`echo "$INCL" | sed '{ s/^include \//\//; s/^include /\/etc\//}'`
+ for x in $SRCH ; do
+@@ -1727,9 +1728,9 @@
+ done
+ fi
+
+- LIBPATHS="`echo $LIBPATHS /$libdir_name /usr/$libdir_name /usr/local/$libdir_name /usr/X11R6/$libdir_name | sed s/'\/ '/' '/g` "
++ enabled cross_compile || LIBPATHS="`echo $LIBPATHS /$libdir_name /usr/$libdir_name /usr/local/$libdir_name /usr/X11R6/$libdir_name | sed s/'\/ '/' '/g` "
+
+- HAS_IT="no"
++ HAS_IT="yes"
+ for LIBPATH in $LIBPATHS ; do
+ if test x`ls $LIBPATH/$1* 2> /dev/null | head -n 1` != x"" ; then
+ echo "$1 IS at $LIBPATH"
+@@ -1745,17 +1746,18 @@
+
+ has_header()
+ {
+- HPATHS="/usr/local/include /usr/include /usr/include/g++-v3 /usr/X11R6/include"
++ enabled cross_compile || HPATHS="/usr/local/include /usr/include /usr/include/g++-v3 /usr/X11R6/include"
+ INCL=`echo $DYLD_LIBRARY_PATH $LD_LIBRARY_PATH | sed s/':'/' '/g`
+ HPATHS="$HPATHS "$(echo $INCL | sed "s/$libdir_name/include/g")
+
+- HAS_IT="no"
++ HAS_IT="yes"
+ for HPATH in $HPATHS ; do
+ if test x`ls $HPATH/$1* 2> /dev/null | head -n 1` != x"" ; then
+ HAS_IT="yes"
+ fi
+ done
+- expr $HAS_IT : "yes" > /dev/null
++ echo "$1: $HAS_IT"
++ expr $HAS_IT : "yes" > /dev/null
+ }
+
+ append CCONFIG "$compile_type"
+@@ -1861,13 +1863,15 @@
+ if test x"$cmov" = x"default"; then
+ disable cmov
+ if enabled cpu_override; then
+- is_x86_cmov_cpu "$cpu" && enable cmov
++ disabled cross_compile && is_x86_cmov_cpu "$cpu" && enable cmov
+ disabled cmov || is_x86_slow_cmov_cpu "$cpu" || enable fast_cmov
+ elif expr "$processor_flags" : ".*cmov" > /dev/null ; then
+- enable cmov
++ disabled cross_compile && enable cmov
+ fi
+ fi
+
++enabled cross_compile && disable cmov
++
+ # use different default ARCHFLAGS for CPU missing cmov (Via C3 ...)
+ if test x"$arch" = x"x86_32" && disabled cmov && disabled cpu_override; then
+ ARCHFLAGS="-march=i586"
+@@ -2239,7 +2243,7 @@
+ EOF
+
+ if $cc $CFLAGS $ECFLAGS -o $TMPE $TMPC 2>/dev/null ; then
+-$TMPE && cpuclipspositive="yes"
++enabled cross_compile || $TMPE && cpuclipspositive="yes"
+ fi
+
+ # test negative wrap
+@@ -2254,7 +2258,7 @@
+ EOF
+
+ if $cc $CFLAGS $ECFLAGS -o $TMPE $TMPC 2>/dev/null ; then
+-$TMPE && cpuclipsnegative="yes"
++enabled cross_compile || $TMPE && cpuclipsnegative="yes"
+ fi
+
+ # test for distcc
+@@ -2607,33 +2611,9 @@
+ check_ldflags -Wl,--warn-common
+ check_ldflags $LDLATEFLAGS
+
+-# GCC version
+-cat > $TMPC << EOF
+-int main(int argc, char **argv)
+-{
+- int ret = 0;
+- if (argc == 1)
+- {
+- #if defined(__GNUC__)
+- ret = __GNUC__;
+- #endif
+- }
+- else
+- {
+- #if defined(__GNUC_MINOR__)
+- ret = __GNUC_MINOR__;
+- #endif
+- }
+- return ret;
+-}
+-EOF
+-
+-if $cc $CFLAGS $TMPC -o $TMPE ; then
+- $TMPE
+- GCC_MAJOR=$?
+- $TMPE "minor"
+- GCC_MINOR=$?
+-fi
++gcc_version=$($cc -v 2>&1 | grep version | cut -s -d' ' -f 3)
++GCC_MAJOR=$(echo ${gcc_version} | cut -s -d'.' -f1)
++GCC_MINOR=$(echo ${gcc_version} | cut -s -d'.' -f2)
+
+ if enabled symbol_visibility; then
+ if test x"$GCC_MAJOR" = x"4" ; then
+@@ -2727,6 +2707,7 @@
+
+ check_header GL/gl.h
+ has_library libGL || has_library libopengl32 || disable opengl
++enabled cross_compile && disable opengl
+
+ VENDOR_XVMC_LIBS=""
+ check_header X11/extensions/XvMClib.h
diff --git a/packages/mythtv/mythtv.inc b/packages/mythtv/mythtv.inc
index 9b7a0a768e..8355e0f1a1 100644
--- a/packages/mythtv/mythtv.inc
+++ b/packages/mythtv/mythtv.inc
@@ -7,8 +7,6 @@ DEPENDS = "jack alsa-lib lame libxinerama libxv libxxf86vm libxvmc lirc"
SRC_URI = "http://www.mythtv.org/mc/mythtv-${PV}.tar.bz2"
-inherit qmake2 qt4x11
-
QMAKE_PROFILES = "mythtv.pro"
diff --git a/packages/mythtv/mythtv_0.18.1.bb b/packages/mythtv/mythtv_0.18.1.bb
index 1602ce0e42..fd2c351845 100644
--- a/packages/mythtv/mythtv_0.18.1.bb
+++ b/packages/mythtv/mythtv_0.18.1.bb
@@ -1,5 +1,7 @@
require mythtv.inc
+inherit qmake2 qt3x11
+
PR = "r1"
SRC_URI += "file://msmpeg-underscore-pic.patch;patch=1 \
diff --git a/packages/mythtv/mythtv_0.20.bb b/packages/mythtv/mythtv_0.20.bb
index c9e2fdc431..2ebebd3012 100644
--- a/packages/mythtv/mythtv_0.20.bb
+++ b/packages/mythtv/mythtv_0.20.bb
@@ -1,5 +1,7 @@
require mythtv.inc
+inherit qmake2 qt3x11
+
DEPENDS += "openchrome"
PR = "r0"
diff --git a/packages/mythtv/mythtv_0.21.bb b/packages/mythtv/mythtv_0.21.bb
index a33c446813..cdb26c2c31 100644
--- a/packages/mythtv/mythtv_0.21.bb
+++ b/packages/mythtv/mythtv_0.21.bb
@@ -1,23 +1,29 @@
require mythtv.inc
-PR = "r0"
+inherit qmake qt3x11
-#SRC_URI += "file://configure.patch;patch=1 \
-# file://libmyth-libdir.patch;patch=1"
+PR = "${SRCREV}+r0"
+REALPV = "0.21"
-# Seen on the mythtv web page:
-# http://www.mythtv.org/mc/fix-mythweb-in-0.20.diff;patch=1
+SRCREV = "17789"
+SRC_URI = "svn://svn.mythtv.org/svn/branches/release-0-21-fixes;module=mythtv;proto=http"
+
+SRC_URI += "file://configure.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/mythtv"
QMAKE_PROFILES = "mythtv.pro"
-mythlibs = "mythavutil mythavcodec mythavformat myth mythtv mythui mythfreemheg mythupnp mythlivemedia"
+mythlibs = "mythdb mythavutil mythavcodec mythavformat myth mythtv mythui mythfreemheg mythupnp mythlivemedia"
PACKAGES =+ "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-data"
+FILES_${PN}-dbg += "${libdir}/mythtv/filters/.debug"
FILES_mythtv-backend = "${bindir}/mythbackend ${bindir}/mythcommflag ${bindir}/mythfilldatabase ${bindir}/mythtranscode"
FILES_mythtv-frontend = "${bindir}/mythfrontend ${datadir}/mythtv/i18n/mythfrontend_* ${datadir}/mythtv/*.ttf"
RDEPENDS_mythtv-frontend = "qt-x11-plugins-sqldrivers qt-x11-plugins-imageformats"
-FILES_mythtv-bin = "${bindir}"
-FILES_mythtv-filters = "${libdir}/mythtv/filters"
+FILES_mythtv-bin = "${bindir}/*"
+FILES_mythtv-filters = "${libdir}/mythtv/filters/*"
FILES_mythtv-data = "${datadir}"
RDEPENDS_${PN} = "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-data"
ALLOW_EMPTY_${PN} = "1"
@@ -28,7 +34,7 @@ python __anonymous () {
import bb
mythlibs = bb.data.getVar('mythlibs', d).split()
- pv = bb.data.expand(bb.data.getVar("PV", d), d)
+ pv = bb.data.expand(bb.data.getVar("REALPV", d), d)
for m in mythlibs:
bb.data.setVar("FILES_lib%s%s" % (m, pv), "${libdir}/lib%s-%s.so.*" % (m, pv), d)
@@ -38,22 +44,49 @@ python __anonymous () {
bb.data.setVar("PACKAGES", packages, d)
}
+
+EXTRA_OECONF_armv5te = " --enable-armv5te "
+EXTRA_OECONF_armv6 = " --enable-armv6 "
+EXTRA_OECONF_armv7a = --enable-armv6"
+
+#build with support for the iwmmxt instruction and pxa270fb overlay support (pxa270 and up)
+#not every iwmmxt machine has the lcd connected to pxafb, but building the module doesn't hurt
+MY_ARCH := "${PACKAGE_ARCH}"
+PACKAGE_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', 'iwmmxt', '${MY_ARCH}',d)}"
+
+MY_TARGET_CC_ARCH := "${TARGET_CC_ARCH}"
+TARGET_CC_ARCH = "${@base_contains('MACHINE_FEATURES', 'iwmmxt', '-march=iwmmxt -mtune=iwmmxt', '${MY_TARGET_CC_ARCH}',d)}"
+
+EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', '--enable-pxa --enable-iwmmxt', '',d)} "
+
+
do_configure_prepend() {
# it's not autotools anyway, so we call ./configure directly
find . -name "Makefile"|xargs rm -f
+
./configure --prefix=/usr \
--mandir=/usr/man \
--cpu=${MYTHTV_ARCH} \
+ --arch=${MYTHTV_ARCH} \
--disable-altivec \
+ --disable-opengl-video \
+ --disable-strip \
--enable-v4l \
--enable-audio-oss \
--enable-proc-opt \
--enable-dvb \
+ --enable-libmp3lame \
--cross-compile \
- --dvb-path=${STAGING_INCDIR}
+ --dvb-path=${STAGING_INCDIR} \
+ --with-bindings= \
+ ${EXTRA_OECONF}
sed 's!PREFIX =.*!PREFIX = ${prefix}!;/INCLUDEPATH += $${PREFIX}\/include/d' < settings.pro > settings.pro.new
mv settings.pro.new settings.pro
+ for pro in ${S}/*/*pro ${S}/*/*/*pro ${S}/*/*/*/*pro ; do
+ sed -i -e s:opengl::g $pro
+ done
+ sed -i /.SUBDIR/d ${S}/bindings/*pro
}
python populate_packages_prepend () {
diff --git a/packages/mythtv/mythtv_svn.bb b/packages/mythtv/mythtv_svn.bb
index cb22a36f58..09cc1ec947 100644
--- a/packages/mythtv/mythtv_svn.bb
+++ b/packages/mythtv/mythtv_svn.bb
@@ -1,9 +1,11 @@
require mythtv.inc
+inherit qmake2 qt4x11
+
DEFAULT_PREFERENCE = "-1"
-PV = "0.21+svnr${SRCREV}"
-PR = "r1"
+PV = "0.21+0.22rc+svnr${SRCREV}"
+PR = "r2"
REALPV = "0.22"
SRCREV = "17892"
@@ -22,7 +24,6 @@ PACKAGES =+ "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-dat
FILES_${PN}-dbg += "${libdir}/mythtv/filters/.debug"
FILES_mythtv-backend = "${bindir}/mythbackend ${bindir}/mythcommflag ${bindir}/mythfilldatabase ${bindir}/mythtranscode"
FILES_mythtv-frontend = "${bindir}/mythfrontend ${datadir}/mythtv/i18n/mythfrontend_* ${datadir}/mythtv/*.ttf"
-RDEPENDS_mythtv-frontend = "qt-x11-plugins-sqldrivers qt-x11-plugins-imageformats"
FILES_mythtv-bin = "${bindir}/*"
FILES_mythtv-filters = "${libdir}/mythtv/filters/*"
FILES_mythtv-data = "${datadir}"