aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mythtv
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-22 16:43:15 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-22 16:43:15 +0000
commitf2e17bbeca4ef97ef626880d81a15a2bcdebeb21 (patch)
tree44728c21a2ca1c4f9d87d0851a234c623ebbb8b2 /packages/mythtv
parent845723e8863b2206fc84d05b63d6e920eb2b4b2d (diff)
downloadopenembedded-f2e17bbeca4ef97ef626880d81a15a2bcdebeb21.tar.gz
mythtv: disable opengl since qt4 doesn't build QtOpenGL
Diffstat (limited to 'packages/mythtv')
-rw-r--r--packages/mythtv/mythtv/configure.patch19
-rw-r--r--packages/mythtv/mythtv/ifdef-qt.diff13
-rw-r--r--packages/mythtv/mythtv_svn.bb9
3 files changed, 39 insertions, 2 deletions
diff --git a/packages/mythtv/mythtv/configure.patch b/packages/mythtv/mythtv/configure.patch
index 16f5076880..c95a785d6c 100644
--- a/packages/mythtv/mythtv/configure.patch
+++ b/packages/mythtv/mythtv/configure.patch
@@ -1,5 +1,5 @@
--- /tmp/configure 2008-07-22 10:27:56.000000000 +0200
-+++ mythtv/configure 2008-07-22 12:50:43.000000000 +0200
++++ mythtv/configure 2008-07-22 17:53:20.000000000 +0200
@@ -476,12 +476,13 @@
}
@@ -30,6 +30,15 @@
processor_flags=""
tune="generic"
+@@ -1185,7 +1186,7 @@
+ lamemp3="yes"
+ lirc="yes"
+ mac_bundle="no"
+-opengl="yes"
++opengl="no"
+ v4l="yes"
+ x11="yes"
+ x11_include_path="/usr/X11R6/include"
@@ -1214,7 +1215,7 @@
# build settings
SHFLAGS='-shared -Wl,-soname,$@'
@@ -129,3 +138,11 @@
fi
# test for distcc
+@@ -2718,6 +2723,7 @@
+
+ check_header GL/gl.h
+ has_library libGL || has_library libopengl32 || disable opengl
++enabled cross_compile && disable opengl
+
+ VENDOR_XVMC_LIBS=""
+ check_header X11/extensions/XvMClib.h
diff --git a/packages/mythtv/mythtv/ifdef-qt.diff b/packages/mythtv/mythtv/ifdef-qt.diff
new file mode 100644
index 0000000000..bdefee11df
--- /dev/null
+++ b/packages/mythtv/mythtv/ifdef-qt.diff
@@ -0,0 +1,13 @@
+--- /tmp/mythmainwindow.cpp 2008-07-22 18:19:06.000000000 +0200
++++ mythtv/libs/libmythui/mythmainwindow.cpp 2008-07-22 18:19:26.000000000 +0200
+@@ -4,7 +4,10 @@
+
+ #include <algorithm>
+
++#ifdef USE_OPENGL_PAINTER
+ #include <QGLWidget>
++endif
++
+ #include <QApplication>
+ #include <QTimer>
+ #include <QDesktopWidget>
diff --git a/packages/mythtv/mythtv_svn.bb b/packages/mythtv/mythtv_svn.bb
index 24a8b3d220..861f4df07b 100644
--- a/packages/mythtv/mythtv_svn.bb
+++ b/packages/mythtv/mythtv_svn.bb
@@ -5,10 +5,11 @@ DEFAULT_PREFERENCE = "-1"
PV = "0.21+svnr${SRCREV}"
PR = "r0"
-SRCREV = "17880"
+SRCREV = "17891"
SRC_URI = "svn://svn.mythtv.org/svn/trunk;module=mythtv;proto=http"
SRC_URI += "file://configure.patch;patch=1 \
+ file://ifdef-qt.diff;patch=1 \
"
S = "${WORKDIR}/mythtv"
@@ -62,11 +63,13 @@ EXTRA_OECONF_append = " ${@base_contains('MACHINE_FEATURES', 'iwmmxt', '--enable
do_configure_prepend() {
# it's not autotools anyway, so we call ./configure directly
find . -name "Makefile"|xargs rm -f
+
./configure --prefix=/usr \
--mandir=/usr/man \
--cpu=${MYTHTV_ARCH} \
--arch=${MYTHTV_ARCH} \
--disable-altivec \
+ --disable-opengl-video \
--disable-strip \
--enable-v4l \
--enable-audio-oss \
@@ -79,6 +82,10 @@ do_configure_prepend() {
sed 's!PREFIX =.*!PREFIX = ${prefix}!;/INCLUDEPATH += $${PREFIX}\/include/d' < settings.pro > settings.pro.new
mv settings.pro.new settings.pro
+ for pro in ${S}/libs/*pro ${S}/libs/*/*pro; do
+ sed -i -e s:opengl::g $pro
+ done
+
}
python populate_packages_prepend () {